Junos OS

Expand all | Collapse all

Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

Jump to Best Answer
  • 1.  Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-10-2019 16:40

    Hi, 


    We have recently deployed an MX204 + EX4300 Fusion Provider Edge Setup, 

     

    We then have a AE Bundle from that EX4300 to another EX4300 which hosts some firewall's for customers etc. 

     

    However, when we configure a new logical interface on the Fusion Provider Edge AE Bundle, it drops all traffic on that AE Bundle and Flaps the interface. 

     

    I assume this is not expected behaviour, can someone advise if I'm missing something very obvious on the configuration to cause this or if I should just log with JCARE.

     

    Thanks


    Mike



  • 2.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-10-2019 18:21
    Hi Mike, Could you please let me know what Junos release are you using and what SNOS release is being used on the satellite. Also could you please provide the config of the ae bundle.


  • 3.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-11-2019 00:20

    Hi All, 

     

    Thanks for your reponses, 

     

    Model: mx204
    Junos: 18.1R2.6

     

    Satellite Version is: 3.4R1.0

     

    Config is here: 

     

    description INFRA::UPLINK::LACP::EX4200STACK;
    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    aggregated-ether-options {
    minimum-links 1;
    lacp {
    active;
    periodic fast;
    }
    }
    unit 19 {
    vlan-id 19;
    family inet {
    mtu 1500;
    address 172.31.2.233/30;
    }
    }
    unit 328 {
    encapsulation vlan-ccc;
    vlan-id 328;
    family ccc;
    }
    unit 330 {
    encapsulation vlan-ccc;
    vlan-id 330;
    family ccc;
    }
    unit 334 {
    encapsulation vlan-ccc;
    vlan-id 334;
    family ccc;
    }
    unit 930 {
    encapsulation vlan-ccc;
    vlan-id 930;
    family ccc;
    }
    unit 931 {
    encapsulation vlan-ccc;
    vlan-id 931;
    family ccc;
    }
    unit 932 {
    encapsulation vlan-ccc;
    vlan-id 932;
    family ccc;
    }
    unit 933 {
    encapsulation vlan-ccc;
    vlan-id 933;
    family ccc;
    }
    unit 937 {
    encapsulation vlan-ccc;
    vlan-id 937;
    family ccc;
    }
    unit 939 {
    encapsulation vlan-ccc;
    vlan-id 939;
    family ccc;
    }
    unit 940 {
    encapsulation vlan-ccc;
    vlan-id 940;
    family ccc;
    }
    unit 961 {
    vlan-id 961;
    family inet {
    address 172.31.4.9/29;
    }
    }
    unit 1000 {
    encapsulation vlan-vpls;
    vlan-id 1000;
    family vpls;
    }
    unit 1001 {
    vlan-id 1001;
    family inet {
    mtu 1500;
    address 37.48.x.x/30;
    }
    }
    unit 2002 {
    encapsulation vlan-vpls;
    vlan-id 2002;
    family vpls;
    }
    unit 2003 {
    encapsulation vlan-vpls;
    vlan-id 2003;
    family vpls;
    }
    unit 2005 {
    encapsulation vlan-ccc;
    vlan-id 2005;
    family ccc;
    }
    unit 2006 {
    vlan-id 2006;
    family inet {
    mtu 1500;
    address 172.31.1.238/30;
    }
    }
    unit 2007 {
    vlan-id 2007;
    family inet {
    mtu 1500;
    address 37.48.x.z/30;
    }
    }
    unit 2009 {
    vlan-id 2009;
    family inet {
    mtu 1500;
    address 37.48.x.y/29;
    }
    }
    unit 2011 {
    vlan-id 2011;
    family inet {
    mtu 1500;
    address 172.31.2.238/30;
    }
    }
    unit 2012 {
    vlan-id 2012;
    family inet {
    mtu 1500;
    address 172.31.3.238/30;
    }
    }
    unit 2013 {
    vlan-id 2013;
    family inet {
    address 172.31.4.57/29;
    }
    }
    unit 2014 {
    vlan-id 2014;
    family inet {
    address 172.31.6.233/30;
    }
    }
    unit 2026 {
    encapsulation vlan-ccc;
    vlan-id 2026;
    family ccc;
    }
    unit 2027 {
    encapsulation vlan-ccc;
    vlan-id 2027;
    family ccc;
    }
    unit 2028 {
    encapsulation vlan-ccc;
    vlan-id 2028;
    family ccc;
    }
    unit 2050 {
    encapsulation vlan-vpls;
    vlan-id 2050;
    family vpls;
    }
    unit 2052 {
    encapsulation vlan-vpls;
    vlan-id 2052;
    family vpls;
    }
    unit 2053 {
    encapsulation vlan-ccc;
    vlan-id 2053;
    family ccc;
    }
    unit 2054 {
    encapsulation vlan-ccc;
    vlan-id 2054;
    family ccc;
    }
    unit 2070 {
    encapsulation vlan-vpls;
    vlan-id 2070;
    family vpls;
    }
    unit 2071 {
    encapsulation vlan-vpls;
    vlan-id 2071;
    family vpls;
    }
    unit 2072 {
    encapsulation vlan-ccc;
    vlan-id 2072;
    family ccc;
    }
    unit 4002 {
    encapsulation vlan-ccc;
    vlan-id 4002;
    family ccc;
    }
    unit 4007 {
    vlan-id 4007;
    family inet {
    address 37.48.y.y/30;
    }
    family inet6 {
    address 2a05:x::y/127;
    }
    }
    unit 4090 {
    encapsulation vlan-ccc;
    vlan-id 4090;
    family ccc;
    }



  • 4.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-11-2019 00:36
    Hi Mike,

    Also could you please provide the configs for the child links of the ae0 ?


    Regards,
    Jibu


  • 5.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-11-2019 10:31

    Hi, 

     

    Here you go: 

     

    ge-101/0/30 {
    description INFRA::EX4200-SWITCH-STACK-1-OF-2::ge-0-1-1;
    ether-options {
    802.3ad ae0;
    }
    }
    ge-101/0/31 {
    description INFRA::EX4200-SWITCH-STACK-2-OF-2::ge-1-1-1;
    ether-options {
    802.3ad ae0;
    }
    }

     

    Thanks


    Mike



  • 6.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation
    Best Answer

    Posted 07-11-2019 14:28
    Hi Mike,

    In the below config can you change the ether-option to gigether-options . The below PR states that this is the right way to configure ae bundle on an extended port.

    https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1424151



    ge-101/0/30 {
    description INFRA::EX4200-SWITCH-STACK-1-OF-2::ge-0-1-1;
    ether-options {
    802.3ad ae0;
    }
    }
    ge-101/0/31 {
    description INFRA::EX4200-SWITCH-STACK-2-OF-2::ge-1-1-1;
    ether-options {
    802.3ad ae0;
    }
    }

    ////

    ###
    set interfaces ge-100/0/30 gigether-options 802.3ad ae0
    set interfaces ge-100/0/31 gigether-options 802.3ad ae0


    Pls try this and let me know if it fixes it.

    Regards,
    Jibu


  • 7.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-12-2019 15:51

    Absolutely hit the nail on the head, changed it over and it's all good, thanks so much!


    @jibut wrote:
    Hi Mike,

    In the below config can you change the ether-option to gigether-options . The below PR states that this is the right way to configure ae bundle on an extended port.

    https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1424151



    ge-101/0/30 {
    description INFRA::EX4200-SWITCH-STACK-1-OF-2::ge-0-1-1;
    ether-options {
    802.3ad ae0;
    }
    }
    ge-101/0/31 {
    description INFRA::EX4200-SWITCH-STACK-2-OF-2::ge-1-1-1;
    ether-options {
    802.3ad ae0;
    }
    }

    ////

    ###
    set interfaces ge-100/0/30 gigether-options 802.3ad ae0
    set interfaces ge-100/0/31 gigether-options 802.3ad ae0


    Pls try this and let me know if it fixes it.

    Regards,
    Jibu

     



  • 8.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-12-2019 21:52
    Great newz !! Thanks for the confirmation .

    Regards,
    Jibu


  • 9.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

     
    Posted 07-10-2019 18:24

    Hi,

     

    Can you please paste the complete configuration on the ae and change that you have done? Are you saying you have aeX which works fine, and when adding aeX.Y, it started to flap ae and drop traffic? If that's the case, looks to me some kind of traffic hitting the new unit congesting LACP PDU, maybe due to a layer 2 loop.

    Not sure if fusion plays a role here. I assume if the AE is on MX204 itself, same issue could happen.

    What you can do is to perform packet capture on the new aeX.Y  by "monitor traffic interface aeX.Y no-resolve detail" and see if anything abnormal coming from that unit.

     

     



  • 10.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-11-2019 00:23

    Hi Mengzhe, 

     

    Close. 

     

    We have AE0 and AE0.1 AE0.2 AE0.3 ETC ETC, 

     

    Every time we add a new AE0.X it drops the bundle for a few seconds before coming back on and staying stable. 

     

    This AE Bundle goes into the fusion switch and both ports run at 1G,

     

    So I don't think it's a Loop, 

     

    Also we are purely migrating the configuration from our MX5 which goes into the same EX4200 Switch with a LAG and that doesnt exhibit the same behaviour.

     

    Thanks



  • 11.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

     
    Posted 07-10-2019 20:07

    It might work better if you have the latest JTAC recommended release if that's an option:

    https://kb.juniper.net/InfoCenter/index?page=content&id=KB21476

     

    Some issues on "flexible-ethernet-services" are fixed in the newer versions, for example:

    https://prsearch.juniper.net/InfoCenter/index?page=prcontent&id=PR1337311

     

    Hope this helps.

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).



  • 12.  RE: Junos Fusion Provider Edge - LACP Bounce on Logical Interface Creation

    Posted 07-11-2019 00:25

    Thank you, we're running a newer version because we need some of the feature set. 

     

    Otherwise I'd change and use the recommended version.

     

    Thanks