Junos OS

 View Only
last person joined: 6 days ago 

Ask questions and share experiences about Junos OS.
  • 1.  IPoE Route Source Address

    Posted 07-03-2018 09:31

    Hi guys,

    I'm testing IPoE, until then working very well.

    But now I need to redirect the traffic of subscribers that contains private ip.

    the pool is allocated by BRAS.
    I would like all subscribers with ip 10.100.100.0/24 the next hop would be router 2.

    I made a small diagram.

    I'm really grateful for the help

    Diagrama2.png

     

    my configuration file

     

    version 17.4R1.16;
    dynamic-profiles {
        VLAN-IPoE {
            routing-instances {
                "$junos-routing-instance" {
                    interface "$junos-interface-name" {
                        any;
                    }
                }
            }
            interfaces {
                "$junos-interface-ifd-name" {
                    unit "$junos-interface-unit" {
                        actual-transit-statistics;
                        demux-source [ inet inet6 ];
                        proxy-arp;
                        vlan-id "$junos-vlan-id";
                        demux-options {
                            underlying-interface "$junos-underlying-interface";
                        }
                        family inet {
                            unnumbered-address "$junos-loopback-interface";
                        }
                        family inet6 {
                            unnumbered-address "$junos-loopback-interface";
                        }
                    }
                }
            }
            protocols {
                router-advertisement {
                    interface "$junos-interface-name" {
                        max-advertisement-interval 900;
                        min-advertisement-interval 300;
                        managed-configuration;
                        other-stateful-configuration;
                    }
                }
            }
        }
        CLIENTS-IPoE {
            interfaces {
                demux0 {
                    unit "$junos-interface-unit" {
                        proxy-arp;
                        family inet {
                            filter {
                                input "$junos-input-filter";
                                output "$junos-output-filter";
                            }
                            unnumbered-address lo0.0 preferred-source-address 200.200.200.1;
                        }
                        family inet6 {
                            unnumbered-address lo0.0 preferred-source-address 2804:aaaa:fb01:0000::1111;
                        }
                    }
                }
            }
        }
    }
    
    interfaces {
        ge-1/0/0 {
            description CLIENTS;
            flexible-vlan-tagging;
            auto-configure {
                vlan-ranges {
                    dynamic-profile VLAN-IPoE {
                        accept any;
                        ranges {
                            500-600;
                        }
                    }
                }
                remove-when-no-subscribers;
            }
            encapsulation flexible-ethernet-services;
        }
    
    firewall {
        family inet {
            filter Police-20M {
                interface-specific;
                term default {
                    then {
                        policer Police-20M;
                        accept;
                    }
                }
            }
    	}
    policer Police-20M {
    if-exceeding {
    bandwidth-limit 20m;
    burst-size-limit 20m;
    }
    then discard;
    }
    }

     

     

     



  • 2.  RE: IPoE Route Source Address
    Best Answer

     
    Posted 07-03-2018 18:27

    Hi,

     

    You can try below option. Attach the firewall filter on subscriber IFL.

     

    set firewall family inet filter test term 1 from source-address X.X.X.X
    set firewall family inet filter test term 1 then routing-instance redirect

    set routing-instances redirect instance-type forwarding
    set routing-instances redirect routing-options static route 0.0.0.0/0 next-hop Y.Y.Y.Y

     

    set routing-options interface-routes rib-group inet nh
    set routing-options rib-groups nh import-rib inet.0
    set routing-options rib-groups nh mport-rib redirect.inet.0

     

    Regards,

    Rahul



  • 3.  RE: IPoE Route Source Address

    Posted 07-04-2018 05:30

    worked perfectly, thank you very much