Junos OS

Expand all | Collapse all

SNMP issue...

Jump to Best Answer
  • 1.  SNMP issue...

    Posted 02-20-2009 10:20

    (.......I posted this in the wrong forum... I'm reposting it here....)

     

    ###########

    [edit snmp]
    juniper@BD-Bottom-M120# show

    community testcommunity {
        authorization read-only;
        routing-instance RDI;
    }
    routing-instance-access;
    traceoptions {
        file snmp;
        flag all;
    }
    ############

     

     

     

     

     

    ##############

    Feb 20 17:44:54 snmpd[4d88b0c2] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    Feb 20 17:44:54 snmpd[4d88b0c2] >>> Get-Next-Request
    Feb 20 17:44:54 snmpd[4d88b0c2] >>>  Source:      10.254.0.33
    Feb 20 17:44:54 snmpd[4d88b0c2] >>>  Destination: 10.254.23.2
    Feb 20 17:44:54 snmpd[4d88b0c2] >>>  Version:     SNMPv2
    Feb 20 17:44:54 snmpd[4d88b0c2] >>>  Request_id:  0x4d88b0c2
    Feb 20 17:44:54 snmpd[4d88b0c2] >>>  Community:   testcommunity
    Feb 20 17:44:54 snmpd[4d88b0c2] >>>  Error:       status=0 / vb_index=0
    Feb 20 17:44:54 snmpd[4d88b0c2] >>>   OID  : mib_2
    Feb 20 17:44:54 snmpd[4d88b0c2] >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    Feb 20 17:44:54 SNMPD_AUTH_FAILURE: nsa_initial_embedcomm: unauthorized SNMP community from 10.254.0.33 to unknown community name (testcommunity)

    ################

     

     

     

     

    Any ideas?  The traffic is indeed coming in on an interface attached to the RDI routing-instance, which is what we expect.



  • 2.  RE: SNMP issue...
    Best Answer

    Posted 02-20-2009 10:34

    When sending SNMP, using routing-instance, configure the client to use <routing-instance>@community.  So, in your example, have it send RDI@testcommunity.

     

    http://www.juniper.net/techpubs/software/junos/junos94/swconfig-net-mgmt/routing-instance-identifying-junos-nm.html

     

     

    Regards,

    Ben



  • 3.  RE: SNMP issue...

    Posted 02-20-2009 11:41
    FIXED!  Thanks!


  • 4.  RE: SNMP issue...

    Posted 01-21-2010 12:08

    I have something along the same lines. However, I did the xxx@routing-instance to do the snmp. Now I have an error in my /var/log/messages that states snmpd_auth_failure: nsa_log_community: unauthorized snmp community from x.x.x.x to unknown community name (xxx@routing-instance).

     

    The funny part of it is that its polling the interfaces and everything just fine. However I still get this error in my messages log.

     

    Any Takers?

     

    Thanks,

    Flan

     



  • 5.  RE: SNMP issue...

    Posted 01-21-2010 13:18

     


    @flan828 wrote:

    I have something along the same lines. However, I did the xxx@routing-instance to do the snmp. Now I have an error in my /var/log/messages that states snmpd_auth_failure: nsa_log_community: unauthorized snmp community from x.x.x.x to unknown community name (xxx@routing-instance).

     

    The funny part of it is that its polling the interfaces and everything just fine. However I still get this error in my messages log.

     

    Any Takers?

     

    Thanks,

    Flan

     


     

     

    This matches the symptoms, documented in PR451869.  As you indicated, it is a cosmetic issue.  The problem is fixed in JUNOS 10.0 and later.

     

    Regards,

    Ben



  • 6.  RE: SNMP issue...

    Posted 08-01-2014 06:03

    We are running Junos 12.3R2 on an MX960 and we are also getting this error message:

     

    Aug  1 13:22:11.888 2014  OURBOXNAME snmpd[1730]: SNMPD_AUTH_FAILURE: nsa_log_community: unauthorized SNMP community from x.x.x.x to y.y.y.y (p
    ublic)

     

    Any other ideas as to what causes this message?

     

    Thank you



  • 7.  RE: SNMP issue...

     
    Posted 08-01-2014 08:12

    is y.y.y.y an address in default routing-instance and you have snmp community public to serve x.x.x.x ?

    /Charlie



  • 8.  RE: SNMP issue...

    Posted 08-06-2019 00:29

    Can you share the correct config?