Junos OS

Expand all | Collapse all

Can no longer connect to J-web after reboot EX4200

  • 1.  Can no longer connect to J-web after reboot EX4200

    Posted 10-29-2020 13:28

    Running 15.1R7.9 on EX4200 stacks. J-web 15.1A4.1. After a reboot the connection with browser to J-web is refused. For example Chrome says "This site can't be reached ... refused to connect". This has happened on two stacks. I have another stack running same software versions that I haven't rebooted for over a year and I can still connect to J-web. Any help much appreciated!



  • 2.  Re: Can no longer connect to J-web after reboot EX4200

     
    Posted 10-29-2020 17:30

    Hi avhays,

     

    Have you tried to check for logs regarding http service,

    >show log messages | match http

     

    Or maybe, restarting the web-management,

    restart web-management

     

    Regards,

    Jeff



  • 3.  Re: Can no longer connect to J-web after reboot EX4200

    Posted 10-29-2020 17:37

    I assume a reboot would restart j-web?  I will check the logs.

     

    By the way if I wanted to re-install j-web for my version of JunOS on the EX4200 which J-web should I get?



  • 4.  Re: Can no longer connect to J-web after reboot EX4200

     
    Posted 10-29-2020 18:12

    Yes, definitely the reboot will restart all the processes, however have you rebooted the device after the first reboot that lead to the j-web failure?

     

    Regarding the version, for some reason is no longer showing under Juniper page for download, however I found this link to get it,

    https://webdownload.juniper.net/swdl/dl/secure/site/1/record/79745.html 

     

    The procedure will be like a normal upgrade, copy the image to /var/tmp/ and then delete the old image and install the new one,

    > request system software delete jweb
    > request system software add /var/tmp/....
     
    Please mark as "Solved" if this works for you so we can help others too 🙂 
     
    Regards,
    Jeff


  • 5.  Re: Can no longer connect to J-web after reboot EX4200

    Posted 10-29-2020 19:24

    Yes have rebooted twice.  As a workaround we enabled plain http and then when you point a browser at the switch you see the login screen and can login.  However it immediately pops up a box that says your session has expired.  If you ignore that and continue you find a lot of things don't work such as under the 'Maintain' tab.



  • 6.  Re: Can no longer connect to J-web after reboot EX4200

    Posted 10-30-2020 11:42

    We are attempting to install J-web now but we are getting the error there is not enough disk space?



  • 7.  RE: Re: Can no longer connect to J-web after reboot EX4200

     
    Posted 11-25-2020 08:31
    Hi,

    Please use the "request system storage cleanup" and try again. Is this working for you now?

    ------------------------------
    Juan Ospina
    ------------------------------