Data Center

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Laer2 VNI VXLAN not learning MAC/IP locally

  • 1.  Laer2 VNI VXLAN not learning MAC/IP locally

    Posted 04-10-2021 17:08
    Hi everyone,
    I am trying to reinforce VXLAN concept using simple network shown below:


    Above we have:
    1 Both QFX  exchaning EVPN routes. Only layer 2 VNI is being used.
    Issue:
    QFX1/QFX2 should learn MAC/IP binding by snooping arps. But this is not happening. Only MAC route is learned.

    VPC7> show ip
    NAME : VPCS7
    IP/MASK : 20.20.20.7/24
    MAC : 00:50:79:66:68:07
    LPORT : 20000
    RHOST:PORT : 127.0.0.1:30000
    MTU : 1500

    But attached QFX2 only shows MAC route not MAC/IP:

    Same case with QFX1:
    VPCS> show ip

    NAME : VPCS6
    IP/MASK : 20.20.20.6/24
    MAC : 00:50:79:66:68:06
    LPORT : 20000
    RHOST:PORT : 127.0.0.1:30000
    MTU : 1500

    Thanks and have a good weekend!!


    Additional info: ( Devices config)
    ##QFX1##
    set version 15.1X53-D60.4
    set system host-name QFX1
    set interfaces xe-0/0/0 unit 0 family ethernet-switching vlan members v20
    set interfaces xe-0/0/1 unit 0 family inet address 11.11.11.1/24
    set interfaces lo0 unit 0 family inet address 1.1.1.1/32

    set routing-options router-id 1.1.1.1
    set routing-options autonomous-system 100

    set protocols bgp group TEST type internal
    set protocols bgp group TEST family evpn signaling
    set protocols bgp group TEST neighbor 2.2.2.2 local-address 1.1.1.1

    set protocols ospf area 0.0.0.0 interface xe-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0

    set protocols evpn encapsulation vxlan
    set protocols evpn extended-vni-list all
    set protocols evpn default-gateway do-not-advertise

    set switch-options vtep-source-interface lo0.0
    set switch-options route-distinguisher 1.1.1.1:1
    set switch-options vrf-target target:100:1
    set vlans v20 vlan-id 20
    set vlans v20 vxlan vni 201

    ## QFX2##
    root@QFX2> show configuration | display set
    set version 15.1X53-D60.4
    set system host-name QFX2
    set interfaces xe-0/0/0 unit 0 family ethernet-switching vlan members v20
    set interfaces xe-0/0/1 unit 0 family inet address 11.11.11.2/24

    set interfaces em1 unit 0 family inet address 169.254.0.2/24
    set interfaces lo0 unit 0 family inet address 2.2.2.2/32


    set routing-options router-id 2.2.2.2
    set routing-options autonomous-system 100
    set protocols bgp group TEST type internal
    set protocols bgp group TEST family evpn signaling
    set protocols bgp group TEST neighbor 1.1.1.1 local-address 2.2.2.2
    set protocols ospf area 0.0.0.0 interface xe-0/0/1.0
    set protocols ospf area 0.0.0.0 interface lo0.0

    set protocols evpn encapsulation vxlan
    set protocols evpn extended-vni-list all
    set protocols evpn default-gateway do-not-advertise


    set switch-options vtep-source-interface lo0.0
    set switch-options route-distinguisher 2.2.2.2:1
    set switch-options vrf-target target:100:1

    set vlans v20 vlan-id 20
    set vlans v20 vxlan vni 201

    ##############################################################################################################