Data Center

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

EVPN MPLS VLAN-BASED MULTIHOMING

  • 1.  EVPN MPLS VLAN-BASED MULTIHOMING

    Posted 09-03-2021 08:28
    Hi everyone, i need some solution for my problem 
    Im doing some lab with EVPN MPLS Vlan-Based, i want to make my CE have a multihoming to 2 PE. But i couldnt figure it out what the problem here. Im not getting any route types 2 in my topology.
    I'll give the configuration below .



    PE1 :
    chassis {
    aggregated-devices {
    ethernet {
    device-count 5;
    }
    }
    fpc 0 {
    pic 0 {
    number-of-ports 8;
    }
    lite-mode;
    }
    network-services enhanced-ip;
    }
    interfaces {
    ge-0/0/0 {
    mtu 9500;
    unit 0 {
    family inet {
    address 20.20.20.1/30;
    }
    family mpls;
    }
    }
    ge-0/0/1 {
    gigether-options {
    802.3ad ae0;
    }
    }
    ae0 {
    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    esi {
    00:11:11:11:11:11:11:11:11:11;
    all-active;
    }
    unit 10 {
    encapsulation vlan-bridge;
    vlan-id 10;
    family bridge;
    }
    }
    fxp0 {
    unit 0 {
    family inet {
    address 100.123.1.0/16;
    }
    }
    }
    lo0 {
    unit 0 {
    family inet {
    address 10.10.10.1/32;
    }
    }
    }
    }
    policy-options {
    policy-statement evpn-lb {
    from protocol evpn;
    then {
    load-balance per-packet;
    }
    }
    }
    routing-instances {
    evpn {
    instance-type evpn;
    protocols {
    evpn;
    }
    interface ae0.10;
    route-distinguisher 10.10.10.1:1;
    vrf-target target:65000:1;
    }
    }
    routing-options {
    static {
    route 0.0.0.0/0 next-hop 100.123.0.1;
    }
    forwarding-table {
    export evpn-lb;
    }
    router-id 10.10.10.1;
    autonomous-system 65000;
    }
    protocols {
    ospf {
    traffic-engineering;
    area 0.0.0.0 {
    interface ge-0/0/0.0;
    interface lo0.0 {
    passive;
    }
    }
    }
    mpls {
    interface ge-0/0/0.0;
    interface lo0.0;
    }
    bgp {
    group RR-BSCF {
    type internal;
    local-address 10.10.10.1;
    family evpn {
    signaling;
    }
    neighbor 10.10.10.7;
    }
    }
    ldp {
    interface ge-0/0/0.0;
    interface lo0.0;
    }
    l2-learning {
    global-mac-table-aging-time 300;

    --------------------------------------
    PE2 :
    chassis {
    aggregated-devices {
    ethernet {
    device-count 5;
    }
    }
    fpc 0 {
    pic 0 {
    number-of-ports 8;
    }
    lite-mode;
    }
    network-services enhanced-ip;
    }
    interfaces {
    ge-0/0/0 {
    mtu 9500;
    unit 0 {
    family inet {
    address 20.20.20.5/30;
    }
    family mpls;
    }
    }
    ge-0/0/1 {
    gigether-options {
    802.3ad ae0;
    }
    }
    ae0 {
    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    esi {
    00:11:11:11:11:11:11:11:11:11;
    all-active;
    }
    unit 10 {
    encapsulation vlan-bridge;
    vlan-id 10;
    family bridge;
    }
    }
    fxp0 {
    unit 0 {
    family inet {
    address 100.123.1.1/16;
    }
    }
    }
    lo0 {
    unit 0 {
    family inet {
    address 10.10.10.2/32;
    }
    }
    }
    }
    policy-options {
    policy-statement evpn-lb {
    from protocol evpn;
    then {
    load-balance per-packet;
    }
    }
    }
    routing-instances {
    evpn {
    instance-type evpn;
    protocols {
    evpn;
    }
    interface ae0.10;
    route-distinguisher 10.10.10.2:1;
    vrf-target target:65000:1;
    }
    }
    routing-options {
    static {
    route 0.0.0.0/0 next-hop 100.123.0.1;
    }
    forwarding-table {
    export evpn-lb;
    }
    router-id 10.10.10.2;
    autonomous-system 65000;
    }
    protocols {
    ospf {
    traffic-engineering;
    area 0.0.0.0 {
    interface ge-0/0/0.0;
    interface lo0.0 {
    passive;
    }
    }
    }
    mpls {
    interface ge-0/0/0.0;
    interface lo0.0;
    }
    bgp {
    group RR-BSCF {
    type internal;
    local-address 10.10.10.2;
    family evpn {
    signaling;
    }
    neighbor 10.10.10.7;
    }
    }
    ldp {
    interface ge-0/0/0.0;
    interface lo0.0;
    }
    l2-learning {
    global-mac-table-aging-time 300;
    }
    }

    ---------------------------------------
    CE :
    chassis {
    aggregated-devices {
    ethernet {
    device-count 5;
    }
    }
    fpc 0 {
    pic 0 {
    number-of-ports 8;
    }
    lite-mode;
    }
    network-services enhanced-ip;
    }
    interfaces {
    ge-0/0/0 {
    gigether-options {
    802.3ad ae0;
    }
    }
    ge-0/0/1 {
    gigether-options {
    802.3ad ae0;
    }
    }
    ge-0/0/2 {
    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    unit 0 {
    encapsulation vlan-bridge;
    vlan-id 10;
    family bridge;
    }
    }
    ae0 {
    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    unit 0 {
    encapsulation vlan-bridge;
    vlan-id 10;
    family bridge;
    }
    }
    fxp0 {
    unit 0 {
    family inet {
    address 100.123.1.2/16;
    }
    }
    }
    }
    policy-options {
    policy-statement load-balancing-policy {
    then {
    load-balance per-packet;
    }
    }
    }
    routing-options {
    static {
    route 0.0.0.0/0 next-hop 100.123.0.1;
    }
    forwarding-table {
    export load-balancing-policy;
    }
    }
    bridge-domains {
    bd10 {
    interface ge-0/0/2.0;
    interface ae0.0;
    }


    ------------------------------
    FERNANDA ADHIPRAMANA
    ------------------------------


  • 2.  RE: EVPN MPLS VLAN-BASED MULTIHOMING

    Posted 09-07-2021 09:45
    Hi ,

    Good day !
    When you say type 2 routes are not generated 

    Few things you can check :
    >is the mac address learning working 
    >change to enterprise style and check
    >are these vlan included in the vni configuration (that part of the configuration is not posted here)

    -Sharanya