Automation

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  netconf port question

    Posted 04-14-2021 17:03
    How can I enable netconf to listen on the default port 830 ?

    I tested without netconf configuration, it listens on port 22 after I enabled ssh.
    If I  configured "set system services netconf ssh", netconf listens on port 22,too.

    The training materials say netconf listens on port 830 by default with you enable ssh or configure "set system services netconf ssh".

    Anything I missed ?

    thanks !!


  • 2.  RE: netconf port question

     
    Posted 04-15-2021 03:21
    Hi,
    are you saying it doesn't listen on port 830? Maybe a firewall filter?
    As per the docs configuring the port doesn't not stop ssh (on port 22) from accepting netconf: "If SSH services are enabled on the server, the default SSH port (22) continues to accept NETCONF sessions even when an alternate NETCONF-over-SSH port is configured."
    Regards
    Ulf


  • 3.  RE: netconf port question

    Posted 04-15-2021 09:43
    thanks a lot !!   I got it.


  • 4.  RE: netconf port question

    Posted 04-15-2021 10:04
    thanks a lot for Steve Puluka's comments. I  did  "show system connections | mathc 830" and found the port is listening.

    I do not know why I could not see your response after the page refreshed.


  • 5.  RE: netconf port question
    Best Answer

     
    Posted 04-15-2021 15:06
    Junos allows connections on port 22 for netconf but is also listening on port 830.

    You can see this on your device using:
    show system connections | match 830

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------