vMX

Expand all | Collapse all

LNS - si interface

Jump to Best Answer
  • 1.  LNS - si interface

     
    Posted 12-11-2018 01:24

    Hi all,

     

    On a physical box, we can get the si interface from the "show chassis hardware command" and this tends to run inline with the physical interface details... so, for example, physical link from LNS to LAC = xe-1/0/0 and the si interface is si-1/0/0.....

     

    If I want to replicate our LNS services on a vMX, how would I go about getting the si interface?



  • 2.  RE: LNS - si interface

     
    Posted 12-11-2018 01:34

    For information purposes... I found what the settings are :

     

    on the vMX for LNS or any other inline-services

     

    set chassis fpc 0 pic 0



  • 3.  RE: LNS - si interface

     
    Posted 12-11-2018 01:43

    I guess the command is "set chassis fpc 0 pic 0 inline-services"



  • 4.  RE: LNS - si interface

     
    Posted 12-11-2018 01:55

    Hi rahul,

     

    Yes, it is. I have completed all of that, and, as an add on, for the vMX you also have to add the following command:

     

    set chassis fpc 0 loopback-device-count 1

     

    However, that has brought up another issue.... for the si interface I have configured the following:

     

    set interfaces si-0/0/0 hierarchical-scheduler maximum-hierarchy-levels 2
    set interfaces si-0/0/0 encapsulation generic-services
    set interfaces si-0/0/0 unit 0 family inet

     

    And for the chassis the following:

    set chassis fpc 0 pic 0 tunnel-services bandwidth 1g
    set chassis fpc 0 pic 0 inline-services bandwidth 1g
    set chassis fpc 0 pic 0 max-queues-per-interface 8
    set chassis fpc 0 lite-mode
    set chassis fpc 0 flexible-queuing-mode

     

    But, if I try to add the following liune to the dynamic-profile:

    set dynamic-profiles dyn-hex-lns-profile interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" dial-options l2tp-interface-id l2tp-encapsulation

     

    And then commit, I get the following error:

    error: Inet family must be configured for the dial-option
    error: foreign file propagation (ffp) failed

     

    So, although "inet" is configured on the si interface, it does not seem to be recognising it, unless this is because it wants some configuraiton on ge-0/0/0 instead of ge-0/0/2.... I'll give that a try and let you know the results...

     

     

     



  • 5.  RE: LNS - si interface

     
    Posted 12-11-2018 01:57

    Nope, same result....

     

    Clive@HEX-LNS-02-TEST# commit
    error: Inet family must be configured for the dial-option
    error: foreign file propagation (ffp) failed

     



  • 6.  RE: LNS - si interface

     
    Posted 12-11-2018 02:00

    Commit issue is because SI interface is not defined. Kindly check the SI interface created using below knob and then define the interface.

     

    show interfaces terse | grep si-

     

    set interfaces si-1/0/0.0 family inet  

     



  • 7.  RE: LNS - si interface
    Best Answer

     
    Posted 12-11-2018 02:01

    Issue resolved....

     

    I had to add the following line to the dynamic-profile:

     

    set dynamic-profiles dyn-hex-lns-profile interfaces "$junos-interface-ifd-name" unit "$junos-interface-unit" family inet unnumbered-address "$junos-loopback-interface"

     

    Thanks Rahul.... but if you look at my answer above, I had that configured..... Thanks 🙂