vMX

Expand all | Collapse all

MC-LAG on vMX 17.x (tried a few versions)

Jump to Best Answer
  • 1.  MC-LAG on vMX 17.x (tried a few versions)

    Posted 10-06-2017 03:16

    this never seems to stabalise using a vMX version other then 14.1 r4.8 (which works perfectly)

     

    I can't get the same config working on any of the 16.x and 17.x vMX releases using VCP/VFP combinations.

     

    following are the outputs:

     

    basically the "show iccp detail" keeps bouncing from up to down which causes xSTP to discard and the LAG LACP port-channel to keep bouncing facing the single homed switch.

     

    root@vMX-VCP1# run show iccp detail    
    
    Redundancy Group Information for peer 10.19.211.2
      TCP Connection       : Established
      Liveliness Detection : Up
      Redundancy Group ID          Status
        1                           Up   
    
    Client Application: lacpd
      Redundancy Group IDs Joined: 1 
    
    Client Application: l2ald_iccpd_client
      Redundancy Group IDs Joined: 1 
    
    
    
    root@vMX-VCP1# run show iccp detail    
    
    Redundancy Group Information for peer 10.19.211.2
      TCP Connection       : In progress
      Liveliness Detection : Up
      Redundancy Group ID          Status
        1                           Down 
    
    Client Application: lacpd
      Redundancy Group IDs Joined: 1 
    
    Client Application: l2ald_iccpd_client
      Redundancy Group IDs Joined: 1 
    
    
    root@vMX-VCP1# run show version 
    Hostname: vMX-VCP1
    Model: vmx
    Junos: 17.3R1.10
    
    root@vMX-VCP2# run show version 
    Hostname: vMX-VCP2
    Model: vmx
    Junos: 17.3R1.10
    
    
    
    vMX1
    set chassis aggregated-devices ethernet device-count 10
    set chassis network-services enhanced-ip
    set interfaces ge-0/0/0 gigether-options 802.3ad ae0
    set interfaces ge-0/0/1 gigether-options 802.3ad ae0
    set interfaces ge-0/0/2 gigether-options 802.3ad ae1
    set interfaces ge-0/0/3 unit 0 family inet address 10.0.1.70/30
    set interfaces ge-0/0/4 gigether-options 802.3ad ae2
    set interfaces ge-0/0/5 unit 0 family inet address 10.0.1.66/30
    set interfaces ge-0/0/6 gigether-options 802.3ad ae2
    set interfaces ae0 description ICCP_Link
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 unit 0 family inet address 10.19.211.1/30
    set interfaces ae1 description To-IOL-SW
    set interfaces ae1 vlan-tagging
    set interfaces ae1 native-vlan-id 1
    set interfaces ae1 multi-chassis-protection 10.19.211.2 interface ae2
    set interfaces ae1 encapsulation flexible-ethernet-services
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp system-id 00:00:00:00:00:02
    set interfaces ae1 aggregated-ether-options lacp admin-key 1
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 2
    set interfaces ae1 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 0
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control active
    set interfaces ae1 unit 0 family bridge interface-mode trunk
    set interfaces ae1 unit 0 family bridge vlan-id-list 1-4094
    set interfaces ae2 description ICP-PL
    set interfaces ae2 flexible-vlan-tagging
    set interfaces ae2 encapsulation flexible-ethernet-services
    set interfaces ae2 aggregated-ether-options lacp active
    set interfaces ae2 aggregated-ether-options lacp periodic fast
    set interfaces ae2 unit 0 family bridge interface-mode trunk
    set interfaces ae2 unit 0 family bridge vlan-id-list 1-4094
    set interfaces fxp0 unit 0 family inet dhcp vendor-id Juniper-vmx
    set interfaces irb unit 200 family inet address 10.14.200.40/24
    set interfaces irb unit 201 family inet address 10.14.201.40/24
    set interfaces lo0 unit 0 family inet address 10.1.1.103/32
    set routing-options router-id 10.0.0.6
    set protocols ospf area 0.0.0.0 interface ge-0/0/3.0 interface-type p2p
    set protocols ospf area 0.0.0.0 interface ge-0/0/5.0 interface-type p2p
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols pim interface ge-0/0/3.0 mode bidirectional-sparse
    set protocols pim interface ge-0/0/5.0 mode bidirectional-sparse
    set protocols iccp local-ip-addr 10.19.211.1
    set protocols iccp peer 10.19.211.2 redundancy-group-id-list 1
    set protocols iccp peer 10.19.211.2 liveness-detection minimum-interval 150
    set protocols iccp peer 10.19.211.2 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 10.19.211.2 liveness-detection multiplier 3
    set protocols iccp peer 10.19.211.2 authentication-key "$9$RMFcrvxNboJDWLJDikTQEcy"
    set protocols vstp interface ae1
    set protocols vstp vlan 1 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 1 interface ae1
    set protocols vstp vlan 200 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 200 interface ae1
    set protocols vstp vlan 201 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 201 interface ae1
    set protocols vstp vlan all bridge-priority 0
    set bridge-domains v200 domain-type bridge
    set bridge-domains v200 vlan-id 200
    set bridge-domains v200 service-id 200
    set bridge-domains v200 mcae-mac-synchronize
    set bridge-domains v200 routing-interface irb.200
    set bridge-domains v200 vxlan vni 5000
    set bridge-domains v200 vxlan multicast-group 225.100.100.100
    set bridge-domains v201 domain-type bridge
    set bridge-domains v201 vlan-id 201
    set bridge-domains v201 service-id 201
    set bridge-domains v201 mcae-mac-synchronize
    set bridge-domains v201 routing-interface irb.201
    set bridge-domains v201 vxlan vni 5001
    set bridge-domains v201 vxlan multicast-group 225.100.100.100
    set switch-options service-id 1
    set switch-options vtep-source-interface lo0.0
    
    
    
    vMX2
    set chassis aggregated-devices ethernet device-count 10
    set chassis network-services enhanced-ip
    set interfaces ge-0/0/0 gigether-options 802.3ad ae0
    set interfaces ge-0/0/1 gigether-options 802.3ad ae0
    set interfaces ge-0/0/2 gigether-options 802.3ad ae1
    set interfaces ge-0/0/3 unit 0 family inet address 10.0.1.58/30
    set interfaces ge-0/0/4 gigether-options 802.3ad ae2
    set interfaces ge-0/0/5 unit 0 family inet address 10.0.1.62/30
    set interfaces ge-0/0/6 gigether-options 802.3ad ae2
    set interfaces ae0 description ICCP_Link
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 unit 0 family inet address 10.19.211.2/30
    set interfaces ae1 description To-IOL-SW
    set interfaces ae1 vlan-tagging
    set interfaces ae1 native-vlan-id 1
    set interfaces ae1 multi-chassis-protection 10.19.211.1 interface ae2
    set interfaces ae1 encapsulation flexible-ethernet-services
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp system-id 00:00:00:00:00:02
    set interfaces ae1 aggregated-ether-options lacp admin-key 1
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 2
    set interfaces ae1 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 1
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control standby
    set interfaces ae1 unit 0 family bridge interface-mode trunk
    set interfaces ae1 unit 0 family bridge vlan-id-list 1-4094
    set interfaces ae2 description ICP-PL
    set interfaces ae2 flexible-vlan-tagging
    set interfaces ae2 encapsulation flexible-ethernet-services
    set interfaces ae2 aggregated-ether-options lacp active
    set interfaces ae2 aggregated-ether-options lacp periodic fast
    set interfaces ae2 unit 0 family bridge interface-mode trunk
    set interfaces ae2 unit 0 family bridge vlan-id-list 1-4094
    set interfaces fxp0 unit 0 family inet dhcp vendor-id Juniper-vmx
    set interfaces irb unit 200 family inet address 10.14.200.40/24
    set interfaces irb unit 201 family inet address 10.14.201.40/24
    set interfaces lo0 unit 0 family inet address 10.1.1.103/32
    set routing-options router-id 10.0.0.7
    set protocols ospf area 0.0.0.0 interface ge-0/0/3.0 interface-type p2p
    set protocols ospf area 0.0.0.0 interface ge-0/0/5.0 interface-type p2p
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols pim interface ge-0/0/3.0 mode bidirectional-sparse
    set protocols pim interface ge-0/0/5.0 mode bidirectional-sparse
    set protocols iccp local-ip-addr 10.19.211.2
    set protocols iccp peer 10.19.211.1 redundancy-group-id-list 1
    set protocols iccp peer 10.19.211.1 liveness-detection minimum-interval 150
    set protocols iccp peer 10.19.211.1 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 10.19.211.1 liveness-detection multiplier 3
    set protocols iccp peer 10.19.211.1 authentication-key "$9$RMFcrvxNboJDWLJDikTQEcy"
    set protocols vstp interface ae1
    set protocols vstp vlan 1 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 1 interface ae1
    set protocols vstp vlan 200 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 200 interface ae1
    set protocols vstp vlan 201 system-identifier 00:01:02:03:04:05
    set protocols vstp vlan 201 interface ae1
    set protocols vstp vlan all bridge-priority 0
    set bridge-domains v200 domain-type bridge
    set bridge-domains v200 vlan-id 200
    set bridge-domains v200 service-id 200
    set bridge-domains v200 mcae-mac-synchronize
    set bridge-domains v200 routing-interface irb.200
    set bridge-domains v200 vxlan vni 5000
    set bridge-domains v200 vxlan multicast-group 225.100.100.100
    set bridge-domains v201 domain-type bridge
    set bridge-domains v201 vlan-id 201
    set bridge-domains v201 service-id 201
    set bridge-domains v201 mcae-mac-synchronize
    set bridge-domains v201 routing-interface irb.201
    set bridge-domains v201 vxlan vni 5001
    set bridge-domains v201 vxlan multicast-group 225.100.100.100
    set switch-options service-id 1
    set switch-options vtep-source-interface lo0.0


  • 2.  RE: MC-LAG on vMX 17.x (tried a few versions)
    Best Answer

    Posted 10-06-2017 13:32

    this is now fixed, it was down to running anycast vtep/vxlan deployment on the mc-lag pair for which ive raised another thread:

     

    https://forums.juniper.net/t5/Routing/Does-Juniper-support-anycast-VTEP-in-VXLAN-deployments/td-p/313909

     

    as soon as I removed the config from the 2nd vMX including the same lo0.0 advertisement in IGP, the topology settled.

     

    raises another question per that thread on whether Juniper supports anycast VTEP, seen nothing in KB on this design...