vMX

Expand all | Collapse all

VMware: how to add PIC to FCP on vMX 16.1R4.7

Jump to Best Answer
  • 1.  VMware: how to add PIC to FCP on vMX 16.1R4.7

    Posted 04-10-2017 08:34

    Hi to all.

     

    This is what i did with VMware ESXi 6.0 release: 

     1) deploy the VCP and VFP VM using OVA file (*);

     2) VCP has 2 interface E1000: br-int and br-ext

     3) VFP has 4 interface: 2xE1000 (br-int and br-ext) and 2xVMXNET3. Each for a public p2p.

     

    After powering on both VM, I see only the FPC on "show chassis hardware". On the VCP configuration I have also defined "set chassis fpc 0 pic 0 number-of-ports 2"  and I have tried with set chassis fpc 0 pic 0 interface-type ge and after with set chassis fpc 0 pic 0 interface-type xe but nothing happens.

     

    This is what I see on VCP console.

    Capture.JPG

     

    Any suggestion?

     

    Thanks

    Giancarlo

     

    (*) WARNING: there is an error in the OVA file for VFP. It sets a VM with 32M of memory. In this case the VM go in cycle reboot. My suggestion is to deploy the VM without booting it. After deployment adjust memory and core then power on the VM. 



  • 2.  RE: VMware: how to add PIC to FCP on vMX 16.1R4.7
    Best Answer

    Posted 04-11-2017 13:47

    First off, vMX is not qualified on ESXi 6, so you are on your own risk.

    https://www.juniper.net/techpubs/en_US/vmx16.1/topics/reference/general/vmx-hw-sw-minimums-vmware.html

     

    You don't have to "set chassis fpc 0 pic 0 number-of-ports 2", but if you don't have enough vCPU for vFP (in this case it should be 4*2+3=11), you need "set chassis fpc 0 lite-mode".

    https://www.juniper.net/techpubs/en_US/vmx16.1/topics/reference/general/vmx-hw-sw-minimums-vmware.html

     

    It will be helpful if you can collect serial console boot log of vFP and see what was happened during booting up.

    https://www.juniper.net/techpubs/en_US/vmx16.1/topics/task/configuration/vmx-vm-connecting-vmware.html

     



  • 3.  RE: VMware: how to add PIC to FCP on vMX 16.1R4.7

    Posted 04-12-2017 23:53

    Hi szhong.

     

    Thanks for suggestion. Setting lite-mode it works.

     

    Bye

    gianvio