Routing

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  No connectivity between loopbacks with ipv6 address in VRF environment

    Posted 10-29-2021 05:52
    I have a problem with connectivity between loopbacks with ipv6 address in VRF environment. I can see all ipv6 prefix in the vrf table but I don have ping connectivity.

    The topology is as follows:

                                                 DARTH_VADER                                                     C-3PO
    CPE <---------------> BNG (MX104) <-----------------------> PE01 (ACX500)
                  PD + NDRA                |                                     MP-BGP                         |
                                                             |                           inet6-vpn unicast                |
                                                             |                            inet-vpn unicast                  |
                                                             |                                                                                  |
                                 Lo0.100 (2002:abcd::1/128)                 Lo0.100 (2001:abcd::88/128)

    The route is present in route table (RIB) and fordwarding table:

    admin@DARTH_VADER> show route table test.inet6.0 2001:abcd::88/128                        
    
    test.inet6.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    2001:abcd::88/128  *[BGP/170] 01:30:43, localpref 100, from 10.10.10.243
                          AS path: I, validation-state: unverified
                        >  to 10.10.10.250 via ge-1/1/2.0, Push 19
    
    admin@DARTH_VADER> show route forwarding-table table test destination 2001:abcd::88/128                                            
    Routing table: test.inet6
    Internet6:
    Destination        Type RtRef Next hop           Type Index    NhRef Netif
    2001:abcd::88/128  user     0                    indr  1048577     3
                                  10.10.10.250      Push 19      577     2 ge-1/1/2.0
    
    
    admin@C-3PO_ACX500> show route table test.inet6.0 2002:abcd::1/128 
    
    test.inet6.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    2002:abcd::1/128   *[BGP/170] 1d 03:01:11, localpref 100, from 10.10.10.241
                          AS path: I, validation-state: unverified
                        >  to 10.10.10.249 via ge-0/1/0.0, Push 19
    
    admin@C-3PO_ACX500> show route forwarding-table table test destination 2002:abcd::1/128 
    Routing table: test.inet6
    Internet6:
    Destination        Type RtRef Next hop           Type Index    NhRef Netif
    2002:abcd::1/128   user     0                    indr  1048575     4
                                  10.10.10.249      Push 19      685     2 ge-0/1/0.0
    ​

    But I don't have ping connectivity:

    admin@DARTH_VADER> ping routing-instance test 2001:abcd::88 source 2002:abcd::1            
    PING6(56=40+8+8 bytes) 2002:abcd::1 --> 2001:abcd::88
    ^C
    --- 2001:abcd::88 ping6 statistics ---
    6 packets transmitted, 0 packets received, 100% packet loss​

    The configuration is as follows:

    admin@DARTH_VADER> show configuration protocols mpls    
    apply-groups GR-LSP;
    no-propagate-ttl;
    icmp-tunneling;
    inactive: label-switched-path r1-to-r2 {
        to 10.10.10.243;
    }
    ipv6-tunneling;
    interface ge-1/1/2.0;
    
    admin@DARTH_VADER> show configuration protocols bgp | display inheritance no-comments 
    group GR-IBGP-PES {
        type internal;
        local-address 10.10.10.241;
        family inet-vpn {
            unicast;
        }
        family inet6-vpn {
            unicast;
        }
        family l2vpn {
            signaling;
        }
        family route-target {
            advertise-default;
        }
        authentication-key "$9$-Aws2aJGiHqMWxN"; ## SECRET-DATA
        cluster 10.10.10.241;
        bfd-liveness-detection {
            minimum-interval 1000;
            multiplier 4;
        }
        neighbor 10.10.10.243 {
            description "### iBGP TO ACX500 ###";
        }
        vpn-apply-export;
    }
    precision-timers;
    log-updown;
    
    admin@DARTH_VADER> show configuration routing-instances test 
    description "vrf Internet BNG";
    instance-type vrf;
    system {
        services {
            dhcp-local-server {
                dhcpv6 {
                    overrides {
                        delegated-pool DHCPV6-PD-POOL;
                    }
                    group PPPoEv6 {
                        interface demux0.0;
                        interface pp0.0;
                    }
                }
            }
        }
    }
    access {
        address-assignment {
            neighbor-discovery-router-advertisement NDRA-POOL;
            high-utilization 90;
            abated-utilization 70;
            pool FTTH-V4-POOL {
                family inet {
                    network 192.168.40.0/24;
                    range DHCP {
                        low 192.168.40.1;
                        high 192.168.40.248;
                    }
                }
            }
            pool DHCPV6-PD-POOL {
                family inet6 {
                    prefix 2040:2000:2000::/48;
                    range CPE prefix-length 64;
                }
            }
            pool NDRA-POOL {
                family inet6 {
                    prefix 2010:0:0:0::/48;
                    range WAN prefix-length 64;
                }
            }
        }
        address-protection;
    }
    interface lo0.100;
    route-distinguisher 48:84;
    vrf-target {
        import target:48:84;
        export target:48:84;
    }
    vrf-table-label;
    
    admin@DARTH_VADER> show configuration interfaces lo0 
    unit 0 {
        description "### ROUTER-ID ###";
        family inet {
            address 10.10.10.241/32;
        }
        family iso {
            address 49.0008.0000.0000.0003.00;
        }
    }
    unit 100 {
        family inet {
            address 48.0.0.1/32;
        }
        family inet6 {
            address 2002:abcd::1/128;
        }
    }
    
    admin@C-3PO_ACX500> show configuration protocols mpls 
    icmp-tunneling;
    inactive: label-switched-path r2-to-r1 {
        to 10.10.10.241;
        ultimate-hop-popping;
    }
    ipv6-tunneling;
    interface ge-0/1/0.0;
    
    admin@C-3PO_ACX500> show configuration protocols bgp | display inheritance no-comments 
    group GR-IBGP-UP {
        type internal;
        local-address 10.10.10.243;
        family inet-vpn {
            unicast;
        }
        family inet6-vpn {
            unicast;
        }
        family route-target;
        authentication-key "$9$-Aws2aJGiHqMWxN"; ## SECRET-DATA
        bfd-liveness-detection {
            minimum-interval 1000;
            multiplier 4;
        }
        neighbor 10.10.10.241 {
            description "### iBGP TO MX104 ###";
        }
    }
    precision-timers;
    
    admin@C-3PO_ACX500> show configuration routing-instances test 
    routing-options {
        rib test.inet6.0 {
            aggregate {
                route ::/0;
            }
        }
        static {
            route 0.0.0.0/0 next-hop 10.32.7.1;
        }
    }
    description "vrf Internet BNG";
    instance-type vrf;
    interface ge-0/1/1.0;
    interface lo0.100;
    route-distinguisher 48:84;
    vrf-target {
        import target:48:84;
        export target:48:84;
    }
    vrf-table-label;
    
    admin@C-3PO_ACX500> show configuration interfaces lo0 
    unit 0 {
        description "### ROUTER ID ###";
        family inet {
            address 10.10.10.243/32;
        }
        family iso {
            address 49.0008.0000.0000.0048.00;
        }
    }
    unit 100 {
        family inet {
            address 44.44.44.44/32;
        }
        family inet6 {
            address 2001:abcd::88/128;
        }
    }
    unit 200 {
        family inet6 {
            address 2001:abcd::1/128;
        }
    }
    unit 300 {
        family inet {
            address 18.1.1.1/32;
        }
    }
    unit 400 {
        family inet {
            address 18.1.1.1/32;
        }
    }
    


    IPV4 works fine. Can you help me figure out what's wrong in this test environment



    ------------------------------
    PABLO JIMENEZ
    ------------------------------


  • 2.  RE: No connectivity between loopbacks with ipv6 address in VRF environment

    Posted 29 days ago
    Hello Pablo, 

    same config works just fine between two MXs, the PFE of the ACX is quite limited, so if i have to bet, the culprit is the ACX that is unable to resolve or perform the double encapsulation for inet6-vpn. 

    thanks, 
    Gabriel FV

    ------------------------------
    GABRIEL FLORES
    ------------------------------