Routing

Expand all | Collapse all

BFD on RSVP LSP not working

  • 1.  BFD on RSVP LSP not working

    Posted 01-24-2021 17:29
    Hi everybody,
    I am testing how we can use BFD for LSP. for some reason, it is not working .
    Set  up:
    MX1-g0/0/0-----g0/0/0 -MX2-ge001--ge0/0/1 MX3
    MX1 has lo0:1.1.1.1, MX3 has lo0: 3.3.3.3
    I statically configured RSVP LSP to 3.3.3.3 on MX1 , which is up.
    But I noticed MX1 is sending BFD probes to 127.0.0.0 instead of 3.3.3.3

    root@MX1> show bfd session
    Detect Transmit
    Address State Interface Time Interval Multiplier
    127.0.0.1 AdminDown ge-0/0/0.0 0.150 1.000 2

    Capture taken between MX1 and MX2 confirms  MX1 is not sending BGP messages to 3.3.3.3, but 127.0.0.1
    How can I tell MX1 to send BFD probe to 3.3.3.3 not to 127.0.0.1 ?

    Thanks and have a good day!!



    Additional info:
    ## MX1##
    set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.1/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 1.1.1.1/32
    set protocols rsvp interface all
    set protocols mpls oam bfd-liveness-detection minimum-interval 50
    set protocols mpls oam bfd-liveness-detection multiplier 2
    set protocols mpls oam bfd-liveness-detection failure-action teardown
    set protocols mpls label-switched-path TEST to 3.3.3.3
    set protocols mpls interface all
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface all
    set protocols ospf area 0.0.0.0 interface fxp0.0 passive
    set protocols lldp interface all

    ##MX2##
    set interfaces ge-0/0/0 unit 0 family inet address 12.12.12.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 unit 0 family inet address 23.23.23.2/24
    set interfaces ge-0/0/1 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 2.2.2.2/32
    set protocols rsvp interface all
    set protocols mpls oam bfd-liveness-detection minimum-interval 50
    set protocols mpls oam bfd-liveness-detection multiplier 2
    set protocols mpls oam bfd-liveness-detection failure-action teardown
    set protocols mpls interface all
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface all
    set protocols ospf area 0.0.0.0 interface fxp0.0 passive
    set protocols lldp interface all

    ##MX3##
    set interfaces ge-0/0/0 unit 0 family inet address 23.23.23.3/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 3.3.3.3/32
    set protocols rsvp interface all
    set protocols mpls oam bfd-liveness-detection minimum-interval 50
    set protocols mpls oam bfd-liveness-detection multiplier 2
    set protocols mpls oam bfd-liveness-detection failure-action teardown
    set protocols mpls interface all
    set protocols ospf traffic-engineering
    set protocols ospf area 0.0.0.0 interface all
    set protocols ospf area 0.0.0.0 interface fxp0.0 passive
    set protocols lldp interface all


  • 2.  RE: BFD on RSVP LSP not working

     
    Posted 01-24-2021 18:24
    Hello,

    LSP self ping does take 127 address rather than loopback and that's how its intended to work.

    I think you might not have allowed UDP port 8503 in your loopback filter for the self ping to work. 

    Please check following KB article for further details. 


    root@root# show firewall family inet filter lo0-filter term self-ping {     from {         prefix-list {             core;         }         protocol udp;         port 8503;     }     then accept; }

    Thanks
    Vishal





  • 3.  RE: BFD on RSVP LSP not working

    Posted 01-24-2021 21:49
    Hi Vishal,
    Thanks for your response,  loopback lo0 has no filter, thus everything is allowed.


  • 4.  RE: BFD on RSVP LSP not working

    Posted 01-24-2021 23:57
    So found a good link (learning byte) explaining BFD for RSVP LSP:
    https://www.youtube.com/watch?v=hXpkRTJr9os

    Now, I understood why destination ip is 127.0.0.0 , it is by design.
    The issue is  BFD session is not establishing between MX1 ( ingress LSR) and MX3 ( egress LSR),  show bfd session on  MX1 shows, session moves through  init, up, admin down:

    root> show bfd session
    Detect Transmit
    Address State Interface Time Interval Multiplier
    127.0.0.1 AdminDown ge-0/0/0.0 0.150 1.000 3

    #Extensive ##
    root> show bfd session extensive
    Detect Transmit
    Address State Interface Time Interval Multiplier
    127.0.0.1 Up ge-0/0/0.0 0.150 0.050 3
    Client RSVP-OAM, TX interval 0.050, RX interval 0.050
    Session up time 00:00:03
    Local diagnostic None, remote diagnostic None
    Remote state Up, version 1
    Session type: Multi hop BFD
    Min async interval 0.050, min slow interval 1.000
    Adaptive async TX interval 0.050, RX interval 0.050
    Local min TX interval 0.050, minimum RX interval 0.050, multiplier 3
    Remote min TX interval 0.050, min RX interval 0.050, multiplier 3
    Local discriminator 47, remote discriminator 47
    Echo mode disabled/inactive
    LSP-Name TEST
    Session ID: 0x0

    Then it goes down:
    root> show bfd session
    Detect Transmit
    Address State Interface Time Interval Multiplier
    127.0.0.1 AdminDown ge-0/0/0.0 0.150 1.000 3









  • 5.  RE: BFD on RSVP LSP not working

     
    Posted 01-25-2021 09:47

    Hello,

    Sorry I had a brain fade moment and thought LSP self ping is not working so I tried to answer that in my previous reply.

    For OAM BFD, I think you timers might be very aggressive. Can you please try (300x3) instead of (50x2) and see if the session remains stable.


    https://www.juniper.net/documentation/en_US/junos/topics/usage-guidelines/mpls-configuring-bfd-for-mpls-ipv4-lsps.html

    NOTE

    BFD for MPLS IPv4 LSP is based on the Routing Engine and is not distributed. As a result, the minimum supported BFD timer interval is (100 ms * 3) per one LSP session, and for scaled LSP sessions, the minimum supported BFD timer interval is (300 ms * 3). As you increase the number of LSP sessions with BFD, you must also increase (scale) the interval timers to support the network.

    For Routing Engine switchover instances with nonstop active routing (NSR) support, the minimum supported BFD timer interval is (2.5 seconds * 3).

    Thanks

    Vishal