Routing

Expand all | Collapse all

EVPN/MPLS with irb interface - got error

  • 1.  EVPN/MPLS with irb interface - got error

    Posted 01-19-2021 12:24
    Hello everyone.
    i`m trying to configure EVPN instance with irb interface. Th instance is quite simple:
    instance-type evpn;
    vlan-id 4094;
    interface ae19.4094;
    vrf-target target:65100:99;
    routing-interface irb.99
    protocols {
        evpn {
            default-gateway do-not-advertise;
        }
    }
    
    show configuration interfaces irb.99 
    family inet {
        policer {
            arp 100k-plr;
        }
        address 172.20.90.1/24;
    }
    mac 00:02:00:00:00:99;
    ​

    then i configure irb.99 under l3vpn instance:

    instance-type vrf;
    interface irb.99;
    vrf-import L3VPN-IMPORT;
    vrf-export L3VPN-EXPORT;
    vrf-table-label;
    ​


    The problem is when i configure EVPN instance with irb interface i got this error:

    show krt queue    
    Routing table add queue: 0 queued
    Interface add/delete/change queue: 0 queued
    Top-priority deletion queue: 0 queued
    Top-priority change queue: 0 queued
    Top-priority add queue: 0 queued
    high priority V4oV6 tcnh delete queue: 0 queued
    high prioriy anchor gencfg delete queue: 0 queued
    High-priority multicast add/change: 0 queued
    Indirect next hop top priority add/change: 0 queued
    Indirect next hop add/change: 0 queued
    high prioriy anchor gencfg add-change queue: 0 queued
    MPLS add queue: 1 queued
                    ADD gf 3 inst id 0 836 /52 receive - table index 37, gf 11
             (14)
                        error 'EINVAL -- Bad parameter in request'
                        kqp '0x68a26c0'
    Indirect next hop delete: 0 queued
    High-priority deletion queue: 0 queued
    MPLS change queue: 0 queued
    High-priority change queue: 0 queued
    High-priority add queue: 0 queued
    Normal-priority indirect next hop queue: 0 queued
    Normal-priority deletion queue: 0 queued
    Normal-priority composite next hop deletion queue: 0 queued
    Low prioriy Statistics-id-group deletion queue: 0 queued
    Normal-priority change queue: 0 queued
    Normal-priority add queue: 0 queued
    Least-priority delete queue: 0 queued
    Least-priority change queue: 0 queued
    Least-priority add queue: 0 queued
    Normal-priority pfe table nexthop queue: 0 queued
    EVPN gencfg queue: 0 queued
    Normal-priority gmp queue: 0 queued
    Routing table delete queue: 0 queued
    Low priority route retry queue: 0 queued




  • 2.  RE: EVPN/MPLS with irb interface - got error

     
    Posted 01-19-2021 12:41

    seems like something is stuck in MPLS queue, can you check you core facing interface and confirm if you have the family MPLS configuration ?

    MPLS add queue: 1 queued
                    ADD gf 3 inst id 0 836 /52 receive - table index 37, gf 11
             (14)
                        error 'EINVAL -- Bad parameter in request'
                        kqp '0x68a26c0'



  • 3.  RE: EVPN/MPLS with irb interface - got error

    Posted 01-19-2021 13:19
    Hello.
    This only happens when i configure routing-interface inside EVPN instance.


  • 4.  RE: EVPN/MPLS with irb interface - got error

     
    Posted 01-19-2021 13:27
    Can you please share configuration of your core facing interface and ae19/ae19.4094

    Also, try following configuration.
    set routing-instances <instance-name> protocols evpn interface ae19.4094



  • 5.  RE: EVPN/MPLS with irb interface - got error

    Posted 01-19-2021 13:40
     show configuration interfaces ae19 
    description "DGS TEST | Phy";
    flexible-vlan-tagging;
    mtu 9192;
    encapsulation flexible-ethernet-services;
    aggregated-ether-options {
        lacp {
            active;
            periodic fast;
            system-id 02:00:00:00:00:99;
        }
    }
    unit 99 {
        encapsulation vlan-ccc;
        vlan-id-list 1-4000;
        esi {
            00:00:00:00:00:00:00:19:00:99;
            all-active;
        }
    }
    unit 4094 {
        encapsulation vlan-bridge;
        vlan-id 4094;
        esi {
            00:00:00:00:00:00:00:19:40:94;
            all-active;
        }
    }​
    I got another mx with same instance - it works well.