Routing

Expand all | Collapse all

Segment Routing support on ACX2200

  • 1.  Segment Routing support on ACX2200

    Posted 06-21-2021 12:47
    hi Experts. 
    I am running 19.4R3 version on ACX220 . Any idea if Segment Routing support is available on that platform in the release 19.4R3 . If not, from which version is it going to be or already available. 

    Thanks
    Aseem.

    ------------------------------
    ASEEM RAI
    ------------------------------


  • 2.  RE: Segment Routing support on ACX2200

     
    Posted 06-21-2021 20:21
    The feature is available on the acx2200 from 17.4.  You can configure basic pcep client support and both standard and spring controller.  But the label depth on the broadcom chips here is only 3 or 4.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 3.  RE: Segment Routing support on ACX2200

    Posted 06-22-2021 02:05
      |   view attached
    hello Steve, 
    Thank you for your reply . 
    On 19.4R3 , i was trying to enable the SRGB but get the below error. 

    [edit]
    juniper# commit <<<<<<<<<<<<<<<<<<<<<<<<<< issue observed .
    [edit protocols isis source-packet-routing]
    'srgb'
    can't config SRGB
    error: configuration check-out failed

    [edit]
    juniper#

    show chassis output 
    juniper> show chassis hardware
    Hardware inventory:
    Item Version Part number Serial number Description
    Chassis PX0218230112 ACX2200
    Midplane REV 05 650-062885 PX0218230112 ACX2200
    Routing Engine BUILTIN BUILTIN Routing Engine
    FEB 0 BUILTIN BUILTIN Forwarding Engine Processor
    FPC 0 BUILTIN BUILTIN FPC BUILTIN
    MIC 0 BUILTIN BUILTIN 4x 1GE(LAN) RJ45
    PIC 0 BUILTIN BUILTIN 4x 1GE(LAN) RJ45
    MIC 1 BUILTIN BUILTIN 4x 1GE(LAN) SFP, RJ45
    PIC 1 BUILTIN BUILTIN 4x 1GE(LAN) SFP, RJ45
    MIC 2 BUILTIN BUILTIN 2x 1GE(LAN) SFP
    PIC 2 BUILTIN BUILTIN 2x 1GE(LAN) SFP
    MIC 3 BUILTIN BUILTIN 2x 10GE(LAN) SFP+
    PIC 3 BUILTIN BUILTIN 2x 10GE(LAN) SFP+
    Xcvr 0 OMPATI NON-JNPR FC2007131520 SFP+-10G-LR
    Xcvr 1 OMPATI NON-JNPR FC2007131591 SFP+-10G-LR

    juniper>

    show configuration
    juniper> show configuration | display set
    set version 19.4R3-S1.3
    set system root-authentication encrypted-password "$6$mVPMxYNJ$/BOnL9VtlRBX3if8zhYS4DB/z34RBkR48XsoeYmoDZeFwGI/4Q/29Xf6ORawWRLyaVPK02cC4ghcEIt.HbViG1"
    set system login user juniper uid 2007
    set system login user juniper class super-user
    set system login user juniper authentication encrypted-password "$6$sWbmzw9p$qHoCDWDzhQ/mgZLb2uz54fZC47mKiENGUbpqe.ePjdIuIVdIs7cBtL9r56dtW22XX0lGHVw9RuzYxdykGjxZE/"
    set system services ssh
    set system services telnet
    set system syslog user * any emergency
    set system syslog file messages any error
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set chassis network-services ip
    set interfaces xe-0/3/0 speed 10g
    set interfaces xe-0/3/0 unit 0 description To_CSR1-2_XE8
    set interfaces xe-0/3/0 unit 0 family inet address 10.110.10.10/30
    set interfaces xe-0/3/0 unit 0 family iso
    set interfaces xe-0/3/0 unit 0 family mpls
    set interfaces xe-0/3/1 speed 10g
    set interfaces xe-0/3/1 unit 0 description To_CSR1-4_XE0
    set interfaces xe-0/3/1 unit 0 family inet address 10.110.10.13/30
    set interfaces xe-0/3/1 unit 0 family iso
    set interfaces xe-0/3/1 unit 0 family mpls
    set interfaces fxp0 unit 0 family inet address 10.110.100.13/24
    set interfaces lo0 unit 0 family inet address 10.110.1.3/32
    set interfaces lo0 unit 0 family iso address 49.0017.0010.0110.0013.00
    set policy-options prefix-list term
    set policy-options policy-statement prefix-sid term 1 from route-filter 10.110.1.3/32 exact
    set policy-options policy-statement prefix-sid term 1 then prefix-segment index 13
    set policy-options policy-statement prefix-sid term 1 then prefix-segment node-segment
    set policy-options policy-statement prefix-sid term 1 then accept
    set protocols isis backup-spf-options remote-backup-calculation
    set protocols isis backup-spf-options node-link-degradation
    set protocols isis source-packet-routing
    set protocols isis level 1 authentication-key "$9$/rRmAuBEhyMWX"
    set protocols isis level 1 authentication-type md5
    set protocols isis level 1 wide-metrics-only
    set protocols isis interface xe-0/3/0.0 point-to-point
    set protocols isis interface xe-0/3/0.0 node-link-protection
    set protocols isis interface xe-0/3/0.0 family inet bfd-liveness-detection minimum-interval 10
    set protocols isis interface xe-0/3/0.0 family inet bfd-liveness-detection minimum-receive-interval 10
    set protocols isis interface xe-0/3/0.0 family inet bfd-liveness-detection multiplier 3
    set protocols isis interface xe-0/3/0.0 level 2 disable
    set protocols isis interface xe-0/3/0.0 ldp-synchronization
    set protocols isis interface xe-0/3/1.0 point-to-point
    set protocols isis interface xe-0/3/1.0 node-link-protection
    set protocols isis interface xe-0/3/1.0 family inet bfd-liveness-detection minimum-interval 3
    set protocols isis interface xe-0/3/1.0 family inet bfd-liveness-detection minimum-receive-interval 3
    set protocols isis interface xe-0/3/1.0 family inet bfd-liveness-detection multiplier 3
    set protocols isis interface xe-0/3/1.0 level 2 disable
    set protocols isis interface xe-0/3/1.0 ldp-synchronization
    set protocols isis interface all ldp-synchronization
    set protocols isis interface lo0.0 passive
    set protocols isis export prefix-sid
    set protocols isis lsp-lifetime 65535
    set protocols isis max-areas 36
    set protocols isis spf-options delay 200
    set protocols isis spf-options holddown 2000
    set protocols isis spf-options rapid-runs 5
    set protocols ldp interface xe-0/3/0.0
    set protocols ldp interface xe-0/3/1.0
    set protocols mpls interface all
    set protocols lldp interface all






    ------------------------------
    ASEEM RAI
    ------------------------------

    Attachment(s)



  • 4.  RE: Segment Routing support on ACX2200

     
    Posted 06-22-2021 05:45
    My lab is running ospf and am able to configure segment routing on the acx2200.

    But I wonder if the requirement may be to also have the configurations setup for source packet routing also under 
    protocols source-packet-routing 
    protocols mpls lsp-external-controller pccd
    protocols pcep pce SERVERNAME spring-capability (and other required parameters)

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 5.  RE: Segment Routing support on ACX2200

    Posted 06-22-2021 14:05
    hello Steve, 
    Thanks again for helping us out here . 
    I tried the "set protocols source-packet-routing" and the "protocols mpls lsp-external-controller pccd" , "protocols pcep pce SERVERNAME spring-capability" and its attributes, but still get the same error. 
    I was browsing through internet and could find the configuration "set chassis network-services enhanced-ip" helps resolve the issue. 
    But , in my ACX2200, i do not see an option to configure "enhanced ip"
    juniper# set chassis network-services ?
    Possible completions: >>>>>>>>>>>>>>>>> no "enhanced-ip" option showing up. 
    ethernet Ethernet network services
    ip IP network services
    [edit]
    juniper# set chassis network-services

    My show version shows : 
    juniper> show version
    Model: acx2200
    Junos: 19.4R3-S1.3
    JUNOS Base OS boot [19.4R3-S1.3]
    JUNOS Base OS Software Suite [19.4R3-S1.3]
    JUNOS Crypto Software Suite [19.4R3-S1.3]
    JUNOS Packet Forwarding Engine Support (ACX) [19.4R3-S1.3]
    JUNOS Web Management [19.4R3-S1.3]
    JUNOS Online Documentation [19.4R3-S1.3]
    JUNOS SDN Software Suite [19.4R3-S1.3]
    JUNOS Services Application Level Gateways [19.4R3-S1.3]
    JUNOS Services COS [19.4R3-S1.3]
    JUNOS Services Jflow Container package [19.4R3-S1.3]
    JUNOS Services Stateful Firewall [19.4R3-S1.3]
    JUNOS Services NAT [19.4R3-S1.3]
    JUNOS Services RPM [19.4R3-S1.3]
    JUNOS Services SOFTWIRE [19.4R3-S1.3]
    JUNOS Services Captive Portal and Content Delivery Container package [19.4R3-S1.3]
    JUNOS Macsec Software Suite [19.4R3-S1.3]
    JUNOS Services Crypto [19.4R3-S1.3]
    JUNOS Services IPSec [19.4R3-S1.3]
    JUNOS Services RTCOM [19.4R3-S1.3]
    JUNOS Services SSL [19.4R3-S1.3]
    JUNOS Services TCP-LOG [19.4R3-S1.3]
    JUNOS DP Crypto Software Software Suite [19.4R3-S1.3]
    JUNOS py-base-powerpc [19.4R3-S1.3]
    JUNOS py-base2-powerpc [19.4R3-S1.3]
    JUNOS py-extensions-powerpc [19.4R3-S1.3]
    JUNOS py-extensions2-powerpc [19.4R3-S1.3]
    JUNOS jsd [powerpc-19.4R3-S1.3-jet-1]
    JUNOS Kernel Software Suite [19.4R3-S1.3]
    JUNOS Routing Software Suite [19.4R3-S1.3]

    Is there a version problem ? 

    Thanks
    Aseem.

    ------------------------------
    ASEEM RAI
    ------------------------------



  • 6.  RE: Segment Routing support on ACX2200

     
    Posted 28 days ago
    The main difference with my lab is running ospf not isis so perhaps that is not supported on the acx2200.  Or the enable command is not in the format you are flagging that generates the error.

    Try using the ? inside the isis hierarchy to see what features are turned on.

    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------