Routing

Expand all | Collapse all

Which area database should an enternal LSA go for an ABR ?

Jump to Best Answer
  • 1.  Which area database should an enternal LSA go for an ABR ?

    Posted 11-27-2020 10:46
    I have the following topology.


    I exported ge-0/0/2.0 into ospf,  the external goes to area 1, why not go to area 0.  Juniper training seems mentioning export, I can't remember exactly what was mentioned.

    root@vMX2# run show ospf database extensive

    OSPF database, Area 0.0.0.0
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Router *172.16.12.2 172.16.12.2 0x80000001 15 0x22 0x9838 36
    bits 0x3, link count 1
    id 172.16.12.0, data 255.255.255.0, Type Stub (3)
    Topology count: 0, Default metric: 1
    Gen timer 00:49:45
    Aging timer 00:59:45
    Installed 00:00:15 ago, expires in 00:59:45
    Last changed 00:00:15 ago, Change count: 1, Ours
    Summary *172.16.23.0 172.16.12.2 0x80000002 11 0x22 0x1b81 28
    mask 255.255.255.0
    Topology default (ID 0) -> Metric: 1
    Gen timer 00:49:49
    Aging timer 00:59:49
    Installed 00:00:11 ago, expires in 00:59:49
    Last changed 00:00:11 ago, Change count: 1, Ours

    OSPF database, Area 0.0.0.1
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Router *172.16.12.2 172.16.12.2 0x80000001 15 0x22 0xfbc9 36
    bits 0x3, link count 1
    id 172.16.23.0, data 255.255.255.0, Type Stub (3)
    Topology count: 0, Default metric: 1
    Gen timer 00:49:45
    Aging timer 00:59:45
    Installed 00:00:15 ago, expires in 00:59:45
    Last changed 00:00:15 ago, Change count: 1, Ours
    Summary *172.16.12.0 172.16.12.2 0x80000002 11 0x22 0x9413 28
    mask 255.255.255.0
    Topology default (ID 0) -> Metric: 1
    Gen timer 00:49:49
    Aging timer 00:59:49
    Installed 00:00:11 ago, expires in 00:59:49
    Last changed 00:00:11 ago, Change count: 1, Ours
    OSPF AS SCOPE link state database
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Extern *172.16.24.0 172.16.12.2 0x80000001 15 0x22 0x7f93 36
    mask 255.255.255.0
    Topology default (ID 0)
    Type: 2, Metric: 0, Fwd addr: 0.0.0.0, Tag: 0.0.0.0
    Gen timer 00:49:45
    Aging timer 00:59:45
    Installed 00:00:15 ago, expires in 00:59:45
    Last changed 00:00:15 ago, Change count: 1, Ours

    thanks a lot in advance !!


  • 2.  RE: Which area database should an enternal LSA go for an ABR ?

     
    Posted 11-27-2020 14:59
    Can you post the configuration of your interfaces and ospf on the 3 routers, also whether the router id is configured under routing-options?  

    I am assuming the output of the show ospf database that you are showing is actually from vMX-2, is that correct? 

    Also, from the DB is looks like this is what you have:  

    Can you confirm?

    Regards, 



    ------------------------------
    Yasmin Lara
    Juniper Ambassador
    JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
    JNCDS-DC, JNCIA-DevOps, JNCIP-CLOUD, CCNP-ENT
    ------------------------------



  • 3.  RE: Which area database should an enternal LSA go for an ABR ?

    Posted 11-27-2020 15:06
    set version 14.1R1.10
    set system host-name vMX2
    set interfaces ge-0/0/0 unit 0 family inet address 172.16.23.2/24
    set interfaces ge-0/0/1 unit 0 family inet address 172.16.12.2/24
    set interfaces ge-0/0/2 unit 0 family inet address 172.16.24.2/24

    set protocols ospf export exp2OSPF
    set protocols ospf area 0.0.0.1 interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
    set policy-options policy-statement exp2OSPF term 1 from interface ge-0/0/2.0
    set policy-options policy-statement exp2OSPF term 1 then accept

    thanks !!

    I used to export external routes in a single area router. This time I happened to export routes in an ABR. So just curious.


  • 4.  RE: Which area database should an enternal LSA go for an ABR ?

     
    Posted 11-27-2020 15:38
    Your output is actually correct:

    OSPF AS SCOPE link state database     <= you are overlooking this line. This is not under AREA1. 
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Extern *172.16.24.0 172.16.12.2 0x80000001 15 0x22 0x7f93 36
    mask 255.255.255.0
    Topology default (ID 0)
    Type: 2, Metric: 0, Fwd addr: 0.0.0.0, Tag: 0.0.0.0
    Gen timer 00:49:45
    Aging timer 00:59:45
    Installed 00:00:15 ago, expires in 00:59:45
    Last changed 00:00:15 ago, Change count: 1, Ours

    Check the database on vMX1.  You will see that the EXTERNAL LSP is there. Should look similar to this: 

    ylara@R1# run show ospf database extensive instance vMX1 external

    OSPF AS SCOPE link state database
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Extern 172.16.24.0 172.16.12.2 0x80000002 125 0x22 0x7d94 36
    mask 255.255.255.0
    Topology default (ID 0)
    Type: 2, Metric: 0, Fwd addr: 0.0.0.0, Tag: 0.0.0.0
    Aging timer 00:57:55
    Installed 00:02:02 ago, expires in 00:57:55
    Last changed 00:13:54 ago, Change count: 1

    And the complete DB on vMX2 should look similar to this: 

    ylara@R1# run show ospf database extensive instance vMX2
    OSPF database, Area 0.0.0.0
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Router 172.16.12.1 172.16.12.1 0x80000003 251 0x22 0x7791 36
    bits 0x0, link count 1
    id 172.16.12.2, data 172.16.12.1, Type Transit (2)
    Topology count: 0, Default metric: 1
    Topology default (ID 0)
    Type: Transit, Node ID: 172.16.12.2
    Metric: 1, Bidirectional
    Aging timer 00:55:48
    Installed 00:04:08 ago, expires in 00:55:49
    Last changed 00:04:08 ago, Change count: 2
    Router *172.16.12.2 172.16.12.2 0x80000003 250 0x22 0x7e84 36
    bits 0x3, link count 1
    id 172.16.12.2, data 172.16.12.2, Type Transit (2)
    Topology count: 0, Default metric: 1
    Topology default (ID 0)
    Type: Transit, Node ID: 172.16.12.2
    Metric: 1, Bidirectional
    Gen timer 00:45:50
    Aging timer 00:55:49
    Installed 00:04:10 ago, expires in 00:55:50, sent 00:04:08 ago
    Last changed 00:04:10 ago, Change count: 2, Ours
    Network *172.16.12.2 172.16.12.2 0x80000001 250 0x22 0x1ff0 32
    mask 255.255.255.0
    attached router 172.16.12.2
    attached router 172.16.12.1
    Topology default (ID 0)
    Type: Transit, Node ID: 172.16.12.1
    Metric: 0, Bidirectional
    Type: Transit, Node ID: 172.16.12.2
    Metric: 0, Bidirectional
    Gen timer 00:45:49
    Aging timer 00:55:49
    Installed 00:04:10 ago, expires in 00:55:50, sent 00:04:08 ago
    Last changed 00:04:10 ago, Change count: 1, Ours
    Summary *172.16.23.0 172.16.12.2 0x80000003 250 0x22 0x1982 28
    mask 255.255.255.0
    Topology default (ID 0) -> Metric: 1
    Gen timer 00:45:50
    Aging timer 00:55:50
    Installed 00:04:10 ago, expires in 00:55:50, sent 00:04:08 ago
    Last changed 00:04:54 ago, Change count: 1, Ours
    OSPF database, Area 0.0.0.1
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Router *172.16.12.2 172.16.12.2 0x80000003 250 0x22 0x6786 36
    bits 0x3, link count 1
    id 172.16.23.1, data 172.16.23.2, Type Transit (2)
    Topology count: 0, Default metric: 1
    Topology default (ID 0)
    Type: Transit, Node ID: 172.16.23.1
    Metric: 1, Bidirectional
    Gen timer 00:45:50
    Aging timer 00:55:50
    Installed 00:04:10 ago, expires in 00:55:50, sent 00:04:08 ago
    Last changed 00:04:10 ago, Change count: 2, Ours
    Router 172.16.23.1 172.16.23.1 0x80000003 251 0x22 0x9944 36
    bits 0x0, link count 1
    id 172.16.23.1, data 172.16.23.1, Type Transit (2)
    Topology count: 0, Default metric: 1
    Topology default (ID 0)
    Type: Transit, Node ID: 172.16.23.1
    Metric: 1, Bidirectional
    Aging timer 00:55:49
    Installed 00:04:08 ago, expires in 00:55:49
    Last changed 00:04:08 ago, Change count: 2
    Network 172.16.23.1 172.16.23.1 0x80000001 256 0x22 0xcf21 32
    mask 255.255.255.0
    attached router 172.16.23.1
    attached router 172.16.12.2
    Topology default (ID 0)
    Type: Transit, Node ID: 172.16.12.2
    Metric: 0, Bidirectional
    Type: Transit, Node ID: 172.16.23.1
    Metric: 0, Bidirectional
    Aging timer 00:55:44
    Installed 00:04:13 ago, expires in 00:55:44
    Last changed 00:04:13 ago, Change count: 1
    Summary *172.16.12.0 172.16.12.2 0x80000004 245 0x22 0x9015 28
    mask 255.255.255.0
    Topology default (ID 0) -> Metric: 1
    Gen timer 00:45:55
    Aging timer 00:55:55
    Installed 00:04:05 ago, expires in 00:55:55, sent 00:04:03 ago
    Last changed 00:04:54 ago, Change count: 1, Ours
    OSPF AS SCOPE link state database
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Extern *172.16.24.0 172.16.12.2 0x80000001 295 0x22 0x7f93 36
    mask 255.255.255.0
    Topology default (ID 0)
    Type: 2, Metric: 0, Fwd addr: 0.0.0.0, Tag: 0.0.0.0
    Gen timer 00:45:05
    Aging timer 00:55:05
    Installed 00:04:55 ago, expires in 00:55:05, sent 00:04:10 ago
    Last changed 00:04:55 ago, Change count: 1, Ours



    ------------------------------
    Yasmin Lara
    Juniper Ambassador
    JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
    JNCDS-DC, JNCIA-DevOps, JNCIP-CLOUD, CCNP-ENT
    ------------------------------



  • 5.  RE: Which area database should an enternal LSA go for an ABR ?
    Best Answer

     
    Posted 11-27-2020 15:59

    This makes it easier to see:

    ylara@R1> show ospf database instance vMX2

    OSPF database, Area 0.0.0.0
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Router 172.16.12.1 172.16.12.1 0x80000003 1997 0x22 0x7791 36
    Router *172.16.12.2 172.16.12.2 0x80000004 368 0x22 0x7c85 36
    Network *172.16.12.2 172.16.12.2 0x80000002 827 0x22 0x1df1 32
    Summary *172.16.23.0 172.16.12.2 0x80000003 1996 0x22 0x1982 28
    OSPF database, Area 0.0.0.1
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Router *172.16.12.2 172.16.12.2 0x80000003 1996 0x22 0x6786 36
    Router 172.16.23.1 172.16.23.1 0x80000003 1997 0x22 0x9944 36
    Network 172.16.23.1 172.16.23.1 0x80000001 2002 0x22 0xcf21 32
    Summary *172.16.12.0 172.16.12.2 0x80000004 1991 0x22 0x9015 28
    OSPF AS SCOPE link state database
    Type ID Adv Rtr Seq Age Opt Cksum Len
    Extern *172.16.24.0 172.16.12.2 0x80000002 1286 0x22 0x7d94 36



    ------------------------------
    Yasmin Lara
    Juniper Ambassador
    JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
    JNCDS-DC, JNCIA-DevOps, JNCIP-CLOUD, CCNP-ENT
    ------------------------------



  • 6.  RE: Which area database should an enternal LSA go for an ABR ?

    Posted 11-27-2020 16:24
    thanks a million !!


  • 7.  RE: Which area database should an enternal LSA go for an ABR ?

    Posted 11-27-2020 16:24
    thanks so much for help!!


  • 8.  RE: Which area database should an enternal LSA go for an ABR ?

    Posted 11-28-2020 02:47
    External LSA / type-5  has AS scope, which means that is not bound to a particular area in the database. As such, flooding is done for the entire OSPF domain, which means that the ASBR redistributing/exporting the route generates it and all other routes should be able to observe the type-5 LSA unless the area is a stub.

    Elvin