Routing

Expand all | Collapse all

bgp.l2vpn.0 prefix format assistance

  • 1.  bgp.l2vpn.0 prefix format assistance

    Posted 10 days ago
    I have the following:
    root@PE1# show routing-instances | display set
    set routing-instances CustA instance-type l2vpn
    set routing-instances CustA interface ge-0/0/1.0
    set routing-instances CustA interface ge-0/0/2.521
    set routing-instances CustA interface ge-0/0/2.522
    set routing-instances CustA interface ge-0/0/3.531
    set routing-instances CustA interface ge-0/0/3.532
    set routing-instances CustA route-distinguisher 192.168.100.1:1
    set routing-instances CustA vrf-target target:65100:65100
    set routing-instances CustA protocols l2vpn encapsulation-type ethernet-vlan
    set routing-instances CustA protocols l2vpn site Local-site-1 site-identifier 1
    set routing-instances CustA protocols l2vpn site Local-site-1 interface ge-0/0/2.521
    set routing-instances CustA protocols l2vpn site Local-site-1 interface ge-0/0/2.522
    set routing-instances CustA protocols l2vpn site Local-site-1 interface ge-0/0/3.531
    set routing-instances CustA protocols l2vpn site Local-site-6 site-identifier 6
    set routing-instances CustA protocols l2vpn site Local-site-6 interface ge-0/0/3.532 remote-site-id 7

    [edit]
    root@PE1# run show route table bgp.l2vpn.0

    bgp.l2vpn.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    192.168.100.2:2:2:1/96
    *[BGP/170] 00:04:14, localpref 100, from 192.168.100.2
    AS path: I, validation-state: unverified
    > to 172.16.11.11 via ge-0/0/0.0, Push 299824
    192.168.100.2:2:3:1/96
    *[BGP/170] 00:04:14, localpref 100, from 192.168.100.2
    AS path: I, validation-state: unverified
    > to 172.16.11.11 via ge-0/0/0.0, Push 299824
    192.168.100.2:2:4:1/96
    *[BGP/170] 00:04:14, localpref 100, from 192.168.100.2
    AS path: I, validation-state: unverified
    > to 172.16.11.11 via ge-0/0/0.0, Push 299824
    192.168.100.2:2:7:5/96
    *[BGP/170] 00:04:14, localpref 100, from 192.168.100.2
    AS path: I, validation-state: unverified
    > to 172.16.11.11 via ge-0/0/0.0, Push 299824

    The prefix here is formatted  route-distinguisger:remote site-identifier:local site-identifier,  right ?

    I configured Local-site-6 site identifier  6,  why bgp prefix is 5 ?

    thanks in advance !!


  • 2.  RE: bgp.l2vpn.0 prefix format assistance

     
    Posted 10 days ago
    How did you configure the router you are getting these routes from?

    ------------------------------
    Yasmin Lara
    Juniper Ambassador
    JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
    JNCDS-DC, JNCIA-DevOps, JNCIP-CLOUD, CCNP-ENT
    ------------------------------



  • 3.  RE: bgp.l2vpn.0 prefix format assistance

    Posted 10 days ago


    On PE1, I have the following:
    set version 14.1R1.10
    set system host-name PE1
    set system root-authentication encrypted-password "$1$DFK0oNJK$Id3W0ZNx.cOTXEdzt2jZr/"
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces ge-0/0/0 unit 0 family inet address 172.16.11.1/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 encapsulation ethernet-ccc
    set interfaces ge-0/0/1 unit 0 family ccc
    set interfaces ge-0/0/2 vlan-tagging
    set interfaces ge-0/0/2 encapsulation vlan-ccc
    set interfaces ge-0/0/2 unit 521 encapsulation vlan-ccc
    set interfaces ge-0/0/2 unit 521 vlan-id 521
    set interfaces ge-0/0/2 unit 521 family ccc
    set interfaces ge-0/0/2 unit 522 encapsulation vlan-ccc
    set interfaces ge-0/0/2 unit 522 vlan-id 522
    set interfaces ge-0/0/2 unit 522 family ccc
    set interfaces ge-0/0/3 flexible-vlan-tagging
    set interfaces ge-0/0/3 encapsulation flexible-ethernet-services
    set interfaces ge-0/0/3 unit 531 encapsulation vlan-ccc
    set interfaces ge-0/0/3 unit 531 vlan-id 531
    set interfaces ge-0/0/3 unit 532 encapsulation vlan-ccc
    set interfaces ge-0/0/3 unit 532 vlan-id 532
    set interfaces lo0 unit 0 family inet address 192.168.100.1/32
    set routing-options autonomous-system 65100
    set protocols mpls interface ge-0/0/0.0
    set protocols mpls interface lo0.0
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 192.168.100.1
    set protocols bgp group iBGP family l2vpn signaling
    set protocols bgp group iBGP neighbor 192.168.100.2
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0 interface-type p2p
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface lo0.0
    set routing-instances CustA instance-type l2vpn
    set routing-instances CustA interface ge-0/0/1.0
    set routing-instances CustA interface ge-0/0/2.521
    set routing-instances CustA interface ge-0/0/2.522
    set routing-instances CustA interface ge-0/0/3.531
    set routing-instances CustA interface ge-0/0/3.532
    set routing-instances CustA route-distinguisher 192.168.100.1:1
    set routing-instances CustA vrf-target target:65100:65100
    set routing-instances CustA protocols l2vpn encapsulation-type ethernet-vlan
    set routing-instances CustA protocols l2vpn site Local-site-1 site-identifier 1
    set routing-instances CustA protocols l2vpn site Local-site-1 interface ge-0/0/2.521
    set routing-instances CustA protocols l2vpn site Local-site-1 interface ge-0/0/2.522
    set routing-instances CustA protocols l2vpn site Local-site-1 interface ge-0/0/3.531
    set routing-instances CustA protocols l2vpn site Local-site-6 site-identifier 6
    set routing-instances CustA protocols l2vpn site Local-site-6 interface ge-0/0/3.532 remote-site-id 7

    On PE2

    root@PE2# show | display set
    set version 14.1R1.10
    set system host-name PE2
    set system root-authentication encrypted-password "$1$FaoNFyMG$r0Y/YidBzDPlYZWUZudCR."
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set interfaces ge-0/0/0 unit 0 family inet address 172.16.22.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/1 encapsulation ethernet-ccc
    set interfaces ge-0/0/1 unit 0 family ccc
    set interfaces ge-0/0/2 vlan-tagging
    set interfaces ge-0/0/2 encapsulation vlan-ccc
    set interfaces ge-0/0/2 unit 521 encapsulation vlan-ccc
    set interfaces ge-0/0/2 unit 521 vlan-id 521
    set interfaces ge-0/0/2 unit 521 family ccc
    set interfaces ge-0/0/2 unit 522 encapsulation vlan-ccc
    set interfaces ge-0/0/2 unit 522 vlan-id 522
    set interfaces ge-0/0/2 unit 522 family ccc
    set interfaces ge-0/0/3 flexible-vlan-tagging
    set interfaces ge-0/0/3 encapsulation flexible-ethernet-services
    set interfaces ge-0/0/3 unit 531 encapsulation vlan-ccc
    set interfaces ge-0/0/3 unit 531 vlan-id 531
    set interfaces ge-0/0/3 unit 532 encapsulation vlan-ccc
    set interfaces ge-0/0/3 unit 532 vlan-id 532
    set interfaces lo0 unit 0 family inet address 192.168.100.2/32
    set routing-options autonomous-system 65100
    set protocols mpls interface lo0.0
    set protocols mpls interface ge-0/0/0.0
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 192.168.100.2
    set protocols bgp group iBGP family l2vpn signaling
    set protocols bgp group iBGP neighbor 192.168.100.1
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0 interface-type p2p
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface lo0.0
    set routing-instances CustA instance-type l2vpn
    set routing-instances CustA interface ge-0/0/2.521
    set routing-instances CustA interface ge-0/0/2.522
    set routing-instances CustA interface ge-0/0/3.531
    set routing-instances CustA interface ge-0/0/3.532
    set routing-instances CustA route-distinguisher 192.168.100.2:2
    set routing-instances CustA vrf-target target:65100:65100
    set routing-instances CustA protocols l2vpn encapsulation-type ethernet-vlan
    set routing-instances CustA protocols l2vpn site Local-Site-3 site-identifier 3
    set routing-instances CustA protocols l2vpn site Local-Site-3 interface ge-0/0/2.522
    set routing-instances CustA protocols l2vpn site Local-Site-2 site-identifier 2
    set routing-instances CustA protocols l2vpn site Local-Site-2 interface ge-0/0/2.521
    set routing-instances CustA protocols l2vpn site Local-Site-4 site-identifier 4
    set routing-instances CustA protocols l2vpn site Local-Site-4 interface ge-0/0/3.531
    set routing-instances CustA protocols l2vpn site Local-Site-7 site-identifier 7
    set routing-instances CustA protocols l2vpn site Local-Site-7 interface ge-0/0/3.532 remote-site-id 6

    Also I do not quite understand, on PE2, I get the following:

    root@PE2# run show route table bgp.l2vpn.0

    bgp.l2vpn.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    192.168.100.1:1:1:1/96                                                                               why both are 1, because of auto-provision ?
    *[BGP/170] 01:05:39, localpref 100, from 192.168.100.1
    AS path: I, validation-state: unverified
    > to 172.16.22.22 via ge-0/0/0.0, Push 299808
    192.168.100.1:1:6:7/96                                                                           On PE2,  remote is 6. that is what I expect to see. 
    *[BGP/170] 01:05:39, localpref 100, from 192.168.100.1
    AS path: I, validation-state: unverified
    > to 172.16.22.22 via ge-0/0/0.0, Push 299808

    thanks a lot !!!