Routing

Expand all | Collapse all

BGP BFD session question

  • 1.  BGP BFD session question

    Posted 12-05-2020 14:09
    I have the following:
    lab@vmx2# show protocols bgp | display set
    set protocols bgp group ToIPS2 type external
    set protocols bgp group ToIPS2 traceoptions file bgp-log
    set protocols bgp group ToIPS2 traceoptions flag all
    deactivate protocols bgp group ToIPS2 traceoptions
    set protocols bgp group ToIPS2 multihop
    set protocols bgp group ToIPS2 local-address 192.168.0.2
    set protocols bgp group ToIPS2 export exp2ISP2
    set protocols bgp group ToIPS2 neighbor 172.16.200.176 peer-as 2222
    set protocols bgp group iBGP apply-groups BFD
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 192.168.0.2
    set protocols bgp group iBGP cluster 192.168.0.2
    set protocols bgp group iBGP allow 192.168.0.0/29
    set protocols bgp group Cluster type internal
    set protocols bgp group Cluster local-address 192.168.0.2
    set protocols bgp group Cluster neighbor 192.168.0.1

    [edit]
    lab@vmx2# run show bfd session
    Detect Transmit
    Address State Interface Time Interval Multiplier
    192.168.0.1 Up 2.700 0.900 3
    192.168.0.3 Up 2.700 0.900 3
    192.168.0.4 Up 2.700 0.900 3

    3 sessions, 3 clients
    Cumulative transmit rate 3.3 pps, cumulative receive rate 3.3 pps

    [edit]
    lab@vmx2# run show bgp neighbor 192.168.0.1 | match Bfd
    Options: <BfdEnabled>
    BFD: enabled, up
    BFD: disabled, down

    [edit]

    I did not apply BFD group to neighbor 192.168.0.1,  why does this neighbor still have BFD enabled ?

    thanks in advance !!


  • 2.  RE: BGP BFD session question

     
    Posted 12-05-2020 23:16
    Are you sure the group is not applied somehow?

    try #show protocols bgp group  Cluster | display inheritance.

    Also, since you have allow 192.168.0.0/29, it is possible that the session you are seeing with 192.168.0.1 was actually initiated by 192.168.0.1, and accepted by vMX2 under group iBGP. 

    try #run show bgp group

    Regards, 
    ​​

    ------------------------------
    Yasmin Lara
    Juniper Ambassador
    JNCIE-SP, JNCIE-ENT, JNCIE-DC, JNCIE-SEC
    JNCDS-DC, JNCIA-DevOps, JNCIP-CLOUD, CCNP-ENT
    ------------------------------



  • 3.  RE: BGP BFD session question

    Posted 12-06-2020 00:09
    thanks a lot !!

    The lab was over.  I will start the lab tomorrow and remove allow statement to give a try.  For the Cluster group, I did not apply BFD group. As the lab instruction states BFD should not be applied to that pair of BGP peers.


  • 4.  RE: BGP BFD session question

    Posted 12-07-2020 13:15
    I tested it again in my virtual lab.  seems working as I expect

    root@vMX2> show bfd session
    Detect Transmit
    Address State Interface Time Interval Multiplier
    192.168.0.3 Up 2.700 0.900 3
    192.168.0.4 Up 2.700 0.900 3

    2 sessions, 2 clients
    Cumulative transmit rate 2.2 pps, cumulative receive rate 2.2 pps

    root@vMX2> show configuration protocols bgp | display set
    set protocols bgp group iBGP apply-groups BFD
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 192.168.0.2
    set protocols bgp group iBGP cluster 192.168.0.2
    set protocols bgp group iBGP allow 192.168.0.0/29
    set protocols bgp group RR type internal
    set protocols bgp group RR local-address 192.168.0.2
    set protocols bgp group RR neighbor 192.168.0.1

    I will pay more attention next time when I do the Juniper Training Lab.

    thanks !!