Routing

Expand all | Collapse all

DHCP Server assistance needed

  • 1.  DHCP Server assistance needed

    Posted 12-19-2020 14:09

    I have three juniper devices as follows:

    DHCP client ---10.100.100.0/24 ---- DHCP relay ----10.100.56.0/24 ---- DHCP Server

    If I added one interface on DHCP relay for DHCP client, it receives IP from DHCP server, but DHCP client can't receive IP via relay agent. DHCP server sees the replay discover packet, but no response.

    Any insights ?

    thanks in advance.

    The configuration is as follows:

    DHCP server

    set access address-assignment pool vlan56 family inet network 10.100.56.0/24
    set access address-assignment pool vlan56 family inet range r1 low 10.100.56.20
    set access address-assignment pool vlan56 family inet range r1 high 10.100.56.30
    set access address-assignment pool vlan100 family inet network 10.100.100.0/24
    set access address-assignment pool vlan100 family inet range r1 low 10.100.100.20
    set access address-assignment pool vlan100 family inet range r1 high 10.100.100.30

    set system services dhcp-local-server group jncie interface irb.56
    set system services dhcp pool 10.100.100.0/24 address-range low 10.100.100.25
    set system services dhcp pool 10.100.100.0/24 address-range high 10.100.100.30
    set system services dhcp pool 10.100.100.0/24 router 10.100.100.254

    DHCP Relay agent

    set forwarding-options dhcp-relay overrides
    set forwarding-options dhcp-relay server-group jncie 10.100.56.254
    set forwarding-options dhcp-relay group jncie active-server-group jncie
    set forwarding-options dhcp-relay group jncie interface irb.100

    My another question is:

    Does DHCP server handle the DHCP discover from the relay agent differently from the direct connection network ?

    The first two lines from the relay agent.

    The last four from the device directly connected.

    Do I need some special configuration to handle the DHCP discovery from the relay agent ?

    thanks !!



  • 2.  RE: DHCP Server assistance needed

    Posted 12-19-2020 21:01

    Anyone saw this  following

    Dec 20 01:31:07.649976 [MSTR][DEBUG][default:default][SVR][INET][irb.56] jdhcpd_find_client_from_client_pdu: BOOTPREQUEST could not find client table ent

    Dec 20 01:31:07.649986 [MSTR][NOTE] [default:default][SVR][INET][irb.56] jdhcpd_packet_handle: BOOTPREQUEST dropping snooped pkt to the local server

    I have the same configuration on QFX5100, it works.

    But on vMX, it got the above in the dhcp log.

    thanks !!



  • 3.  RE: DHCP Server assistance needed

    Posted 12-19-2020 22:22
    -------------------------------------------
    Original Message:
    Sent: 12-19-2020 21:00
    From: Unknown User
    Subject: DHCP Server assistance needed




  • 4.  RE: DHCP Server assistance needed

    Posted 12-21-2020 02:36

    Hi,

    I can provide my working setup but it runs on SRX. The major difference should be the host inbound. But if you are using MX, then you might have a firewall filter to prevent traffic to reach the RE as well? - If so, remember to permit the traffic in both directions.

    I hope this will provide some clarity;

     Configure the DHCP-server-settings.

    set access address-assignment pool local-jdhcpd-pool family inet network 172.26.3.0/27
    set access address-assignment pool local-jdhcpd-pool family inet range dhcp-range low 172.26.3.1
    set access address-assignment pool local-jdhcpd-pool family inet range dhcp-range high 172.26.3.10
    set access address-assignment pool local-jdhcpd-pool family inet dhcp-attributes maximum-lease-time 172800
    set access address-assignment pool local-jdhcpd-pool family inet dhcp-attributes router 172.26.3.30
    set access address-assignment pool local-jdhcpd-pool family inet dhcp-attributes propagate-settings ge-0/0/0.0
    set access address-assignment pool local-jdhcpd-pool family inet host PRINTER hardware-address d2:22:22:2a:77:f0
    set access address-assignment pool local-jdhcpd-pool family inet host PRINTER ip-address 172.26.3.20

    Enable jDHCPd on an interface, in this case the irb (vlan-interface)
    Edit
    set routing-instances client_sto01-vr system services dhcp-local-server group SRX-JDHCPD interface irb.0

    Also enable the required things on the interface/zone (SRX specific)
    Edit
    set security zones security-zone Users host-inbound-traffic system-services ping
    set security zones security-zone Users host-inbound-traffic system-services dhcp
    set security zones security-zone Users interfaces irb.0

    Configure the switched user interfaces on the device (if i recall it correctly, switched interface is a must for this to work.. but not quite sure)
    Edit
    set interfaces ge-0/0/1 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members LAN10
    set interfaces ge-0/0/1 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/1 unit 0 family ethernet-switching recovery-timeout 1200
    set forwarding-options storm-control-profiles default all
    set protocols l2-learning global-mode switching
    set vlans LAN10 description Users
    set vlans LAN10 vlan-id 10
    set vlans LAN10 l3-interface irb.0

    //Rob




  • 5.  RE: DHCP Server assistance needed

    Posted 12-21-2020 09:36

    thanks so much !!

    vMX might have some limitation on this.