Routing

 View Only

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Need assistance for IPV6 via MPLS

    Posted 03-18-2022 05:43
    I have the following topology:
    I am working a 6PE lab. The routing tables seem right. But ping stops at egress PE routers. PE router does not route IPv6 prefix to the CE routers. The followings are my configuration.
    Anyone can help me to take a look. I am not sure whether this is related to vMX.
    root@CE2# show | display setset version 14.1R1.10
    set interfaces ge-0/0/2 unit 0 family inet address 192.168.0.30/30
    set interfaces ge-0/0/2 unit 0 family inet6 address fc09:c0:ffee::2/126
    set interfaces lo0 unit 0 family inet address 22.22.22.22/32
    set interfaces lo0 unit 0 family inet6 address fd01:bbbb:2222:0:f::2/128
    set routing-options router-id 22.22.22.22
    set routing-options autonomous-system 2222
    set protocols bgp group To_PE1 type external
    set protocols bgp group To_PE1 family inet unicast
    set protocols bgp group To_PE1 export expLo0
    set protocols bgp group To_PE1 neighbor 192.168.0.29 peer-as 65535
    set protocols bgp group To_PE1v6 type external
    set protocols bgp group To_PE1v6 export expLo0
    set protocols bgp group To_PE1v6 neighbor fc09:c0:ffee::1 peer-as 65535
    set policy-options policy-statement expLo0 term 1 from interface lo0.0
    set policy-options policy-statement expLo0 term 1 then accept
    set policy-options policy-statement expLo0 term 2 from family inet6
    set policy-options policy-statement expLo0 term 2 from interface lo0.0
    set policy-options policy-statement expLo0 term 2 then accept
    
    ​
    root@PE1# show | display set
    set interfaces ge-0/0/2 unit 0 family inet address 192.168.0.29/30
    set interfaces ge-0/0/2 unit 0 family inet6 address fc09:c0:ffee::1/126
    set interfaces ge-0/0/6 unit 0 family inet address 10.0.0.6/30
    set interfaces ge-0/0/6 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 1.1.1.1/32
    set interfaces lo0 unit 0 family inet6 address fd02:aaaa:1111:0:f::1/128
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols ospf area 0.0.0.0 interface ge-0/0/6.0
    set protocols mpls ipv6-tunneling
    set protocols mpls interface ge-0/0/6.0
    set protocols ldp interface ge-0/0/6.0
    
    set routing-options router-id 1.1.1.1
    set routing-options autonomous-system 65535
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 1.1.1.1
    set protocols bgp group iBGP family inet unicast
    set protocols bgp group iBGP family inet6 labeled-unicast explicit-null
    set protocols bgp group iBGP neighbor 3.3.3.3
    set protocols bgp group To_CE2 type external
    set protocols bgp group To_CE2 family inet unicast
    set protocols bgp group To_CE2 neighbor 192.168.0.30 peer-as 2222
    set protocols bgp group To_CE2v6 family inet6 unicast
    set protocols bgp group To_CE2v6 neighbor fc09:c0:ffee::2 peer-as 2222
    
    root@PE2# show | display set
    set interfaces ge-0/0/3 unit 0 family inet address 192.168.3.1/30
    set interfaces ge-0/0/3 unit 0 family inet6 address ::192.168.3.1/126
    set interfaces ge-0/0/7 unit 0 family inet address 10.0.0.10/30
    set interfaces ge-0/0/7 unit 0 family mpls
    set interfaces lo0 unit 0 family inet address 3.3.3.3/32
    set interfaces lo0 unit 0 family inet6 address fd02:cccc:3333:0:f::3/128
    set protocols ospf area 0.0.0.0 interface lo0.0 passive
    set protocols ospf area 0.0.0.0 interface ge-0/0/7.0
    set protocols mpls ipv6-tunneling
    set protocols mpls interface ge-0/0/7.0
    set protocols ldp interface ge-0/0/7.0
    
    set routing-options router-id 3.3.3.3
    set routing-options autonomous-system 65535
    set protocols bgp group To_CE3 type external
    set protocols bgp group To_CE3 accept-remote-nexthop
    set protocols bgp group To_CE3 import NHS
    set protocols bgp group To_CE3 family inet unicast
    set protocols bgp group To_CE3 family inet6 unicast
    set protocols bgp group To_CE3 export NHSv6
    set protocols bgp group To_CE3 neighbor 192.168.3.2 peer-as 3333
    set protocols bgp group iBGP type internal
    set protocols bgp group iBGP local-address 3.3.3.3
    set protocols bgp group iBGP family inet unicast
    set protocols bgp group iBGP family inet6 labeled-unicast explicit-null
    set protocols bgp group iBGP neighbor 1.1.1.1
    set policy-options policy-statement NHS term 1 from protocol bgp
    set policy-options policy-statement NHS term 1 from rib inet6.0
    set policy-options policy-statement NHS term 1 then next-hop ::192.168.3.2
    set policy-options policy-statement NHS term 1 then accept
    set policy-options policy-statement NHSv6 term 1 from family inet6
    set policy-options policy-statement NHSv6 term 1 from protocol bgp
    set policy-options policy-statement NHSv6 term 1 then next-hop ::192.168.3.1
    set policy-options policy-statement NHSv6 term 1 then accept
    
    root@CE3# show | display set
    set interfaces ge-0/0/3 unit 0 family inet address 192.168.3.2/30
    set interfaces ge-0/0/3 unit 0 family inet6 address ::192.168.3.2/126
    set interfaces lo0 unit 0 family inet address 33.33.33.33/32
    set interfaces lo0 unit 0 family inet6 address fd01:cccc:3333:0:f::3/128
    set routing-options router-id 33.33.33.33
    set routing-options autonomous-system 3333
    set protocols bgp group To_PE2 type external
    set protocols bgp group To_PE2 family inet unicast
    set protocols bgp group To_PE2 family inet6 unicast
    set protocols bgp group To_PE2 export exp2bgp
    set protocols bgp group To_PE2 neighbor 192.168.3.1 peer-as 65535
    set policy-options policy-statement exp2bgp term 1 from interface lo0.0
    set policy-options policy-statement exp2bgp term 1 then accept
    
    
    Verification
    root@PE1# run show route advertising-protocol bgp fc09:c0:ffee::2
    
    inet6.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
      Prefix                  Nexthop              MED     Lclpref    AS path
      fd01:cccc:3333:0:f::3/128
    *                         Self                                    3333 I
    
    root@CE2# run show route table inet6.0 protocol bgp
    
    inet6.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    fd01:cccc:3333:0:f::3/128
                       *[BGP/170] 00:21:14, localpref 100
                          AS path: 65535 3333 I, validation-state: unverified
                        > to fc09:c0:ffee::1 via ge-0/0/2.0
    
    root@PE2# run show route advertising-protocol bgp 192.168.3.2 table inet6.0
    
    inet6.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
      Prefix                  Nexthop              MED     Lclpref    AS path
      fd01:bbbb:2222:0:f::2/128
    *                         ::192.168.3.1                           2222 I
    
    root@CE3# run show route table inet6.0 protocol bgp
    
    inet6.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both
    
    fd01:bbbb:2222:0:f::2/128
                       *[BGP/170] 00:29:36, localpref 100, from 192.168.3.1
                          AS path: 65535 2222 I, validation-state: unverified
                        > to ::192.168.3.1 via ge-0/0/3.0
    
    
    root@CE2# run ping fd01:cccc:3333:0:f::3 source fd01:bbbb:2222:0:f::2
    PING6(56=40+8+8 bytes) fd01:bbbb:2222:0:f::2 --> fd01:cccc:3333:0:f::3
    
    
    
    
    
    

    The following is a capture on PE2 port ge-0/0/7


    The packets are not routed out of ge-0/0/3

    thanks for any insight !!!


  • 2.  RE: Need assistance for IPV6 via MPLS

    Posted 03-18-2022 13:57
    Got it working.  missed family inet6 on the core facing interfaces.  thanks for the previous post here in the community


  • 3.  RE: Need assistance for IPV6 via MPLS

    Posted 03-18-2022 13:58
    got it working.  Missed family inet6 on the core facing interfaces.  thanks for the previous post here in the community.