Routing

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

how to configure mx evpn type 5 route with vxlan encapsulation

  • 1.  how to configure mx evpn type 5 route with vxlan encapsulation

    Posted 06-23-2021 05:39
    Dear expert;

    topology ce1--------pe1-------pe2------ce2

    pes vmx version are Junos: 21.1R1.11

    pe1----pe2  establish EVPN type 5 route, ce1 and pe1 loopback in VRF can't ping each other. I show routing table is good.


    root@pe-1> ping routing-instance vxlan-1 2.2.2.2 source 1.1.1.1
    PING 2.2.2.2 (2.2.2.2): 56 data bytes
    ^C
    --- 2.2.2.2 ping statistics ---
    3 packets transmitted, 0 packets received, 100% packet loss




    root@pe-1> show route table vxlan-1.

    vxlan-1.inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    1.1.1.1/32 *[Direct/0] 22:55:56
    > via lo0.1
    2.2.2.2/32 *[EVPN/170] 22:23:33
    > to 10.0.12.2 via ge-0/0/0.0
    10.0.13.0/24 *[Direct/0] 22:54:02
    > via ge-0/0/2.0
    10.0.13.1/32 *[Local/0] 22:54:02
    Local via ge-0/0/2.0
    10.0.24.0/24 *[EVPN/170] 22:23:33
    > to 10.0.12.2 via ge-0/0/0.0
    10.0.24.2/32 *[EVPN/170] 22:23:33
    > to 10.0.12.2 via ge-0/0/0.0
    22.22.22.0/24 *[EVPN/170] 22:15:53
    > to 10.0.12.2 via ge-0/0/0.0
    192.168.0.0/24 *[Static/5] 22:54:02
    > to 10.0.13.2 via ge-0/0/2.0



    set interfaces ge-0/0/0 unit 0 family inet address 10.0.12.1/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/2 unit 0 family inet address 10.0.13.1/24
    set interfaces irb unit 2 family inet address 10.0.13.1/24
    set interfaces lo0 unit 0 family inet address 10.0.0.1/32
    set interfaces lo0 unit 1 family inet address 1.1.1.1/32
    set policy-options policy-statement evpn-in term 1 then accept
    set policy-options policy-statement evpn-out term 1 then accept
    set routing-instances vxlan-1 instance-type vrf
    set routing-instances vxlan-1 routing-options static route 192.168.0.0/24 next-hop 10.0.13.2
    set routing-instances vxlan-1 routing-options static route 222.0.0.0/24 next-hop 10.0.24.4
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes advertise direct-nexthop
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes encapsulation vxlan
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes vni 5000
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes import evpn-in
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes export evpn-out
    set routing-instances vxlan-1 vtep-source-interface lo0.0
    set routing-instances vxlan-1 remote-vtep-list 10.0.0.2
    set routing-instances vxlan-1 interface ge-0/0/2.0
    set routing-instances vxlan-1 interface lo0.1
    set routing-instances vxlan-1 route-distinguisher 20004:1
    set routing-instances vxlan-1 vrf-target target:20004:1
    set routing-instances vxlan-1 vrf-table-label
    set protocols bgp group ibgp family evpn signaling
    set protocols bgp group ibgp peer-as 12
    set protocols bgp group ibgp neighbor 10.0.0.2 local-address 10.0.0.1
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface lo0.0
    set protocols mpls interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set routing-options router-id 10.0.0.1
    set routing-options autonomous-system 12


    PE2 configuration

    root@pe-2# run show route table vxlan-1.

    vxlan-1.inet.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    1.1.1.1/32 *[EVPN/170] 22:32:13
    > to 10.0.12.1 via ge-0/0/0.0
    2.2.2.2/32 *[Direct/0] 23:04:56
    > via lo0.1
    10.0.13.0/24 *[EVPN/170] 22:32:13
    > to 10.0.12.1 via ge-0/0/0.0
    10.0.13.1/32 *[EVPN/170] 22:32:13
    > to 10.0.12.1 via ge-0/0/0.0
    10.0.24.0/24 *[Direct/0] 23:03:01
    > via ge-0/0/2.0
    10.0.24.2/32 *[Local/0] 23:03:01
    Local via ge-0/0/2.0
    22.22.22.0/24 *[Static/5] 22:24:34
    > to 10.0.24.4 via ge-0/0/2.0
    192.168.0.0/24 *[EVPN/170] 22:32:13
    > to 10.0.12.1 via ge-0/0/0.0


    set interfaces ge-0/0/0 unit 0 family inet address 10.0.12.2/24
    set interfaces ge-0/0/0 unit 0 family mpls
    set interfaces ge-0/0/2 unit 0 family inet address 10.0.24.2/24
    set interfaces irb unit 2 family inet address 10.0.24.2/24
    set interfaces irb unit 2 family inet address 10.0.13.2/24
    set interfaces lo0 unit 0 family inet address 10.0.0.2/32
    set interfaces lo0 unit 1 family inet address 2.2.2.2/32
    set policy-options policy-statement evpn-in term 1 then accept
    set policy-options policy-statement evpn-out term 1 then accept
    set routing-instances vxlan-1 instance-type vrf
    set routing-instances vxlan-1 routing-options static route 22.22.22.0/24 next-hop 10.0.24.4
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes advertise direct-nexthop
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes encapsulation vxlan
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes vni 5000
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes import evpn-in
    set routing-instances vxlan-1 protocols evpn ip-prefix-routes export evpn-out
    set routing-instances vxlan-1 vtep-source-interface lo0
    set routing-instances vxlan-1 remote-vtep-list 10.0.0.1
    set routing-instances vxlan-1 interface ge-0/0/2.0
    set routing-instances vxlan-1 interface lo0.1
    set routing-instances vxlan-1 route-distinguisher 20004:2
    set routing-instances vxlan-1 vrf-target target:20004:1
    set routing-instances vxlan-1 vrf-table-label
    set protocols bgp group ibgp family evpn signaling
    set protocols bgp group ibgp peer-as 12
    set protocols bgp group ibgp neighbor 10.0.0.1 local-address 10.0.0.2
    set protocols ldp interface ge-0/0/0.0
    set protocols ldp interface lo0.0
    set protocols mpls interface ge-0/0/0.0
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
    set routing-options router-id 10.0.0.2
    set routing-options autonomous-system 12


  • 2.  RE: how to configure mx evpn type 5 route with vxlan encapsulation

    Posted 07-17-2021 08:51
    I am not following this, can you also add the addressing on each of the devices in question?

    What are you seeing in the ARP table of the devices?
    Same segment or different?

    Elvin