Routing

Expand all | Collapse all

Simulate BNG using vMX and vQFX on EVE-NG?

Jump to Best Answer
  • 1.  Simulate BNG using vMX and vQFX on EVE-NG?

    Posted 09-26-2019 16:00

    Hi all,

     

    Currently i'm try to simulate BNG IPOE/DHCP without using radius on EVE-NG. The test involve vMX (17.1) & vQFX (ver 18) & Windows 7 client. All the device is virtual in EVE-NG.  The issue now the client cannot get the ip address. Below is configuration vMX & vQFX. Appreciate if someone advise whether i have missing any config. The topology is simple vMX --> vQFX ---> Windows PC.

     

    vMX

     

    set dynamic-profiles VLAN-DEMUX-PROFILE interfaces demux0 unit "$junos-interface-unit" demux-source inet
    set dynamic-profiles VLAN-DEMUX-PROFILE interfaces demux0 unit "$junos-interface-unit" demux-source inet6
    set dynamic-profiles VLAN-DEMUX-PROFILE interfaces demux0 unit "$junos-interface-unit" vlan-id "$junos-vlan-id"
    set dynamic-profiles VLAN-DEMUX-PROFILE interfaces demux0 unit "$junos-interface-unit" demux-options underlying-interface "$junos-interface-ifd-name"
    set dynamic-profiles VLAN-DEMUX-PROFILE interfaces demux0 unit "$junos-interface-unit" family inet unnumbered-address lo0.0
    set dynamic-profiles VLAN-DEMUX-PROFILE interfaces demux0 unit "$junos-interface-unit" family inet unnumbered-address preferred-source-address 192.168.0.1
    set dynamic-profiles VLAN-DEMUX-PROFILE interfaces demux0 unit "$junos-interface-unit" family inet6 unnumbered-address lo0.0
    set dynamic-profiles IP-DHCP-PROFILE-1 interfaces demux0 unit "$junos-interface-unit" demux-options underlying-interface "$junos-underlying-interface"
    set dynamic-profiles IP-DHCP-PROFILE-1 interfaces demux0 unit "$junos-interface-unit" family inet demux-source $junos-subscriber-ip-address
    set dynamic-profiles IP-DHCP-PROFILE-1 interfaces demux0 unit "$junos-interface-unit" family inet unnumbered-address lo0.0
    set dynamic-profiles IP-DHCP-PROFILE-1 interfaces demux0 unit "$junos-interface-unit" family inet unnumbered-address preferred-source-address 192.168.0.1
    set dynamic-profiles IP-DHCP-PROFILE-1 interfaces demux0 unit "$junos-interface-unit" family inet6 demux-source $junos-subscriber-ipv6-address
    set dynamic-profiles IP-DHCP-PROFILE-1 interfaces demux0 unit "$junos-interface-unit" family inet6 unnumbered-address lo0.0
    set system host-name BNG
    set system root-authentication encrypted-password "$6$GNRmbJCA$NcnN0HefWfpxjL9byPZIo0GhWLyDP9jKrr748/Hs6bTs5vsIJgYUAhe1F4iz.wt8730xM2iEe6pi0mcACw2Li1"
    set system dynamic-profile-options versioning
    set system services dhcp-local-server dhcpv6 authentication password 123
    set system services dhcp-local-server dhcpv6 authentication username-include client-id
    set system services dhcp-local-server dhcpv6 authentication username-include interface-name
    deactivate system services dhcp-local-server dhcpv6 authentication
    set system services dhcp-local-server dhcpv6 group 6 dynamic-profile IP-DHCP-PROFILE-1
    set system services dhcp-local-server dhcpv6 group 6 interface xe-0/0/1.0
    set system services dhcp-local-server dhcpv6 group 6 interface demux0.0
    set system services dhcp-local-server pool-match-order ip-address-first
    set system services dhcp-local-server authentication password 123
    set system services dhcp-local-server authentication username-include mac-address
    deactivate system services dhcp-local-server authentication
    set system services dhcp-local-server group 1 dynamic-profile IP-DHCP-PROFILE-1

    set system services dhcp-local-server group 1 interface xe-0/0/1.0
    set system services dhcp-local-server group 1 interface demux0.0
    set system syslog user * any emergency
    set system syslog user * match "!(.*fpc0.*)"
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set system syslog file filter-syslog any notice
    set system syslog file filter-syslog match "!(.*fpc0.*)"
    set chassis aggregated-devices ethernet device-count 1
    set chassis fpc 0 pic 0 interface-type xe
    set chassis network-services enhanced-ip
    set access-profile Access-Profile-1
    set interfaces xe-0/0/1 description "TRUNK DOWNLINK"
    set interfaces xe-0/0/1 flexible-vlan-tagging
    set interfaces xe-0/0/1 auto-configure vlan-ranges dynamic-profile VLAN-DEMUX-PROFILE accept dhcp-v4
    set interfaces xe-0/0/1 auto-configure vlan-ranges dynamic-profile VLAN-DEMUX-PROFILE accept dhcp-v6
    set interfaces xe-0/0/1 auto-configure vlan-ranges dynamic-profile VLAN-DEMUX-PROFILE accept any
    set interfaces xe-0/0/1 auto-configure vlan-ranges dynamic-profile VLAN-DEMUX-PROFILE ranges any
    set interfaces xe-0/0/1 auto-configure remove-when-no-subscribers
    set interfaces xe-0/0/1 mtu 9192
    set interfaces xe-0/0/1 unit 10 description "-- management interface"
    set interfaces xe-0/0/1 unit 10 vlan-id 10
    set interfaces xe-0/0/1 unit 10 family inet address 10.10.10.1/24
    set interfaces lo0 description "-- loopback"
    set interfaces lo0 unit 0 family inet address 1.1.1.20/32 primary
    set interfaces lo0 unit 0 family inet address 1.1.1.20/32 preferred
    set interfaces lo0 unit 0 family inet address 192.168.0.1/32
    set interfaces lo0 unit 0 family inet6 address 2001::1/128
    set access profile Access-Profile-1 authentication-order none
    set access address-assignment pool ipv4-pool family inet network 192.168.0.0/24
    set access address-assignment pool ipv4-pool family inet range R1 low 192.168.0.2
    set access address-assignment pool ipv4-pool family inet range R1 high 192.168.0.254
    set access address-assignment pool ipv4-pool family inet dhcp-attributes maximum-lease-time 3600
    set access address-assignment pool ipv4-pool family inet dhcp-attributes name-server 8.8.4.4
    set access address-assignment pool ipv4-pool family inet dhcp-attributes router 192.168.0.1
    set access address-assignment pool ipv6-iana-pool family inet6 prefix 2001::/64
    set access address-assignment pool ipv6-iana-pool family inet6 range R2 low 2001::2/128
    set access address-assignment pool ipv6-iana-pool family inet6 range R2 high 2001::ffff/128
    set access address-assignment pool ipv6-iana-pool family inet6 dhcp-attributes maximum-lease-time 3600
    set access address-assignment pool ipv6-iana-pool family inet6 dhcp-attributes dns-server 2001:4860:4860::8888
    set access address-protection
    set access report-interface-descriptions
    set access radius-options request-rate 500
    deactivate access radius-options

     

    vQFX

     

    root@CSW# run show configuration interfaces xe-0/0/0
    description "Access Port to BNG";
    mtu 9192;
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members 10-11;
    }
    }
    }

     

    root@CSW# run show configuration interfaces xe-0/0/1
    description "Access Port to Windows 7";
    unit 0 {
    family ethernet-switching {
    interface-mode access;
    vlan {
    members 11;
    }
    }
    }

     

    root@CSW# run show configuration vlans
    VLAN-10 {
    vlan-id 10;
    l3-interface irb.10;
    }
    VLAN-11 {
    vlan-id 11;
    }
    default {
    vlan-id 1;
    }

     

     



  • 2.  RE: Simulate BNG using vMX and vQFX on EVE-NG?
    Best Answer

     
    Posted 09-26-2019 19:35
    Hi,

    Please enable bbe knob and reboot system and check

    set system services subscriber-management enable
    set system configuration-database max-db-size 314572800

    thank you
    Prabin


  • 3.  RE: Simulate BNG using vMX and vQFX on EVE-NG?

    Posted 09-27-2019 01:08

    Hi Prabin,

     

     

    It's work !!.. Thanks for your advise.

     

     



  • 4.  RE: Simulate BNG using vMX and vQFX on EVE-NG?

    Posted 04-04-2020 22:22

    Hi