Routing

Expand all | Collapse all

No IP address on PTX1K between PTX1K and QFX5K

Jump to Best Answer
  • 1.  No IP address on PTX1K between PTX1K and QFX5K

    Posted 03-30-2020 21:47

    Hi,

     

    I couldn't get the following devices pinging to each other. Any help is appreciated.

    PTX1K (192.168.10.1) <------> (irb 192.168.10.2) QFX5K

     

    PTX1K:
    ----------
    set interface et-0/0/1 unit 0 family inet address 192.168.10.1/30
    
    QFX5K:
    -------------
    set vlans vlan-testing vlan-id 100 
    set interfaces et-0/0/4 unit 0 family ethernet-switching vlan members vlan-testing
    set interfaces irb unit 100 family inet address 192.168.10.2/30
    set vlans vlan-testing l3-interface irb.100

    root@PTX1K# run show interfaces et-0/0/1 terse
    Interface Admin Link Proto Local Remote
    et-0/0/1 up up
    et-0/0/1.0 up up aenet --> ae11.0

    [edit]

     

    Earlier, I had to disable the et-0/0/1 on PTX1K with 'deactivate interfaces et-0/0/1 unit 0' due to bundle interface

    and it let me commit the one-line config above, but still shows no IP address as seen above.

    --------------------------

    root@QFX5K# run show interfaces irb terse
    Interface Admin Link Proto Local Remote
    irb up up
    irb.100 up up inet 192.168.10.2/30

    {master:0}[edit]

    root@QFX5K# run show vlans

    Routing instance VLAN name Tag Interfaces
    default-switch default 1

    default-switch vlan-testing 100
    et-0/0/4.0*

    {master:0}[edit


    Please let me know what I am missing.

    Thanks in advance



  • 2.  RE: No IP address on PTX1K between PTX1K and QFX5K

     
    Posted 03-30-2020 22:25

    Your config shows the IP on et-0/0/1 but your output shows it as part of ae11.  What's the full config of the ptx1k's interfaces?



  • 3.  RE: No IP address on PTX1K between PTX1K and QFX5K

    Posted 03-30-2020 22:38
    root@PTX1K> show configuration    
            interfaces {
                et-0/0/1 {
                    unit 0 {
                        family inet {
                            address 1.2.1.64/31;
                        }
                    }
                }
    .......
            interfaces {
                ae11 {
                    description QFX5K;
                    unit 0 {
                        family inet {
                            address 1.2.1.64/31;
                        }
                    }
                }

    Is that what you are looking for? Please let me know the commands that you like to show interface config.

    Thanks,

     



  • 4.  RE: No IP address on PTX1K between PTX1K and QFX5K

     
    Posted 03-30-2020 22:56

    Hi,

     

    Do you want et-0/0/1 to be part of ae11 bundle or an individual interface connecting to the QFX5K.

     

    If you want it to part of ae bundle, remove the IP configuration of the et-0/0/1 interface, reactivate it and configure the IP on the ae11 interface. If you want to be an individual interface, remove it from the ae11 bundle.

     

    Let us know what is your expectation and if need help on the commands, please share the output of:

     

    show configuration | display set | match et-0/0/1

    show configuration | display set | match ae11

     

    Hope this helps.

     

    Thanks and Regards,

    Pradeep Kumar



  • 5.  RE: No IP address on PTX1K between PTX1K and QFX5K

    Posted 03-31-2020 09:15

    @Pradeep:

    It still didn't work. I tried with the interface part of the ae bundle first.

     

    1) Remove IP address from et-0/0/1 interface

    # delete interfaces et-0/0/1 unit 0

     

    2) Configure 192.168.10.1 on ae11 interface of PTX1K:

    # set interfaces ae11 unit 0 family inet address 192.168.10.1/30

     

    root@PTX1K> show interfaces terse
    Interface Admin Link Proto Local Remote
    et-0/0/1 up up
    et-0/0/1.0 up up aenet --> ae11.0   

    ..........

    ae11 up down
    ae11.0 up down inet 1.2.1.64/31
                                        192.168.10.1/30
                                        inet6 fefe::7777:ffff:ffff:1111/64
                                        mpls
                                        multiservice

     

    root@PTX1K> show configuration | display set | match et-0/0/1
    set groups OSPF-TO-S protocols ospf area 0.0.0.0 interface et-0/0/1.0 interface-type p2p
    set groups OSPF-TO-S protocols ospf area 0.0.0.0 interface et-0/0/1.0 ldp-synchronization
    set groups OSPF-TO-S protocols ospf area 0.0.0.0 interface et-0/0/1.0 hello-interval 1
    set groups LDP-TO-S protocols ldp interface et-0/0/1.0
    set groups MPLS-TO-ALL protocols mpls interface et-0/0/1.0
    set groups INTERFACES-TO-S interfaces et-0/0/1 description to QFX5K
    set groups INTERFACES-TO-S interfaces et-0/0/1 unit 0 family inet address 1.2.1.64/31
    set groups AE-INTERFACES-TO-S interfaces et-0/0/1 gigether-options 802.3ad ae11
    set groups SFLOW protocols sflow interfaces et-0/0/1.0
    
    
    root@PTX1K> show configuration | display set | match ae11
    set groups AE-OSPF-TO-S protocols ospf area 0.0.0.0 interface ae11.0 interface-type p2p
    set groups AE-OSPF-TO-S protocols ospf area 0.0.0.0 interface ae11.0 ldp-synchronization
    set groups AE-OSPF-TO-S protocols ospf area 0.0.0.0 interface ae11.0 hello-interval 1
    set groups AE-LDP-TO-S protocols ldp interface ae11.0
    set groups AE-INTERFACES-TO-S interfaces ae11 description to-spc-1-qfx5k
    set groups AE-INTERFACES-TO-S interfaces ae11 unit 0 family inet address 1.2.1.64/31
    set groups AE-INTERFACES-TO-S interfaces et-0/0/1 gigether-options 802.3ad ae11
    set interfaces ae11 unit 0 family inet address 192.168.10.1/30


  • 6.  RE: No IP address on PTX1K between PTX1K and QFX5K
    Best Answer

     
    Posted 03-31-2020 10:08

    Hi,

     

    Since on QFX side, there's no ae, please remove ae in PTX1k side as well.

     

    On QFX side, it's irb over bridge-domain (vlan), thus we are expecting vlan tags. On PTX side, we also need to have vlan tagging of 100 

     

    #deactivate interface ae11

    #deactivate groups AE-INTERFACES-TO-S interfaces et-0/0/1 gigether-options

     

    #set in et-0/0/1 flexible-vlan-tagging

    #set in et-0/0/1 encapsulation flexible-ethernet-services

    #set in et-0/0/1 unit 100 vlan-id 100

    #set in et-0/0/1 unit 100 family inet address 192.168.10.1/30



  • 7.  RE: No IP address on PTX1K between PTX1K and QFX5K

    Posted 03-31-2020 16:17

    @Mengzhe Hu:

     

    Everytime, I deactivated:

    deactivate groups AE-INTERFACES-TO-S interfaces et-0/0/1 gigether-option

     

    and do a commit, it complained of:

    error: Number of member links configured, i.e [0], for interface [ae11]is lesser than the required minimum [1].
    error: configuration check-out failed

     

    Suggestions?



  • 8.  RE: No IP address on PTX1K between PTX1K and QFX5K

    Posted 03-31-2020 02:33

    Hi PL2,

     

    The config shows a different IP address assigned to the interface. 
    The et-0/0/1 has the IP 1.2.1.64/31 and you shared the question with another IP address. Please verify and share the outputs. I think there is some misconfiguration. Please verify the configuration.

     

    Please mark "accept as solution" if this answers your query. Kudos are appreciated too ! 

     

    Regards, 

    Sharat Ainapur.



  • 9.  RE: No IP address on PTX1K between PTX1K and QFX5K

    Posted 03-31-2020 10:47

    Hi PL2,

     

    First : You can't have the same IP on the same box, the IPs won't show up, but if you have routing instances , it will work, but for the main instance(inet.0) it won't work.

     

    Second: Make sure you have the child interfaces assigned to the AE, make sure the other side is the same and have LACP configured if needed.

     

    Third: Also , you can remove the child interface and assign the IP and see if that comes up, go step by step, then you can assign the second interface.

     

    I hope this help!

    Franky

     

    If this solves your problem, please mark this post as "Accepted Solution".
    If you think that my answer was helpful, please spend some Kudos.