Routing

Expand all | Collapse all

vmx-bundle-15.1F6.9 and vmx-14.1R8.6 cannot be opened by telnet as emulated by console login via EVE-NG

  • 1.  vmx-bundle-15.1F6.9 and vmx-14.1R8.6 cannot be opened by telnet as emulated by console login via EVE-NG

    Posted 01-19-2020 02:43

    Unable to use telnet to open vMX on EVE-NG. The implementation steps as follows:

     

    1. Download the following two imgs and saved at /opt/unetlab/addons/qemu/;

     

    root@eve-ng:/opt/unetlab/addons/qemu# ls -lrt | grep jinstall
    -rw-r--r-- 1 root root 992411648 Jun 30 2016 jinstall-vmx-15.1F6.9-domestic.img
    -rw-r--r-- 1 root root 648740864 Jan 19 01:30 jinstall-vmx-14.1R8.6-domestic.img
    root@eve-ng:/opt/unetlab/addons/qemu#

     

    2. create vmx14 and vmx15 directory

     

    root@eve-ng:/opt/unetlab/addons/qemu# mkdir vmx14
    root@eve-ng:/opt/unetlab/addons/qemu# mkdir vmx15
    root@eve-ng:/opt/unetlab/addons/qemu#

     

    3. convert the img to qcow2:

     
    root@eve-ng:/opt/unetlab/addons/qemu# qemu-img convert -f raw -O qcow2 jinstall-vmx-14.1R8.6-domestic.img vmx14/hda.qcow2
     
    root@eve-ng:/opt/unetlab/addons/qemu# qemu-img convert -f raw -O qcow2 jinstall-vmx-15.1F6.9-domestic.img vmx15/hda.qcow2
    root@eve-ng:/opt/unetlab/addons/qemu# chmod -R 777 vmx14/
    root@eve-ng:/opt/unetlab/addons/qemu# chmod -R 777 vmx15/

     

    root@eve-ng:/opt/unetlab/addons/qemu# ls -lrt vmx14/
    total 633864
    -rwxrwxrwx 1 root root 649134080 Jan 19 12:03 hda.qcow2
    root@eve-ng:/opt/unetlab/addons/qemu# ls -lrt vmx15/
    total 969480
    -rwxrwxrwx 1 root root 992804864 Jan 19 12:03 hda.qcow2
    root@eve-ng:/opt/unetlab/addons/qemu#

     

    4. Fix permission

    root@eve-ng:/opt/unetlab/addons/qemu# /opt/unetlab/wrappers/unl_wrapper -a fixpermissions

     

    5. go to http portal of eve-ng, and setup the vmx router

    vmx14 setup on eve-ng.pngvmx15 setup on eve-ng.png

     

    6 start the vmx01 and vmx02 in EVE-NG, however the telnet session looks green but nothing is displayed.

    eve-ng vmx issue.pngeve-ng vmx issue02.pngvmx01 (v14) telnet session issue.pngvmx02 (v14) telnet session issue.png

     

    My question:

    1. what's setup wrong? like qemu? junos image? steps?

    2. why the telnet does not show anything but the telnet session shows green other than red?

    3. I have tested eve-ng in bare metal server and in VMware workstation, both do not work. why?

    4. vMX VCP and VFP seperated VMs over EVE-NG work very well, but only vmx v14 and v15 cannot be opened by telnet session.

     

     

     


     



  • 2.  RE: vmx-bundle-15.1F6.9 and vmx-14.1R8.6 cannot be opened by telnet as emulated by console login via EVE-NG

    Posted 01-23-2020 13:36

    Anyone has idea about this? hope someone can share sth with me.

    Cheers



  • 3.  RE: vmx-bundle-15.1F6.9 and vmx-14.1R8.6 cannot be opened by telnet as emulated by console login via EVE-NG

     
    Posted 08-04-2020 08:16

    Hi Syang,

     

    Are you running eve-ng on ESXi? if so, I solved that issue modifying Qemu options to:

     

    ajgr_0-1596554130362.png

     

    Hope this helps!

     

     



  • 4.  RE: vmx-bundle-15.1F6.9 and vmx-14.1R8.6 cannot be opened by telnet as emulated by console login via EVE-NG

    Posted 08-05-2020 11:35

    vMX deployment is not same like vSRX.

    To spin up one vMX you would need 2 VM - VCP and VFP

    VCP for control plane and VFP for forwarding plane.

    VCP VM and VFP VM should connected via an internal link/em1

     

    Follow the steps mentioned in below link and it should work.

    https://www.eve-ng.net/index.php/documentation/howtos/howto-add-juniper-vmx-16-x-17-x/

     

    I have multiple vMX deployed on eve-ng and they are working fine.