Routing

Expand all | Collapse all

ospf nssa do not export the default route

Jump to Best Answer
  • 1.  ospf nssa do not export the default route

    Posted 11-06-2019 02:42

    Hi there i have the following topology

    RouterA connected to RouterB and I want to run ospf.

    RouterA is an ABR

     

    RouterA@yyyy> show configuration protocols ospf
    area 0.0.1.94 {
    nssa {
    default-lsa {
    default-metric 10;
    type-7;
    }
    no-summaries;
    }
    interface xe-1/1/10:0.350 {
    priority 150;
    hello-interval 2;
    dead-interval 8;
    authentication {
    md5 1 key "xxxxxx"; ## SECRET-DATA
    }
    }
    }
    area 0.0.0.0 {
    interface lo0.0 {
    passive;
    }
    }

    and


    RouterB@xxx> show configuration protocols ospf
    area 0.0.1.94 {
    nssa;
    interface vlan.350 {
    priority 100;
    hello-interval 2;
    dead-interval 8;
    authentication {
    md5 1 key "xxxxxx"; ## SECRET-DATA
    }
    }
    interface lo0.0 {
    passive;
    }
    interface vlan.2001 {
    passive;
    }
    }


    Router A learn via BGP the default route from upstream

    RouterA@yyyy> > show route 0.0.0.0

    inet.0: 10792 destinations, 20875 routes (10767 active, 0 holddown, 25 hidden)
    + = Active Route, - = Last Active, * = Both

    0.0.0.0/0 *[BGP/170] 00:15:30, localpref 100
    AS path: xxxx, validation-state: unverified
    > to yyyy via ae0.0

     

    But RouterB dose not receive any default-route. Why?

    RouterB@xxx>> show route protocol ospf

    inet.0: 15 destinations, 15 routes (15 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    224.0.0.5/32 *[OSPF/10] 192w1d 00:27:39, metric 1
    MultiRecv

     

    OSPF peering is ok and on RouterA I am able to see via ospf the directly connected routes of RouterB.



  • 2.  RE: ospf nssa do not export the default route

    Posted 11-06-2019 02:55

    Hello

     

    Try removing type-7 on your nssa default-lsa configuration



  • 3.  RE: ospf nssa do not export the default route

    Posted 11-06-2019 02:56
    Router A should have a ospf adjacency in area 0 to advertise default route.


  • 4.  RE: ospf nssa do not export the default route

    Posted 11-06-2019 03:29

    Thnaks for the answer.

    Basically based on this thread

    https://www.reddit.com/r/Juniper/comments/3xvncq/totally_stubby_area_not_sending_default_route_on/

    it seems that

    “Area 0 must have a neighbor to announce a default route into stub or totally stubby areas”

     

    But I am working with nssa area first point.

     

    More, I do not really need an ospf area 0 (I know is needed for different reason in theory) and I apply the follwoing workaround

    On RouterA I change the config:

    1)I eliminate the area 0.0.0.0

    2)I apply an export policy to export the default route

    3)Now i have

    set protocols ospf export accept-default
    set protocols ospf no-active-backbone
    set protocols ospf area 0.0.1.94 nssa default-lsa default-metric 10
    set protocols ospf area 0.0.1.94 nssa default-lsa type-7
    set protocols ospf area 0.0.1.94 nssa no-summaries
    set protocols ospf area 0.0.1.94 interface xe-1/1/10:0.350 priority 150
    set protocols ospf area 0.0.1.94 interface xe-1/1/10:0.350 hello-interval 2
    set protocols ospf area 0.0.1.94 interface xe-1/1/10:0.350 dead-interval 8
    set protocols ospf area 0.0.1.94 interface xe-1/1/10:0.350 authentication md5 1 key "xxxx"

     

    And on router B now i have the default-route but I really did not understand the effect of the commands.

    • set protocols ospf no-active-backbone : ignore the junos mechanism to stop adevrtising default-route in case of loss connection from backbone
    • set protocols ospf area 0.0.1.94 nssa default-lsa default-metric 10
      set protocols ospf area 0.0.1.94 nssa default-lsa type-7
      set protocols ospf area 0.0.1.94 nssa no-summaries

    The above 3 commands should take care to inject default-route. But does not work. To have it working I need to add the export policy

    set policy-options policy-statement accept-default term yes from route-filter 0.0.0.0/0 exact
    set policy-options policy-statement accept-default term yes then accept

     

    and apply it to ospf

    set protocols ospf export accept-default

     

    Which in my opinion should not be the case. Protocol should work without this export policy. What do you think?



  • 5.  RE: ospf nssa do not export the default route
    Best Answer

     
    Posted 11-12-2019 13:24

    You are correct. You don't need export policy to get 0/0 advertised on totally nssa. Your configuration looks correct though

     

    Here I want to point out something:

    1. On ROUTER A, You don't need to care about 0/0. No matter it has 0/0 or not in its RIB, it's going to generate 0/0 in LSDB

    2. Check on ROUTER B, "show ospf database" and see if you can see 0/0 entry if you don't have export policy on router A