Routing

Expand all | Collapse all

how to configure 40G port on mx204

  • 1.  how to configure 40G port on mx204

    Posted 02-25-2020 23:21

    Can someone guide me how to configure the 4 port to 40G on mx204?

    Right now I see

    xe-0/0/0:0 up up
    xe-0/0/0:1 up up
    xe-0/0/0:2 up up
    xe-0/0/0:3 up up
    I refer https://www.juniper.net/documentation/en_US/junos/topics/topic-map/rate-selectability-configuring.html

    not working as it should.

    Thanks



  • 2.  RE: how to configure 40G port on mx204

     
    Posted 02-26-2020 01:52

    Hi

     

    As the document suggests which method are you using of the 2 methods "pic level" or "port level" ?

    Both the method didnt work ? Are you getting some error while changing the config.



  • 3.  RE: how to configure 40G port on mx204

     
    Posted 02-26-2020 01:59

    Hi,

     

    please refer to the below link , it mentions some rules to follow to be able to change rate on MX204 ports
    https://www.juniper.net/documentation/en_US/junos/topics/topic-map/rate-selectability-overview.html#id-mx204-router-rate-selectability-overview

     

    If this solves your problem, please mark this post as "Accepted Solution



  • 4.  RE: how to configure 40G port on mx204

    Posted 02-26-2020 06:41

    I configured port 0,1 at 40g

    [edit chassis fpc 0 pic 0]
    root@x# show
    port 0 {
    speed 40g;
    }
    port 1 {
    speed 40g;
    }

     

      But when I run show interface command I see them as xe.. not et-0

     

    xe-0/0/0:0 up up
    xe-0/0/0:1 up up
    xe-0/0/0:2 up up
    xe-0/0/0:3 up up

     

    There is no option in configuration to delete and configure as et-0/0/0

    Can someone guide me how to fix?



  • 5.  RE: how to configure 40G port on mx204

     
    Posted 02-26-2020 06:50

    Please check below link to make sure your configuration for both pic 0 and pic 1 are valid:

    https://apps.juniper.net/home/port-checker/index.html

     

    Also check "show system alarms" to see if any alarms related to PIC.

    If your configuration is valid, but port didn't get changed from xe to et, you mostly need to restart the PIC or FPC 



  • 6.  RE: how to configure 40G port on mx204

    Posted 02-26-2020 06:58

    There is only one port 0 @ 40G connected to ex4300 switch and I checked the configuration via that app.

     

    2 alarms currently active
    Alarm time Class Description
     UTC Minor FPC 0 PIC 1 Invalid port profile configuration
     UTC Minor FPC 0 PIC 0 Invalid port profile configuration

    but when I checked config before commit it passed,

     

     



  • 7.  RE: how to configure 40G port on mx204

     
    Posted 02-26-2020 08:57

    If you are not using any ports on PIC1, please configure following:

     

    set chassis fpc 0 pic 1 number-of-ports 0

     

    After that restart the FPC.  You should see the 40Gig ports

    If that doesn't work please send complete "show chassis alarm/show chassis hardware/show configuration chassis" output

     

    Thanks
    Vishal



  • 8.  RE: how to configure 40G port on mx204

    Posted 02-26-2020 13:19

    Hi,

    I'm still quite new to Juniper, so sorry if this is bad advice, but are you using a break out cable?

     

    In past (with another vendor) I have had 40G QSFP ports on a switch, and attached a breakout cable, which converted the one port into four 10G SFP+ ports.

     

    Could your issue be something like this?