Routing

 View Only
last person joined: 2 days ago 

Ask questions and share experiences about ACX Series, CTP Series, MX Series, PTX Series, SSR Series, JRR Series, and all things routing, including portfolios and protocols.
  • 1.  can't ping irb interface

    Posted 12-14-2018 12:34

    I'm having trouble getting my irb interfaces configured. This is an EX4600 switch. I have two hosts connected.

     

    One on ge-0/0/1 assigned an ip address of 192.168.1.38/24

    and another on ge-0/0/2 assigned 192.168.6.38/24

     

    They are configured as follows:

     

     

    > show configuration interfaces ge-0/0/1  
    unit 0 {
    description host1;
        family ethernet-switching {
            interface-mode access;
            vlan {
                members default;
            }
        }
    }

    and:

     

     

    > show configuration interfaces ge-0/0/2    
    description host1-ipmi;
    unit 0 {
        family ethernet-switching {
            interface-mode access;
            vlan {
                members mgmt-vlan;
            }
        }
    }

    since they are members of different VLANS and I would like to access accross the VLANS, I have configured an IRB interface:

     

     

    > show configuration interfaces irb unit 10 
    family inet {
        address 192.168.6.254/24;
        address 192.168.10.254/24;
    }

    The default VLAN is 1 and the management VLAN is 10.

     

     

    default {
        vlan-id 1;
        l3-interface irb.0;
    }
    mgmt-vlan {
        description "Management VLAN";
        vlan-id 10;
        l3-interface irb.10;
        domain-type bridge;
    }

    I can ping between the IRBs when logged into the switch management console:

     

     

    > ping source 192.168.6.254 192.168.10.254     
    PING 192.168.10.254 (192.168.10.254): 56 data bytes
    64 bytes from 192.168.10.254: icmp_seq=0 ttl=64 time=0.357 ms
    64 bytes from 192.168.10.254: icmp_seq=1 ttl=64 time=0.041 ms
    
    
    > ping source 192.168.6.254 192.168.6.38      
    PING 192.168.6.38 (192.168.6.38): 56 data bytes
    64 bytes from 192.168.6.38: icmp_seq=0 ttl=64 time=17.397 ms
    64 bytes from 192.168.6.38: icmp_seq=1 ttl=64 time=11.110 ms
    
    
    > ping source 192.168.40.1 192.168.6.254      
    PING 192.168.6.254 (192.168.6.254): 56 data bytes
    64 bytes from 192.168.6.254: icmp_seq=0 ttl=64 time=0.264 ms
    64 bytes from 192.168.6.254: icmp_seq=1 ttl=64 time=0.041 ms

    But when I'm on host1 (192.168.1.38) which is physically plugged into ge-0/0/1 on VLAN 1 I cannot ping any of the IRB interfaces (192.168.6.254, 192.168.10.254, or 192.168.40.1)  or the host1-ipmi connected to ge-0/0/2.

     

    Any advice or suggestions would be greatly appreciated.

     

     

     



  • 2.  RE: can't ping irb interface

     
    Posted 12-14-2018 15:37

    You haven’t assign an IP address for irb.0. What default gateway are you using on your hosts?

    set interfaces irb unit 0 family inet address ???

     

    I also recommend aligning your vlan tags with irb units for easier reading and troubleshooting.

    set interfaces irb unit 1 family inet address xxx/xx
    set vlans default vlan-id 1 l3–interface irb.1


  • 3.  RE: can't ping irb interface

    Posted 12-14-2018 16:54

    I do have inet addresses assigned for the irb interfaces:

     

    > show configuration interfaces irb           
    unit 1 {
        family inet {
            address 192.168.1.46/24;
        }
    }
    unit 10 {
        family inet {
            address 192.168.6.254/24;
            address 192.168.10.254/24;
        }
    }
    unit 40 {
        family inet {
            address 192.168.40.1/24;
        }
    }
    

    I moved irb.0 to irb.1 so now all vlan tags align with the irb units:

     

    vlan 1 --->  irb.1

    vlan 10 ---> irb.10

    vlan 40 ---> irb.40

     

    However, deleting irb unit 0 and setting a new unit 1 has locked me out of the switch. I'll now need to take a laptop to the server room and connect with the console cable. I'll wait until Monday to do this.

     

    My understanding was that the layer3 routing from one vlan to another would use the irb.0 or irb.10  addresses as the gateway. So I'm quite confused why I cant ping these addresses from host1.

     

     

     



  • 4.  RE: can't ping irb interface

     
    Posted 12-14-2018 17:05

    Yes, as long as your vlan 1 hosts are using the irb.1 address (192.168.1.46) as their default gateway then they will be able to reach the other vlan interface IP’s as long as they are up (which you’ve already confirmed to be the case).