Routing

Expand all | Collapse all

Adding host devices to the juniper vlabs topology

Jump to Best Answer
  • 1.  Adding host devices to the juniper vlabs topology

     
    Posted 07-22-2020 10:36
      |   view attached

    Hello,

     

    I am working on Juniper vlabs (vlabs.juniper.net) to create 3 logical /24 subnets and advertise these subnets via OSPF to the OSPF backbone. I was able to create the networks but unable to advertise the networks back to the OPSF backbone. These three logical networks are created as irb networks. Since irb networks require at least one host to be active on the subnet, the routes are not being advertised upstream.

     

    Is it possible to add host devices to these 3 logical networks so that the networks can be advertised upstream? I was thinking if there was a way to configure a virtual router on the device, such that the virtual router would act as a host device.

     

    Attached is the Juniper vlab topology for reference. I basically need to simulate multiple host devices on the vMX5 router.

     

    Any help would be highly appreciated.



  • 2.  RE: Adding host devices to the juniper vlabs topology

    Posted 07-23-2020 17:38

    Hello ,

     

    Can you please share the configuration of the vMX5 device.

     

    Thanks.



  • 3.  RE: Adding host devices to the juniper vlabs topology

     
    Posted 07-24-2020 07:42

    Hi Aldair,

     

    The config is pretty straight forward and I'm just using the default config on the vlabs site. Really the ask is, whether it is possible to treat a virtual router as a host device, as there is no physical host (servers) connected to this topology.

     



  • 4.  RE: Adding host devices to the juniper vlabs topology
    Best Answer

    Posted 07-25-2020 00:56
      |   view attached

    Hi ,

     

    If I am understanding correctly, you can use flexible-vlan-tagging and use multiple logical interfaces. See my topology where vMX1 connects to vMX2 with 3 logical interfaces on GE-0/0/0 then routes are advertised to area 0

     

    VMX1:

    logical-systems {
    R1 {
    interfaces {
    ge-0/0/0 {
    unit 1 {
    vlan-id 1;
    family inet {
    address 10.0.1.1/24;
    }
    }
    }
    }
    protocols {
    ospf {
    area 0.0.0.1 {
    interface ge-0/0/0.1;
    }
    }
    }
    }
    R2 {
    interfaces {
    ge-0/0/0 {
    unit 2 {
    vlan-id 2;
    family inet {
    address 10.0.2.1/24;
    }
    }
    }
    }
    protocols {
    ospf {
    area 0.0.0.1 {
    interface ge-0/0/0.2;
    }
    }
    }
    }
    R3 {
    interfaces {
    ge-0/0/0 {
    unit 3 {
    vlan-id 3;
    family inet {
    address 10.0.3.1/24;
    }
    }
    }
    }
    protocols {
    ospf {
    area 0.0.0.1 {
    interface ge-0/0/0.3;
    }
    }
    }
    }
    }
    interfaces {
    ge-0/0/0 {
    flexible-vlan-tagging;
    }
    }

     

     

    vMX2

    interfaces {
    ge-0/0/0 {
    flexible-vlan-tagging;
    unit 1 {
    vlan-id 1;
    family inet {
    address 10.0.1.2/24;
    }
    }
    unit 2 {
    vlan-id 2;
    family inet {
    address 10.0.2.2/24;
    }
    }
    unit 3 {
    vlan-id 3;
    family inet {
    address 10.0.3.2/24;
    }
    }
    }
    ge-0/0/1 {
    unit 0 {
    family inet {
    address 172.16.0.1/31;
    }
    }
    }
    }
    protocols {
    ospf {
    area 0.0.0.1 {
    interface ge-0/0/0.1;
    interface ge-0/0/0.2;
    interface ge-0/0/0.3;
    }
    area 0.0.0.0 {
    interface ge-0/0/1.0;
    }
    }
    }

     

    vMX3

    interfaces {
    ge-0/0/1 {
    unit 0 {
    family inet {
    address 172.16.0.0/31;
    }
    }
    }
    lo0 {
    unit 0 {
    family inet {
    address 10.10.10.10/32;
    }
    }
    }
    }
    protocols {
    ospf {
    area 0.0.0.0 {
    interface ge-0/0/1.0;
    interface lo0.0;
    }
    }
    }

     

    [edit]
    root@vMX3# run show route

    inet.0: 7 destinations, 7 routes (7 active, 0 holddown, 0 hidden)
    + = Active Route, - = Last Active, * = Both

    10.0.1.0/24 *[OSPF/10] 00:05:29, metric 2
    > to 172.16.0.1 via ge-0/0/1.0
    10.0.2.0/24 *[OSPF/10] 00:05:29, metric 2
    > to 172.16.0.1 via ge-0/0/1.0
    10.0.3.0/24 *[OSPF/10] 00:05:29, metric 2
    > to 172.16.0.1 via ge-0/0/1.0
    10.10.10.10/32 *[Direct/0] 00:06:14
    > via lo0.0
    172.16.0.0/31 *[Direct/0] 00:06:15
    > via ge-0/0/1.0
    172.16.0.0/32 *[Local/0] 00:06:15
    Local via ge-0/0/1.0
    224.0.0.5/32 *[OSPF/10] 00:06:15, metric 1
    MultiRecv

     

    vMX3 in area 0 is getting the 3 subnets from vMX1 that are on 3 different logical systems.

     

    Hope this help you.

     

    Kudos is always appreciated!

    If this resolve your issue/questions, please mark as "Accepted Solution"



  • 5.  RE: Adding host devices to the juniper vlabs topology

     
    Posted 07-27-2020 06:31

    Thanks Adair, I haven't used logical systems yet, but will give that a try.