Routing

Expand all | Collapse all

Juniper Equivalent to Cisco Loopback Interfaces / VyOS Dummy Interfaces

Jump to Best Answer
  • 1.  Juniper Equivalent to Cisco Loopback Interfaces / VyOS Dummy Interfaces

    Posted 06-06-2020 07:27

    Hi, all! I'm primarily a Cisco administrator, so I'm used to the concept of the ability to create multiple loopback interfaces "in a single routing instance" (VRF/routing context in Cisco world).

     

    On VyOS, you can have something similar with dummy interfaces. However, I can't find an equivalent on Juniper gear. I am aware that you can add multiple IPs to the default lo0 interface under a unit, but you can only have one interface unit per routing instance. This would be extremely useful for testing purposes, since the problem is that IGPs (e.g. OSPF) have interfaces enabled under the process and not specific networks. Therefore, on Cisco platforms, I could create two loopback interfaces (say, 1.1.1.1/32 and 2.2.2.2/32) and advertise one into area 0 and the other into area 1 on the OSPF ABR to induce the creation of a Type 3 LSA. The same could be accomplished on the VyOS platform.

     

    However, since I'd be assigning these two IPs to the same interface on JUNOS platforms, both networks would be injected into OSPF, if my logic serves me right. I'm therefore making this post to ask how I might be able to achieve the same behavior as I can using IOS's loopback interfaces of creating "dummy networks" that are separated from each other at the interface level so that I can have more control over them. Thank you in advance to anyone who is able to provide any assistance at all, it's greatly appreciated!



  • 2.  RE: Juniper Equivalent to Cisco Loopback Interfaces / VyOS Dummy Interfaces

     
    Posted 06-06-2020 07:36

    Hello kelvin,

     

    there is no difference between Cisco and Juniper in context of multiple loopback interfaces, on JunOS you can configure multiple loopback interfaces as well. The only difference is lo0 is always present on JunOS, as it is the door to the routing engine. But you can configure anytime additional loopback interfaces, like lo1, lo2, lo3 ...

     

    Does this answer your question?



  • 3.  RE: Juniper Equivalent to Cisco Loopback Interfaces / VyOS Dummy Interfaces

     
    Posted 06-06-2020 09:07

    Close -- it's lo0 unit 0, unit 1, unit 2, ...



  • 4.  RE: Juniper Equivalent to Cisco Loopback Interfaces / VyOS Dummy Interfaces

     
    Posted 06-06-2020 09:49

    I'm sorry, you are right, I mixed this up by mistake, only lo0 with different units.



  • 5.  RE: Juniper Equivalent to Cisco Loopback Interfaces / VyOS Dummy Interfaces

    Posted 06-06-2020 12:15

    Hi,

     

    Thanks for your response! I am aware that you can make multiple loopback units, but you'd have to put them into multiple routing instances (what I understand to be the equivalent of Cisco's VRFs - I'm aware this is an oversimplification) since I tried this once and it only allowed one loopback unit per RI. If my equivalence to an RI to a VRF is incorrect, could you give me some more details or help to point me in a direction for documentation that I can read to gain more insight on the matter? Thanks!



  • 6.  RE: Juniper Equivalent to Cisco Loopback Interfaces / VyOS Dummy Interfaces
    Best Answer

    Posted 06-06-2020 21:11

    Hello,

     

    If You want to inject LSA Type 3 into different OSPF areas, all residing in the same routing-instance, then multiple lo0 units are not the tool to use.

    You have to use LT units (AFAIK, LT is supported on SRX/MX/ACX, never tried them on EX/QFX). Below example is for MX:

     

    set chassis fpc 0 pic 0 tunnel-services bandwidth 10g
    set interfaces lt-0/0/0 unit 1 peer-unit 2
    set interfaces lt-0/0/0 unit 2 peer-unit 1
    set interfaces lt-0/0/0 unit 1 encapsulation ethernet
    set interfaces lt-0/0/0 unit 1 family inet address 203.0.113.1/24
    set interfaces lt-0/0/0 unit 2 encapsulation ethernet-ccc
    set interfaces lt-0/0/0 unit 2 family ccc
    set protocols ospf area 1 interface lt-0/0/0.1 passive

     

     

    If You can live with LSA Type 5 then You could use "receive" static route, it is pingable:

     

    set routing-options static route 203.0.113.0/24 receive
    set policy-options policy-statement PL-EX-OSPF term 1 from route-filter 203.0.113.0/24 exact
    set policy-options policy-statement PL-EX-OSPF term 1 then accept
    set protocols ospf export PL-EX-OSPF 

     

    HTH

    Thx

    Alex

     

     

     

     

     

     



  • 7.  RE: Juniper Equivalent to Cisco Loopback Interfaces / VyOS Dummy Interfaces

    Posted 06-06-2020 23:00

    Hi there,

    I will try the logical tunnel interfaces on my vSRX box when I get the chance to. It does seem promising.

     

    Looks like I should be able to use a combination of loopback units (since they can have multiple associated IP addresses for BGP update-sources and things of that nature) and the logical tunnel interfaces to simulate the functionality I might get out of the following Cisco commands:

     

    AwesomeRouter(config)#interface loopback 1
    AwesomeRouter(config-int)#ip address 1.1.1.1 255.255.255.255
    AwesomeRouter(config-int)#ip ospf 1 area 1
    AwesomeRouter(config-int)#interface loopback 2
    AwesomeRouter(config-int)#ip address 2.2.2.2 255.255.255.255
    AwesomeRouter(config-int)#ip ospf 1 area 2

    Please feel free to correct me if I'm wrong in that assumption. I will report back to see whether the LT interface suggestion helps! Thank you to everyone for your help, it has been invaluable.