Routing

Expand all | Collapse all

Cannot use command "show vlan" in MX960

  • 1.  Cannot use command "show vlan" in MX960

    Posted 05-21-2016 13:46

    Hi I cannot type command "show vlan" in MX960 in any mode. Any one can give some suggestion? Thank you



  • 2.  RE: Cannot use command "show vlan" in MX960

     
    Posted 05-22-2016 06:12

    The vlan hierarchy is only on the SRX and EX series devices.  On the MX we use bridge domains and the vlan id attribute on interfaces for layer 2 configurations.

     

    http://www.juniper.net/documentation/en_US/junos15.1/topics/concept/layer-2-bridge-domain-environment-overview-mx-solutions.html



  • 3.  RE: Cannot use command "show vlan" in MX960

    Posted 05-22-2016 12:00

    Thank you so much for your reply. Do we have some commands to show vlan status for MX960? 



  • 4.  RE: Cannot use command "show vlan" in MX960

     
    Posted 05-23-2016 17:57

    The functional equivalent command would be 

    show bridge domain

     

    http://www.juniper.net/documentation/en_US/junos14.1/topics/reference/command-summary/show-bridge-domain-command.html

     

    Here is a fuller description of layer 2 configuration examples on the MX series for reference.

     

    http://www.juniper.net/documentation/en_US/junos15.1/topics/example/layer-2-bridge-domain-environment-example-mx-solutions.html



  • 5.  RE: Cannot use command "show vlan" in MX960

    Posted 05-24-2016 08:24

    Thank you so much for your reply. The router has vlan. please see below. but when I enter command show bidge damain, it shows nothing. Maybe I did something wrong? 

     

    xe-1/0/0.10 up up aenet --> ae1.10
    xe-1/0/0.17 up up aenet --> ae1.17



  • 6.  RE: Cannot use command "show vlan" in MX960

     
    Posted 05-26-2016 03:31

    Hard to tell from the partial output, but it would appear your system is using the alternative method for vlan assignment, configuring directly on the interface.  In Juniper gear you can create the bridge doman/vlan and assign interfaces to this.  Or you can directly assign vlan tags to the sub interface.

     

    And in your case there may also be a physical interface versus ae bundle too.  Typically here you assign the physical interface to the ae bundle then configure the sub interface parameters on the ae logical interface.

     

    to have a look at the interface vlan id setup use 

    show configuration interface ae1



  • 7.  RE: Cannot use command "show vlan" in MX960

    Posted 05-10-2018 02:28

    This is such a weird caveat as now the only way to check the VLAN assignment is from the configuration itself.

    But hey, it works.