Routing

Expand all | Collapse all

IS-IS Quick question

Jump to Best Answer
  • 1.  IS-IS Quick question

     
    Posted 09-12-2017 00:27

    As we are utilising IPv6, I wanted to use part of that IPv6 address as the unique ID in the NET address, so something along the lines of:

     

    49.0001.34a4.29a6.0000.000e.00

     

    Although the MX240 accepts the command and commits okay, when I look in the database, it tells me that the addresses are an invalid format..... Is that because of the Letters (alpha) rather than purely numeric? Or is there something else wrong?

     

    It's obviously easy for me to check if the NET address is Alpha/Numeric capable simply by changing it to all numbers and looking, but thought I would ask if anyone had seen this behaviour before?

     

     



  • 2.  RE: IS-IS Quick question
    Best Answer

    Posted 09-12-2017 00:58

    no the sytem id is too long

    49.0001.34a4.29a6.0000.000e.00

    correct

    49.0001.34a4.29a6.0000..00

    49.area.systemid.00

    systemid is 6 byte on juniper not 8 byte, even though the standard allows also larger system-ids

    1921.6824.0199

     

    regards

     

    alexander



  • 3.  RE: IS-IS Quick question

     
    Posted 09-12-2017 02:12

    Hi Alexander,

     

    Many apologies, I typed this wrong.... we have the address configured correctly.... the 0000 is not there so it is the correct length.

     

    We have IS-IS working as we are now able to ping to different networks but the actual seems to be the following:

     

    I have set the following:

     

    [edit protocols isis]

    set traceoptions file isisdebug

    set traceoptions flag error

     

    I see the following in the output, but cannot see any issues in the config:

     

    Notification not sent due to 5-second throttle as per rfc4444: isisSequenceNumberSkip

    ERROR: IS-IS instance does not have a valid router ID

     

    This does not seem right.... the IPv6 pings from anywhere to anywhere and all addresses are unique. As mentioned, although ISIS is operating correctly, I wanted to know what these errors really mean.

     

    Thanks



  • 4.  RE: IS-IS Quick question

     
    Posted 09-12-2017 02:34

    Many apologies to everyone for wasting your time....

     

    I did not notice that I had the same NET address on two of the routers. We have now fixed this issue and are seeing no more errors in the log file.

     

    Thanks for your help.