Routing

Expand all | Collapse all

configure static P2MP LSP for MVPN !

Jump to Best Answer
  • 1.  configure static P2MP LSP for MVPN !

    Posted 06-02-2017 07:47

    Hi,

    I have the MVPN lab. i try to configure static P2MP LSP but i can not commit. When i commit, junos show me the error :

     

    [edit routing-instances black provider-tunnel selective group 233.3.3.3/32 source 10.0.0.100/32 rsvp-te static-lsp]
    'static-lsp P2MP-TEST'
    Referenced point-to-multipoint static LSP does not exist
    error: configuration check-out failed: (statements constraint check failed)

     

    I haved searched on the internet but didnt see any thing about this error.

    This is my configuration:

     

    lab@PE-1#show protocols mpls
    label-switched-path TO-PE-2 {
    to 3.3.3.3;
    optimize-timer 180;
    p2mp P2MP-TEST;
    }
    label-switched-path TO-PE-3 {
    to 4.4.4.4;
    optimize-timer 180;
    p2mp P2MP-TEST;
    }

     

    lab@PE-1# show routing-instances black
    instance-type vrf;
    interface ge-0/0/2.2;
    interface lo0.41;
    route-distinguisher 44444:101;
    selective {
    group 233.3.3.3/32 {
    source 10.0.0.100/32 {
    rsvp-te {
    ##
    ## Warning: Referenced point-to-multipoint static LSP does not exist
    ##
    static-lsp P2MP-TEST;
    }
    }
    }
    }
    }
    vrf-target target:45543:111;
    vrf-table-label;
    routing-options {
    static {
    route 10.0.0.0/24 next-hop 10.0.1.1;
    }
    multicast {
    ssm-groups [ 239.0.0.0/8 232.0.0.0/8 ];
    asm-override-ssm;
    }
    }
    protocols {
    pim {
    rp {
    local {
    address 41.41.41.41;
    }
    }
    interface all {
    mode sparse-dense;
    }
    }
    mvpn;
    }

     

    Thanks for any idea.



  • 2.  RE: configure static P2MP LSP for MVPN !

     
    Posted 06-02-2017 14:50

    I think you are missing "provider tunnel" level in your vrf configuration.

     

     

    rsvp-te {
    ##
    ## Warning: Referenced point-to-multipoint static LSP does not exist
    ##
    static-lsp P2MP-TEST;
    
    should be
    
    provider-tunnel {
          rsvp-te {
                static-lsp P2MP-TEST;


  • 3.  RE: configure static P2MP LSP for MVPN !

    Posted 06-02-2017 20:03

    Hi,

    Sorry because of my missed configuration,

     

    [edit  routing-instances black]

    lab@PE-1# show 
    instance-type vrf;
    interface ge-0/0/2.2;
    interface lo0.41;
    route-distinguisher 45543:101;
    provider-tunnel {
    rsvp-te {
    ##
    ## Warning: Referenced point-to-multipoint static LSP does not exist
    ##
    static-lsp P2MP-TEST;
    }
    }
    vrf-target target:45543:111;
    vrf-table-label;
    routing-options {
    static {
    route 10.0.0.0/24 next-hop 10.0.1.1;
    }
    multicast {
    ssm-groups [ 239.0.0.0/8 232.0.0.0/8 ];
    asm-override-ssm;
    }
    }
    protocols {
    pim {
    rp {
    local {
    address 41.41.41.41;
    }
    }
    interface all {
    mode sparse-dense;
    }
    }
    mvpn;
    }

     

    Junos still display the warning in the configuration and error when committing:

    lab@PE-1# commit check
    [edit routing-instances black provider-tunnel rsvp-te static-lsp]

    'static-lsp P2MP-TEST'
    Referenced point-to-multipoint static LSP does not exist
    error: configuration check-out failed: (statements constraint check failed)

     

    Although the p2mp LSP have created already:

    lab@PE-1# run show rsvp session p2mp 
    Ingress RSVP: 2 sessions
    P2MP name: P2MP-TEST, P2MP branch count: 2
    To From State Rt Style Labelin Labelout LSPname
    4.4.4.4 1.1.1.1 Up 0 1 SE - 299840 TO-PE-3
    3.3.3.3 1.1.1.1 Up 0 1 SE - 299840 TO-PE-2

     

    Thanks ! 🙂



  • 4.  RE: configure static P2MP LSP for MVPN !

     
    Posted 06-03-2017 04:17

    That all looks correct.  Do you have tunneling services activated on the fpc/pic combination invovled?

     

    chassis {
         fpc 0 {
             pic 0 {
                  tunnel-services {
                       bandwidth 1g;
                      }
                  }
           }
    }


  • 5.  RE: configure static P2MP LSP for MVPN !

    Posted 06-03-2017 05:37

    Hi,

    I have tunneling services activated.

    lab@PE-1# show chassis
    fpc 0 {
    pic 0 {
    tunnel-services {
    bandwidth 1g;
    }
    }
    }

     

    I try to do this with the real MX960, but Junos gives the same message.

     



  • 6.  RE: configure static P2MP LSP for MVPN !
    Best Answer

     
    Posted 06-04-2017 11:35

    I am able to clear this error in the lab on a MX480 running Junos 13.3

     

    --- JUNOS 13.3R10.2
    
    MX480# show protocols mpls 
    .....
    label-switched-path TO-PE-2 {
        to 3.3.3.3;
        optimize-timer 180;
        p2mp P2MP-TEST;
    }
    
    {master}[edit routing-instances black]
    MX480# show 
    ....
    provider-tunnel {
        rsvp-te {
            static-lsp P2MP-TEST;
        }
    }
    
    

    As soon as the static-lsp name does not match I get the same message you have above even without an attempt to commit.  I would take a close look at the exact charcater matches and heirarchies on the lsp and static-lsp configuration.



  • 7.  RE: configure static P2MP LSP for MVPN !

    Posted 06-05-2017 07:49

    Thanks for ur help,

    The problem was fixed. Because PE-1 is the logical system of the vMX, so it did not allow me to commit. I configured PE-1 to be the main router, it worked perfectly !

    And in the real lab, maybe i forgot to create the p2mp LSP in protocols mpls statement, and it is the reson why the same result was showed.

    Thanks again.



  • 8.  RE: configure static P2MP LSP for MVPN !

     
    Posted 06-05-2017 15:19

    Thanks for the update.  There are some features that don't work with LSYS.  But in this case I wonder if the LSYS has a separate protocol mpls hierarchy separate from the root/master routing instance.



  • 9.  RE: configure static P2MP LSP for MVPN !

    Posted 06-06-2017 01:44

    I'm not sure,

    But, before i changed my lab, i had created the same p2mp in the main vMX (Of couse, this LSP is down because the main vMX in my lab just a CE router, so the mpls did not run), and the commit command can be performed. The message :

    'static-lsp P2MP-TEST'
    Referenced point-to-multipoint static LSP does not exist

    does not show anymore.

    So, i dont know that there is something shared between LSYS and  the main router of vMX.