Routing

Expand all | Collapse all

RR and BGP group

Jump to Best Answer
  • 1.  RR and BGP group

    Posted 09-30-2016 03:55

    Dear Sirs

     

    I have trouble understanding the cluster concept.

    below is my bgp group

     

    root@vMX2> show bgp group
    Group Type: Internal AS: 1111 Local AS: 1111
    Name: IBGP-STD Index: 0 Flags: <>
    Holdtime: 0
    Total peers: 3 Established: 3
    11.11.11.11+63591
    44.44.44.44+179
    33.33.33.33+51429
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10
    inet.0: 5/6/5/0

     

    Group Type: Internal AS: 1111 Local AS: 1111
    Name: IBGP-RR Index: 1 Flags: <>
    Options: <Cluster>
    Holdtime: 0
    Total peers: 2 Established: 2
    88.88.88.88+179
    66.66.66.66+63537
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10
    inet.0: 0/5/3/0

    Groups: 2 Peers: 5 External: 0 Internal: 5 Down peers: 0 Flaps: 25
    Table Tot Paths Act Paths Suppressed History Damp State Pending
    inet.0
    11 5 0 0 0 0

     

    base on my existing understanding, group IBGP-RR bgp neighbor will be the route-reflector client. as such, the rule where the route i receive from the group IBGP-RR will be reflected with each other as below :

     

    root@vMX2> show route receive-protocol bgp 88.88.88.88

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    Prefix Nexthop MED Lclpref AS path
    99.99.99.0/24 88.88.88.88 0 100 I
    100.100.100.0/24 88.88.88.88 0 100 I
    120.120.120.0/24 88.88.88.88 0 100 I

     

    root@vMX2> show route advertising-protocol bgp 66.66.66.66

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    Prefix Nexthop MED Lclpref AS path
    * 36.255.39.0/24 2.2.2.3 100 I
    * 36.255.41.0/24 2.2.2.3 100 I
    * 99.99.99.0/24 77.77.77.77 0 100 I
    * 100.100.100.0/24 77.77.77.77 0 100 I
    * 210.210.210.0/24 49.49.49.9 0 100 9255 I

     

    On what i have read so far too, i will also be able to advertise the route i am learning from 88.88.88.88 to the non-clients in group IBGP-RR. however i am not able to do that as below :

     

    root@vMX2> show route receive-protocol bgp 88.88.88.88

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    Prefix Nexthop MED Lclpref AS path
    99.99.99.0/24 88.88.88.88 0 100 I
    100.100.100.0/24 88.88.88.88 0 100 I
    120.120.120.0/24 88.88.88.88 0 100 I

     

    root@vMX2> show route advertising-protocol bgp 11.11.11.11

     

    root@vMX2> show route advertising-protocol bgp 33.33.33.33

     

    root@vMX2> show route advertising-protocol bgp 44.44.44.44

    root@vMX2>

     

    per my understanding, the particular router will also not advertise route it receive from 11.11.11.11 and towards 33.33.33.33 as those are non-clients of this particular router, which is on the following behaviour below 

    root@vMX2> show route receive-protocol bgp 11.11.11.11

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    Prefix Nexthop MED Lclpref AS path
    * 36.255.39.0/24 2.2.2.3 100 I
    * 36.255.41.0/24 2.2.2.3 100 I

     

    root@vMX2> show route advertising-protocol bgp 33.33.33.33

    root@vMX2>

     

    my question will be is there a configuration error that i am not able to advertise the route i receive from my client to my non client of this particular router ? 

     

     

     



  • 2.  RE: RR and BGP group

    Posted 10-01-2016 03:25

    Hi,

     

    please share the configuration and "show bgp neighbor" output.



  • 3.  RE: RR and BGP group

    Posted 10-01-2016 06:56

    Hi adwivedi

     

    root@vMX2> show configuration | no-more
    ## Last commit: 2016-09-30 18:18:21 UTC by root
    version 14.1R1.10;
    system {
    host-name vMX2;
    root-authentication {
    encrypted-password "$1$IZuPmkhp$yhA5evYxTRErWGrzzl/M//"; ## SECRET-DATA
    }
    syslog {
    user * {
    any emergency;
    }
    file messages {
    any notice;
    authorization info;
    }
    file interactive-commands {
    interactive-commands any;
    }
    }
    }
    interfaces {
    ge-0/0/0 {
    mac 50:00:00:02:00:02;
    unit 0 {
    family inet {
    address 4.4.4.2/24;
    }
    }
    }
    ge-0/0/1 {
    mac 50:00:00:02:00:03;
    unit 0 {
    family inet {
    address 6.6.6.2/24;
    }
    }
    }
    ge-0/0/2 {
    mac 50:00:00:02:00:04;
    unit 0 {
    family inet {
    address 7.7.7.2/24;
    }
    }
    }
    ge-0/0/3 {
    mac 50:00:00:02:00:05;
    unit 0 {
    family inet {
    address 10.10.10.2/24;
    }
    }
    }
    lo0 {
    unit 0 {
    family inet {
    address 22.22.22.22/32;
    }
    }
    }
    }
    routing-options {
    static {
    route 88.88.88.88/32 next-hop 10.10.10.8;
    }
    router-id 22.22.22.22;
    autonomous-system 1111;
    }
    protocols {
    bgp {
    traceoptions {
    file bgp_ror;
    flag update receive detail;
    }
    group IBGP-RR {
    type internal;
    local-address 22.22.22.22;
    neighbor 11.11.11.11 {
    peer-as 1111;
    }
    neighbor 44.44.44.44 {
    peer-as 1111;
    }
    neighbor 33.33.33.33 {
    peer-as 1111;
    }
    }
    group IBGP-CLUSTER02 {
    type internal;
    local-address 22.22.22.22;
    cluster 22.22.22.22;
    neighbor 88.88.88.88 {
    peer-as 1111;
    }
    neighbor 66.66.66.66 {
    peer-as 1111;
    }
    }
    }
    ospf {
    export [ RM-REDISTRIBUTE-CONNECTED RM-REDISTRIBUTE-STATIC ];
    area 0.0.0.0 {
    interface lo0.0 {
    passive;
    }
    interface ge-0/0/0.0 {
    interface-type p2p;
    }
    interface ge-0/0/1.0 {
    interface-type p2p;
    }
    interface ge-0/0/2.0 {
    interface-type p2p;
    }
    }
    }
    }
    policy-options {
    policy-statement RM-REDISTRIBUTE-CONNECTED {
    term 2 {
    from protocol direct;
    then accept;
    }
    term 1 {
    from interface fxp0.0;
    then reject;
    }
    }
    policy-statement RM-REDISTRIBUTE-STATIC {
    term 1 {
    from {
    protocol static;
    tag 51;
    }
    then {
    metric 150;
    accept;
    }
    }
    term 2 {
    from {
    protocol static;
    tag 50;
    }
    then reject;
    }
    term 3 {
    from protocol static;
    then accept;
    }
    term 4 {
    then reject;
    }
    }
    }

    root@vMX2>

     

    root@vMX2> show bgp neighbor
    Peer: 11.11.11.11+179 AS 17819 Local: 22.22.22.22+53584 AS 17819
    Type: Internal State: Established Flags: <Sync>
    Last State: OpenConfirm Last Event: RecvKeepAlive
    Last Error: None
    Options: <Preference LocalAddress PeerAS Refresh>
    Local Address: 22.22.22.22 Holdtime: 90 Preference: 170
    Number of flaps: 0
    Peer ID: 11.11.11.11 Local ID: 22.22.22.22 Active Holdtime: 90
    Keepalive Interval: 30 Group index: 0 Peer index: 0
    BFD: disabled, down
    NLRI for restart configured on peer: inet-unicast
    NLRI advertised by peer: inet-unicast
    NLRI for this session: inet-unicast
    Peer supports Refresh capability (2)
    Stale routes from peer are kept for: 300
    Peer does not support Restarter functionality
    NLRI that restart is negotiated for: inet-unicast
    NLRI of received end-of-rib markers: inet-unicast
    NLRI of all end-of-rib markers sent: inet-unicast
    Peer supports 4 byte AS extension (peer-as 17819)
    Peer does not support Addpath
    Table inet.0 Bit: 10000
    RIB State: BGP restart is complete
    Send state: in sync
    Active prefixes: 2
    Received prefixes: 2
    Accepted prefixes: 2
    Suppressed due to damping: 0
    Advertised prefixes: 0
    Last traffic (seconds): Received 5 Sent 10 Checked 21
    Input messages: Total 2586 Updates 2 Refreshes 0 Octets 49185
    Output messages: Total 2585 Updates 2 Refreshes 0 Octets 49244
    Output Queue[0]: 0
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10

    Peer: 33.33.33.33+179 AS 17819 Local: 22.22.22.22+61960 AS 17819
    Type: Internal State: Established Flags: <Sync>
    Last State: OpenConfirm Last Event: RecvKeepAlive
    Last Error: None
    Options: <Preference LocalAddress PeerAS Refresh>
    Local Address: 22.22.22.22 Holdtime: 90 Preference: 170
    Number of flaps: 0
    Peer ID: 33.33.33.33 Local ID: 22.22.22.22 Active Holdtime: 90
    Keepalive Interval: 30 Group index: 0 Peer index: 2
    BFD: disabled, down
    NLRI for restart configured on peer: inet-unicast
    NLRI advertised by peer: inet-unicast
    NLRI for this session: inet-unicast
    Peer supports Refresh capability (2)
    Stale routes from peer are kept for: 300
    Peer does not support Restarter functionality
    NLRI that restart is negotiated for: inet-unicast
    NLRI of received end-of-rib markers: inet-unicast
    NLRI of all end-of-rib markers sent: inet-unicast
    Peer supports 4 byte AS extension (peer-as 17819)
    Peer does not support Addpath
    Table inet.0 Bit: 10000
    RIB State: BGP restart is complete
    Send state: in sync
    Active prefixes: 2
    Received prefixes: 2
    Accepted prefixes: 2
    Suppressed due to damping: 0
    Advertised prefixes: 0
    Last traffic (seconds): Received 12 Sent 21 Checked 58
    Input messages: Total 2584 Updates 2 Refreshes 0 Octets 49154
    Output messages: Total 2583 Updates 2 Refreshes 0 Octets 49206
    Output Queue[0]: 0
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10

    Peer: 44.44.44.44+179 AS 17819 Local: 22.22.22.22+57643 AS 17819
    Type: Internal State: Established Flags: <Sync>
    Last State: OpenConfirm Last Event: RecvKeepAlive
    Last Error: None
    Options: <Preference LocalAddress PeerAS Refresh>
    Local Address: 22.22.22.22 Holdtime: 90 Preference: 170
    Number of flaps: 0
    Peer ID: 44.44.44.44 Local ID: 22.22.22.22 Active Holdtime: 90
    Keepalive Interval: 30 Group index: 0 Peer index: 1
    BFD: disabled, down
    NLRI for restart configured on peer: inet-unicast
    NLRI advertised by peer: inet-unicast
    NLRI for this session: inet-unicast
    Peer supports Refresh capability (2)
    Stale routes from peer are kept for: 300
    Peer does not support Restarter functionality
    NLRI that restart is negotiated for: inet-unicast
    NLRI of received end-of-rib markers: inet-unicast
    NLRI of all end-of-rib markers sent: inet-unicast
    Peer supports 4 byte AS extension (peer-as 17819)
    Peer does not support Addpath
    Table inet.0 Bit: 10000
    RIB State: BGP restart is complete
    Send state: in sync
    Active prefixes: 1
    Received prefixes: 2
    Accepted prefixes: 1
    Suppressed due to damping: 0
    Advertised prefixes: 0
    Last traffic (seconds): Received 4 Sent 8 Checked 79
    Input messages: Total 2577 Updates 3 Refreshes 0 Octets 49052
    Output messages: Total 2584 Updates 2 Refreshes 0 Octets 49225
    Output Queue[0]: 0
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10

    Peer: 66.66.66.66+179 AS 17819 Local: 22.22.22.22+58595 AS 17819
    Type: Internal State: Established (route reflector client)Flags: <Sync>
    Last State: OpenConfirm Last Event: RecvKeepAlive
    Last Error: None
    Options: <Preference LocalAddress Cluster PeerAS Refresh>
    Local Address: 22.22.22.22 Holdtime: 90 Preference: 170
    Number of flaps: 0
    Peer ID: 66.66.66.66 Local ID: 22.22.22.22 Active Holdtime: 90
    Keepalive Interval: 30 Group index: 1 Peer index: 1
    BFD: disabled, down
    NLRI for restart configured on peer: inet-unicast
    NLRI advertised by peer: inet-unicast
    NLRI for this session: inet-unicast
    Peer supports Refresh capability (2)
    Stale routes from peer are kept for: 300
    Peer does not support Restarter functionality
    NLRI that restart is negotiated for: inet-unicast
    NLRI of received end-of-rib markers: inet-unicast
    NLRI of all end-of-rib markers sent: inet-unicast
    Peer supports 4 byte AS extension (peer-as 17819)
    Peer does not support Addpath
    Table inet.0 Bit: 10001
    RIB State: BGP restart is complete
    Send state: in sync
    Active prefixes: 0
    Received prefixes: 2
    Accepted prefixes: 0
    Suppressed due to damping: 0
    Advertised prefixes: 5
    Last traffic (seconds): Received 16 Sent 19 Checked 3
    Input messages: Total 2597 Updates 2 Refreshes 0 Octets 49380
    Output messages: Total 2585 Updates 4 Refreshes 0 Octets 49397
    Output Queue[0]: 0
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10

    Peer: 88.88.88.88+179 AS 17819 Local: 22.22.22.22+62924 AS 17819
    Type: Internal State: Established (route reflector client)Flags: <Sync>
    Last State: OpenConfirm Last Event: RecvKeepAlive
    Last Error: None
    Options: <Preference LocalAddress Cluster PeerAS Refresh>
    Local Address: 22.22.22.22 Holdtime: 90 Preference: 170
    Number of flaps: 0
    Peer ID: 88.88.88.88 Local ID: 22.22.22.22 Active Holdtime: 90
    Keepalive Interval: 30 Group index: 1 Peer index: 0
    BFD: disabled, down
    NLRI for restart configured on peer: inet-unicast
    NLRI advertised by peer: inet-unicast
    NLRI for this session: inet-unicast
    Peer supports Refresh capability (2)
    Stale routes from peer are kept for: 300
    Peer does not support Restarter functionality
    Peer does not support Receiver functionality
    Peer supports 4 byte AS extension (peer-as 17819)
    Peer does not support Addpath
    Table inet.0 Bit: 10001
    RIB State: BGP restart is complete
    Send state: in sync
    Active prefixes: 0
    Received prefixes: 3
    Accepted prefixes: 3
    Suppressed due to damping: 0
    Advertised prefixes: 5
    Last traffic (seconds): Received 1 Sent 19 Checked 12
    Input messages: Total 2564 Updates 2 Refreshes 0 Octets 48764
    Output messages: Total 2585 Updates 3 Refreshes 0 Octets 49320
    Output Queue[0]: 0
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10

    root@vMX2>



  • 4.  RE: RR and BGP group

    Posted 10-01-2016 07:41

    Hi,

    I can see that your both neighbor has "Active prefixes: 0

     

    Either fix this or configure advertise-inactive

     

    https://www.juniper.net/documentation/en_US/junos16.1/topics/example/bgp-advertise-inactive.html



  • 5.  RE: RR and BGP group

    Posted 10-01-2016 07:56

    Hi

     

    I think the reason why it is inactive is partly due to another router advertising the same prefix.

    can i still receive from 88.88.88.88 in the output above and advertise towards all the non-clients ? 

     

    i tried advertise inactive but it still wouldnt show as advertising the inactive path. is there a way to do this ?

     

    root@vMX2> show bgp group
    Group Type: Internal AS: 17819 Local AS: 17819
    Name: IBGP-RR Index: 0 Flags: <Export Eval>
    Options: <AdvertiseInactive>
    Holdtime: 0
    Total peers: 3 Established: 3
    11.11.11.11+179
    44.44.44.44+179
    33.33.33.33+179
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10
    inet.0: 5/6/5/0

    Group Type: Internal AS: 17819 Local AS: 17819
    Name: IBGP-CLUSTER02 Index: 1 Flags: <Export Eval>
    Options: <Cluster>
    Holdtime: 0
    Total peers: 2 Established: 2
    88.88.88.88+179
    66.66.66.66+179
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10
    inet.0: 0/5/3/0

    Groups: 2 Peers: 5 External: 0 Internal: 5 Down peers: 0 Flaps: 0
    Table Tot Paths Act Paths Suppressed History Damp State Pending
    inet.0
    11 5 0 0 0 0

    root@vMX2>

     

    root@vMX2> show route receive-protocol bgp 88.88.88.88

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    Prefix Nexthop MED Lclpref AS path
    99.99.99.0/24 88.88.88.88 0 100 I
    100.100.100.0/24 88.88.88.88 0 100 I
    120.120.120.0/24 88.88.88.88 0 100 I

    root@vMX2> show route advertising-protocol bgp 11.11.11.11

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    Prefix Nexthop MED Lclpref AS path
    120.120.120.0/24 88.88.88.88 0 100 I

     

    root@vMX2> show route advertising-protocol bgp 33.33.33.33

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    Prefix Nexthop MED Lclpref AS path
    120.120.120.0/24 88.88.88.88 0 100 I

     

    root@vMX2> show route advertising-protocol bgp 44.44.44.44

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    Prefix Nexthop MED Lclpref AS path
    120.120.120.0/24 88.88.88.88 0 100 I



  • 6.  RE: RR and BGP group

    Posted 10-01-2016 11:35

    I see one prefix  120.120.120.0/24 is advertised. you can follow the given link to modify config for advertising the inactive routes.



  • 7.  RE: RR and BGP group

    Posted 10-02-2016 06:04

     

    Hi

    I tried to have the configuration and it seems i still cannot advertise the route.

    root@vMX2> show configuration protocols bgp group IBGP-RR
    type internal;
    local-address 22.22.22.22;
    export ADV_BGP_INACTIVE;
    neighbor 11.11.11.11 {
    peer-as 1111;
    }
    neighbor 44.44.44.44 {
    peer-as 1111;
    }
    neighbor 33.33.33.33 {
    peer-as 1111;
    }

     

    root@vMX2> show policy ADV_BGP_INACTIVE
    Policy ADV_BGP_INACTIVE:
    Term 1:
    from proto BGP
    prefix-list ORIGINATED_ROUTES
    state inactive
    route filter:
    99.99.99.0/24 exact
    100.100.100.0/24 exact
    then accept

     

    root@vMX2>

    root@vMX2> show bgp neighbor 11.11.11.11
    Peer: 11.11.11.11+50930 AS 1111 Local: 22.22.22.22+179 AS 1111
    Type: Internal State: Established Flags: <Sync>
    Last State: OpenConfirm Last Event: RecvKeepAlive
    Last Error: Cease
    Export: [ ADV_BGP_INACTIVE ]
    Options: <Preference LocalAddress PeerAS Refresh>
    Local Address: 22.22.22.22 Holdtime: 90 Preference: 170
    Number of flaps: 1
    Last flap event: Stop
    Error: 'Cease' Sent: 1 Recv: 0
    Peer ID: 11.11.11.11 Local ID: 22.22.22.22 Active Holdtime: 90
    Keepalive Interval: 30 Group index: 0 Peer index: 1
    BFD: disabled, down
    NLRI for restart configured on peer: inet-unicast
    NLRI advertised by peer: inet-unicast
    NLRI for this session: inet-unicast
    Peer supports Refresh capability (2)
    Stale routes from peer are kept for: 300
    Peer does not support Restarter functionality
    NLRI that restart is negotiated for: inet-unicast
    NLRI of received end-of-rib markers: inet-unicast
    NLRI of all end-of-rib markers sent: inet-unicast
    Peer supports 4 byte AS extension (peer-as 1111)
    Peer does not support Addpath
    Table inet.0 Bit: 10000
    RIB State: BGP restart is complete
    Send state: in sync
    Active prefixes: 2
    Received prefixes: 2
    Accepted prefixes: 2
    Suppressed due to damping: 0
    Advertised prefixes: 0
    Last traffic (seconds): Received 15 Sent 11 Checked 28
    Input messages: Total 59 Updates 3 Refreshes 0 Octets 1259
    Output messages: Total 75 Updates 17 Refreshes 1 Octets 2176
    Output Queue[0]: 0
    Trace options: detail recv update
    Trace file: /var/log/bgp_ror size 131072 files 10

    root@vMX2> show route 99.99.99.0 detail
    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    99.99.99.0/24 (2 entries, 1 announced)
    *BGP Preference: 170/-101
    Next hop type: Indirect
    Address: 0x940d9a8
    Next-hop reference count: 6
    Source: 33.33.33.33
    Next hop type: Router, Next hop index: 1048575
    Next hop: 4.4.4.1 via ge-0/0/0.0, selected
    Session Id: 0x5
    Next hop: 6.6.6.4 via ge-0/0/1.0
    Session Id: 0x3
    Protocol next hop: 77.77.77.77
    Indirect next hop: 0x9618220 1048578 INH Session ID: 0x30
    State: <Active Int Ext>
    Local AS: 1111 Peer AS: 1111
    Age: 27:01 Metric: 0 Metric2: 0
    Validation State: unverified
    Task: BGP_1111.33.33.33.33+61118
    Announcement bits (3): 0-KRT 4-BGP_RT_Background 5-Resolve tree 1
    AS path: I (Originator)
    Cluster list: 33.33.33.33
    Originator ID: 77.77.77.77
    Accepted
    Localpref: 100
    Router ID: 33.33.33.33
    BGP Preference: 170/-101
    Next hop type: Indirect
    Address: 0x940fb74
    Next-hop reference count: 3
    Source: 88.88.88.88
    Next hop type: Router, Next hop index: 570
    Next hop: 10.10.10.8 via ge-0/0/3.0, selected
    Session Id: 0x1
    Protocol next hop: 88.88.88.88
    Indirect next hop: 0x9618330 - INH Session ID: 0x0
    State: <NotBest Int Ext>
    Inactive reason: Not Best in its group - Router ID
    Local AS: 1111 Peer AS: 1111
    Age: 26:45 Metric: 0 Metric2: 0
    Validation State: unverified
    Task: BGP_1111.88.88.88.88+179
    AS path: I
    Accepted
    Localpref: 100
    Router ID: 88.88.88.88

     

    Below is the route that i want to advertise towards the non-clients from the receiving route-reflector client

     

    root@vMX2> show route 99.99.99.0 detail

    inet.0: 33 destinations, 38 routes (32 active, 0 holddown, 3 hidden)
    99.99.99.0/24 (2 entries, 1 announced)
    *BGP Preference: 170/-101
    Next hop type: Indirect
    Address: 0x940d9a8
    Next-hop reference count: 6
    Source: 33.33.33.33
    Next hop type: Router, Next hop index: 1048575
    Next hop: 4.4.4.1 via ge-0/0/0.0, selected
    Session Id: 0x5
    Next hop: 6.6.6.4 via ge-0/0/1.0
    Session Id: 0x3
    Protocol next hop: 77.77.77.77
    Indirect next hop: 0x9618220 1048578 INH Session ID: 0x30
    State: <Active Int Ext>
    Local AS: 1111 Peer AS: 1111
    Age: 27:01 Metric: 0 Metric2: 0
    Validation State: unverified
    Task: BGP_1111.33.33.33.33+61118
    Announcement bits (3): 0-KRT 4-BGP_RT_Background 5-Resolve tree 1
    AS path: I (Originator)
    Cluster list: 33.33.33.33
    Originator ID: 77.77.77.77
    Accepted
    Localpref: 100
    Router ID: 33.33.33.33
    BGP Preference: 170/-101
    Next hop type: Indirect
    Address: 0x940fb74
    Next-hop reference count: 3
    Source: 88.88.88.88
    Next hop type: Router, Next hop index: 570
    Next hop: 10.10.10.8 via ge-0/0/3.0, selected
    Session Id: 0x1
    Protocol next hop: 88.88.88.88
    Indirect next hop: 0x9618330 - INH Session ID: 0x0
    State: <NotBest Int Ext>
    Inactive reason: Not Best in its group - Router ID
    Local AS: 1111 Peer AS: 1111
    Age: 26:45 Metric: 0 Metric2: 0
    Validation State: unverified
    Task: BGP_1111.88.88.88.88+179
    AS path: I
    Accepted
    Localpref: 100
    Router ID: 88.88.88.88

    root@vMX2>

     

    As you can see in the other router, there is only 1 bgp path installed, is there a way to see 2 bgp path ?

    it is due to the route receiving from vMX2 from 88.88.88.88 is not active i suppose

     

    root@vMX3> show route protocol bgp 99.99.99.0

    inet.0: 33 destinations, 36 routes (31 active, 0 holddown, 4 hidden)
    + = Active Route, - = Last Active, * = Both

    99.99.99.0/24 *[BGP/170] 1d 18:44:09, MED 0, localpref 100, from 77.77.77.77
    AS path: I, validation-state: unverified
    > to 9.9.9.7 via ge-0/0/3.0



  • 8.  RE: RR and BGP group
    Best Answer

     
    Posted 10-02-2016 07:25

    please try add-path between your non-clients ..

     

    This will solve your problem



  • 9.  RE: RR and BGP group

    Posted 10-02-2016 07:27

    Hi 

     

    After adding that command, the route are able to receive at the non-clients

     



  • 10.  RE: RR and BGP group

    Posted 07-15-2017 07:48

    Dear all 

     

    Thank you for support.

     

    I have one question regarding add-path command in the RR topologie.

    should we use this command with advertise-inactive or only this command add-path send in the RR and add-path receive in the clients, will advertise inactive route to clients?

     

    Welcome to any other information about add-path send /receive.

     

    Regards

     



  • 11.  RE: RR and BGP group

    Posted 07-21-2017 09:43

    if i remember correctly, i did the add-path command on both the send/receive in the lab previously.
    I can get another active route towards the destination, this is without the advertise-inactive. 
    hope this helps