Contrail

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Contrail 3.0: Installation Dependency Issues

    Posted 04-13-2016 08:23

    Trying to install a single node Contrail 3.0 setup. 

     

    - Ubuntu 14.04.4: ubuntu-14.04.4-server-amd64.iso

    - Contrail 3.0.0 Ubuntu (OpenStack Kilo): contrail-install-packages_3.0.0.0-2725-ubuntu-14-04kilo_all.deb

     

    Procedure is pretty straightforward:

     

    1. Copy package to host:

    cp ~/Downloads/contrail-install-packages_3.0.0.0-2725-ubuntu-14-04kilo_all.deb root@10.10.10.100:/root

     

    2. Unpack and setup

    dpkg -i /root/contrail-install-packages_3.0.0.0-2725-ubuntu-14-04kilo_all.deb
    cd /opt/contrail/contrail_packages/ ; ./setup.sh

     

    3. Edit testbed.py

    cd /opt/contrail/utils/fabfile/testbeds/

    cp testbed_singlebox_example.py testbed.py

    nano /opt/contrail/utils/fabfile/testbeds/testbed.py

     

    4. Install Contrail

    cd /opt/contrail/utils/

    fab install_contrail

     

    Eventually, this fails:

     

    2016-04-13 07:45:29:058197: [root@10.10.10.100] out: The following packages have unmet dependencies:
    2016-04-13 07:45:29:058288: [root@10.10.10.100] out: contrail-openstack : Depends: keystone but it is not going to be installed
    2016-04-13 07:45:29:058408: [root@10.10.10.100] out: Depends: nova-novncproxy but it is not going to be installed
    2016-04-13 07:45:29:058505: [root@10.10.10.100] out: E: Unable to correct problems, you have held broken packages.

     

    I've done a bunch of messing around with trying to manually install packages with no luck. In the Contrail 2.20 days I was able to eventually figure out what magic combination of packages installed before Contrail installation is attempted, and also during Contrail installation would produce a working system where the fab install_contrail command would actually succeed. I've not been so lucky in the Contrail 3.0 attempt so far. Has anyone seen this and been able to fix it?

     

    Also, why does Juniper keep distributing broken Contrail packages? I really shouldn't need to do all this. 


    #Contrail3.0
    #Contrail


  • 2.  RE: Contrail 3.0: Installation Dependency Issues

     
    Posted 04-13-2016 09:10

    Hi Chris,

     

    When I was doing that the magic combination was to just install a bare minimal Ubuntu, with OpenSSH as an only optional package. That was not Contrail 3.0 however.

     



  • 3.  RE: Contrail 3.0: Installation Dependency Issues

    Posted 04-13-2016 09:13

    Yup, same here. Absolute base Ubuntu install with OpenSSH being the only thing selected. I did a lot of manual package installations before and eventually got it working. Not having any luck doing that with Contrail 3.0 yet. 



  • 4.  RE: Contrail 3.0: Installation Dependency Issues
    Best Answer

    Posted 04-14-2016 09:53

    So apparently the solution is "use the recommended version of Ubuntu".

     

    I was using Ubuntu 14.04.4, but recommended is 14.04.2. When I switched to .2, Contrail 3.0 installed without having to use ANY manual dependency adds. That's actually the first time since I started using Contrail (1.05) where I've had no issues. I'm shocked. 

     

    Thanks all for the help.



  • 5.  RE: Contrail 3.0: Installation Dependency Issues

     
    Posted 04-14-2016 15:44

    Good to know you've solved it. Actually when I read you are using 14.04.4 I just thought that one is now recommended.