Switching

 View Only
last person joined: 13 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Understanding MVRP (Cont)

    Posted 03-25-2021 21:54
    ​Ok, I'm new to Juniper, and am working on configuring some new switches for a new network.  I've worked with Cisco so I'm familiar with how they do things, so I just need to get my bearings on how Juniper does things.

    Right now I'm trying to figure out MVRP.  As others have mentioned, people are looking for the VTP equivalent on Juniper which is MVRP.  However I'm having a hard time grasping this concept, probably mostly because I'm trying to equate it to VTP.  So, I need someone to explain to me like I'm five to concepts of MVRP and how to make it work the way I want to.

    I have two QFX5120 switches in a VC that are to act as the core switch.  On that, I have created a handful of vlans and assigned them layer 3 interfaces so the can be the core router for the vlan.

    >show configuration vlans
    default {
        vlan-id 1;
        l3-interface irb.0;
    }
    v110-voip-svr-net {
        vlan-id 110;
        l3-interface irb.110;
    }
    v180-vdi-client-net {
        vlan-id 180;
        l3-interface irb.180;
    }
    v181-vdi-atty1-net {
        vlan-id 181;
        l3-interface irb.181;
    }
    v182-vdi-atty2-net {
        vlan-id 182;
        l3-interface irb.182;
    }
    v183-vdi-staff1-net {
        vlan-id 183;
        l3-interface irb.183;
    }
    v184-vdi-staff2-net {
        vlan-id 184;
        l3-interface irb.184;
    }
    v185-admin-wkstn-net {
        vlan-id 185;
        l3-interface irb.185;
    }
    v186-vdi-cntrctr-net {
        vlan-id 186;
        l3-interface irb.186;
    }
    v501-svr-net {
        vlan-id 501;
        l3-interface irb.501;
    }
    
    >show configuration interfaces
    irb {
        unit 110 {
            family inet {
                address 10.200.10.1/24;
            }
        }
        unit 180 {
            family inet {
                address 10.80.0.1/22;
            }
        }
        unit 181 {
            family inet {
                address 10.80.4.1/23;
            }
        }
        unit 182 {
            family inet {
                address 10.80.6.1/23;
            }
        }
        unit 183 {
            family inet {
                address 10.80.8.1/23;
            }
        }
        unit 184 {
            family inet {
                address 10.80.10.1/23;
            }
        }
        unit 185 {
            family inet {
                address 10.85.1.1/24;
            }
        }
        unit 186 {
            family inet {
                address 10.80.12.1/23;
            }
        }
        unit 501 {
            family inet {
                address 10.200.1.1/24;
            }
        }​

    The QFX VC is connected to another VC of two EX4300 switches, to be the access switches.  They are connected with a LAG, ae2 which is a trunk between the two with vlan allowed all.

    I added the LAG ae2 on both VCs to the protocol mvrp, and I see vlans in all the show mvrp commands on the QFX switch.

    > show mvrp applicant-state
    MVRP applicant state for routing instance 'default-switch'
     (VO) Very anxious observer, (VP) Very anxious passive, (VA) Very anxious new,
     (AN) Anxious new, (AA) Anxious active, (QA) Quiet active, (LA) Leaving active,
     (AO) Anxious observer, (QO) Quiet observer, (LO) Leaving observer,
     (AP) Anxious passive, (QP) Quiet passive
    
    VLAN Id     Interface          State
          1     ae2                Idle      (LO)
         75     ae2                Idle      (LO)
        110     ae2                Idle      (LO)
        180     ae2                Idle      (LO)
        181     ae2                Idle      (LO)
        182     ae2                Idle      (LO)
        183     ae2                Idle      (LO)
        184     ae2                Idle      (LO)
        185     ae2                Idle      (LO)
        186     ae2                Idle      (LO)
        501     ae2                Idle      (LO)


    But I do not see anything on the EX switches:

    > show mvrp applicant-state
    MVRP applicant state for routing instance 'default-switch'
     (VO) Very anxious observer, (VP) Very anxious passive, (VA) Very anxious new,
     (AN) Anxious new, (AA) Anxious active, (QA) Quiet active, (LA) Leaving active,
     (AO) Anxious observer, (QO) Quiet observer, (LO) Leaving observer,
     (AP) Anxious passive, (QP) Quiet passive
    
    VLAN Id     Interface          State
          1     ae2                Idle      (LO)


    From what I've read so far, this is to be expected.  I guess I'm just not sure what to expect to see to know that it's working.  Ultimately, my goal is to be able to create vlans on the QFX switches and have those propagate to the access switches so that I can assign those vlans to the ports at the endpoints.  (like VTP).  So I guess I'm just looking for some direction on what to look for or configure to look at this to know if it's working properly, and if this will in fact do what I'm looking for.

    Sorry for being simple here, just trying to get to know junos.  Any help is appreciated!  Let me know if you need any other configs.  These are pretty new switches so there's not a whole lot configured on them yet.

    Thanks!



    ------------------------------
    RYAN FISHER
    ------------------------------