Switching

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

EX4300 Can't ping nothing

Jump to Best Answer
  • 1.  EX4300 Can't ping nothing

    Posted 08-04-2021 11:38

    Hi all,
    Im noob with Juniper switches, and networking at all.
    Could someone kindly tell me why non of devices on vlan 690 can't ping each other?
    Thanks in advance!

    set version 18.2R1.9
    set system root-authentication encrypted-password xxx
    set system host-name testNet
    set system services ssh root-login allow
    set system services ssh protocol-version v2
    set system services netconf ssh
    set system services web-management management-url http://192.168.1.1
    set system services web-management http
    set system syslog user * any emergency
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag packet
    set chassis aggregated-devices ethernet device-count 2
    set interfaces ge-0/0/0 description "Port assigned to VLAN 660"
    set interfaces ge-0/0/0 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members 660
    set interfaces ge-0/0/0 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/1 description "Port assigned to VLAN 690"
    set interfaces ge-0/0/1 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members 690
    set interfaces ge-0/0/1 unit 0 family ethernet-switching storm-control default
    set interfaces ge-0/0/2 unit 0 family ethernet-switching interface-mode access
    set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members 690
    
    
    set interfaces xe-0/2/0 description "Part of LAG"
    set interfaces xe-0/2/0 ether-options 802.3ad ae0
    set interfaces xe-0/2/0 unit 0 family ethernet-switching storm-control default
    deactivate interfaces xe-0/2/0 unit 0
    set interfaces xe-0/2/1 description "Part of LAG"
    set interfaces xe-0/2/1 ether-options 802.3ad ae0
    set interfaces xe-0/2/1 unit 0 family ethernet-switching storm-control default
    deactivate interfaces xe-0/2/1 unit 0
    set interfaces xe-0/2/2 unit 0 family ethernet-switching storm-control default
    set interfaces xe-0/2/3 unit 0 family ethernet-switching storm-control default
    set interfaces ae0 description "LAG interface to watchguard"
    set interfaces ae0 vlan-tagging
    set interfaces ae0 aggregated-ether-options minimum-links 2
    set interfaces ae0 aggregated-ether-options link-speed 10g
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 aggregated-ether-options lacp periodic fast
    set interfaces ae0 unit 660 vlan-id 660
    set interfaces ae0 unit 690 vlan-id 690
    set interfaces irb unit 660 family inet address 10.10.20.1/24
    set interfaces irb unit 690 family inet address 10.20.20.1/24
    set interfaces vme unit 0 family inet address 192.168.1.1/24
    set forwarding-options storm-control-profiles default all
    set protocols lldp interface all
    set protocols lldp-med interface all
    set protocols igmp-snooping vlan default
    set protocols rstp interface all
    set vlans Main-Test-VLAN vlan-id 660
    set vlans Main-Test-VLAN l3-interface irb.660
    set vlans RI-Test-VLAN vlan-id 690
    set vlans RI-Test-VLAN l3-interface irb.690
    set vlans default vlan-id 1
    set poe interface all
    


    ------------------------------
    ALEKSANDER KARAPETIAN
    ------------------------------


  • 2.  RE: EX4300 Can't ping nothing
    Best Answer

     
    Posted 08-09-2021 11:17
    I don't see an issue with the configuration here.  So first I would verify that the two devices do not have any firewall or ip tables enabled.

    On the EX check that the routed interface is up and what arp are received.
    show interface terse irb.690
    show arp interface irb.690


    ------------------------------
    Steve Puluka BSEET - Juniper Ambassador
    IP Architect - DQE Communications Pittsburgh, PA (Metro Ethernet & ISP)
    http://puluka.com/home
    ------------------------------



  • 3.  RE: EX4300 Can't ping nothing

    Posted 08-09-2021 11:17
    Hi Steve,
    Thank you for your replay.
    It was firewall indeed!
    Many thanks for your help,
    Stay safe!

    ------------------------------
    ALEKSANDER KARAPETIAN
    ------------------------------