Switching

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  VRRP between MX204 with a QFX3500 in the between... Issue with VRRP advertisement not forwarded

    Posted 09-13-2021 09:47
    Hello,

    I am currently trying to setup VRRP (v3) between 2 MX204.
    Between those MX204, I have  QFX3500 with junos 15.1R7.9 (Latest available).
    The configuration is pretty simple : 

    interfaces {
        xe-0/0/6 {
            description "Core: to sw01 (10G 1550nm)";
            ether-options {
                auto-negotiation;
                flow-control;
            }
            unit 0 {
                family ethernet-switching {
                    interface-mode trunk;
                    vlan {
                        members [ HCT-MGMT AP-Datacenter NAT ];
                    }
                    storm-control default;
                }
            }
        }
        et-0/1/0 {
            description "Core: mx204 {et-0/0/0}";
            ether-options {
                auto-negotiation;
                flow-control;
            }
            unit 0 {
                family ethernet-switching {
                    interface-mode trunk;
                    vlan {
                        members [ AP-Datacenter NAT ];
                    }
                    storm-control default;
                }
            }
        }
    }
    vlans {
        AP-Datacenter {
            description AP-Datacenter;
            vlan-id 3016;
        }
        NAT {
            description "NATed Customers";
            vlan-id 3085;
        }
    }​


    But when I do monitor traffic interface et-0/1/0.0 match vrrp I see only the VRRP packet from the mx204 directly connected on it but not from the port xe-0/0/6...

    Same issue with monitor traffic interface xe-0/0/6.0 match vrrp, I see only traffic comming from sw01 but not the traffic that should be forwared from et-0/1/0.0.

    Is there any specific setup to let the QFX forward suck packets?

    Regards



    ------------------------------
    KEVIN LOUTZ
    ------------------------------


  • 2.  RE: VRRP between MX204 with a QFX3500 in the between... Issue with VRRP advertisement not forwarded
    Best Answer

     
    Posted 09-13-2021 10:20
    Hi Kevin,
    The best way to check if the VRRP packets are egressing from QFX would be to configure a Firewall filter to match the known VRRP MAC address and see if the counter increments.



  • 3.  RE: VRRP between MX204 with a QFX3500 in the between... Issue with VRRP advertisement not forwarded

    Posted 09-14-2021 08:56
    Well I finaly found where was the issue...
    It was on a filter on MX204 that didn't allowed VRRP.
    Sorry for the noise...

    ------------------------------
    KEVIN LOUTZ
    ------------------------------



  • 4.  RE: VRRP between MX204 with a QFX3500 in the between... Issue with VRRP advertisement not forwarded

     
    Posted 09-14-2021 09:17
    Can we safely assume that both MX routers can in fact ping each other on the unique configured IP addresses to rule out any other possible issues through the switch.


  • 5.  RE: VRRP between MX204 with a QFX3500 in the between... Issue with VRRP advertisement not forwarded

     
    Posted 09-14-2021 09:17
    No problem these things happen and good to know it is not some weird behavior issues etc. Good to know it is working.

    Thanks.