Switching

Expand all | Collapse all

EX2300 switch routing issue

  • 1.  EX2300 switch routing issue

    Posted 12-06-2020 15:15
    Hi,

    I have EX2300 switch. I'm trying to connect my CPE (Customer Premises Equipment) device to internet. My internet gateway is in the one of port which is member of vlan 20. 

    192.168.80.1>>>>>>>192.168.80.4  ping is OK
    192.168.80.4>>>>>>>192.168.1.15 ping is OK
    192.168.80.1>>>>>>>192.168.1.15 ping is not OK?

    Also there is no ping  to 192.168.1.1(internet gateway) from 192.168.1.15.  Should i add some routings to connect my CPE device to the internet? Could someone help me about this topology?





    ------------------------------
    CAGRI TUNCER
    ------------------------------


  • 2.  RE: EX2300 switch routing issue

     
    Posted 12-06-2020 15:34
    Hello Cagri,

    > 192.168.80.1>>>>>>>192.168.1.15 ping is not OK?

    Do you have configured a default route (0.0.0.0/0) on this CPE device with next hop 192.168.80.4? Without this route another subnet outside this 192.168.80 cannot be reached.

    > Also there is no ping to 192.168.1.1(internet gateway) from 192.168.1.15. 

    Then it could be the case that your Internet uplink device is not working. As most probably 192.168.1.1 is in the same network as 192.168.1.15 (I assume this is a /24 network), this should work without any further route.
    Additionally, if you want to make the EX2300 reachable from the internet, you have to configure a static route as well: set routing-options statice route 0.0.0.0/0 next-hop 192.168.1.1

    Generally, without knowing details about your configuration, it is always a guess where the issue could be located.

    ------------------------------
    ------------------------------
    If my answer provides the solution, please mark my post as "Accepted Solution".
    If you think my answer helps, please spend some Kudos
    ------------------------------



  • 3.  RE: EX2300 switch routing issue

    Posted 12-07-2020 06:48
    Hello,

    I implemented what you said. After the setting  CPE'sgateway as 192.168.80.4 and adding route  192.168.1.0/24 next-hop 192.168.80.4 on CPE device ( adding route 0.0.0.0/0 unavailable on device) ping is open from CPE device to 192.168.1.15

    But  ping is not works from CPE device to 192.168.1.1 ( added route on switch 0.0.0.0/0 next-hop 192.168.1.1)
    ping to 192.168.1.1 from 192.168.1.15 ok

    Could you also let me know if there are another options to get  connected my device to internet?

    Many thanks in advance..

    ------------------------------
    CAGRI TUNCER
    ------------------------------



  • 4.  RE: EX2300 switch routing issue

    Posted 12-16-2020 10:54
    Good Day Cagri,

    Once again,
    ping is open from CPE device to 192.168.1.15 (192.168.80.4 -> 192.168.1.15 works well).
    ping is not works from CPE device to 192.168.1.1 (192.168.80.4 -> 192.168.1.1 doesn't work).
    ping to 192.168.1.1 from 192.168.1.15 ok

    Seems to me, Internet device has no idea about the network  192.168.80.0 to reply back on pings.
    The general idea how to connect the device to internet is to perform NAT (PAT) translation to outgoing interface with IP 192.168.1.15.
    Please apply NAT (PAT), this should solve your question.

    Thanks,
    Deimos.