Switching

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



Expand all | Collapse all

EX3400 configuring ERP with ELS support

Jump to Best Answer
  • 1.  EX3400 configuring ERP with ELS support

    Posted 05-04-2021 12:04
    Hi all,

    Trying to setup a ring between 6 EX3400 which are not on the same physical location. I have the cabling sorted but having issues with the config side of things. I'm following this guide from Juniper

    https://www.juniper.net/documentation/us/en/software/junos/multicast-l2/topics/example/interfaces-ethernet-ring-protection-switching-ex-series-els.html

    Here's my config so far

    root@EX-U1# show protocols protection-group
    ethernet-ring erp1 {
    ring-protection-link-owner;
    east-interface {
    control-channel {
    ge-0/0/0.0;
    }
    ring-protection-link-end;
    }
    west-interface {
    control-channel {
    ge-0/0/23.0;
    }
    }
    control-vlan 100;
    data-channel {
    vlan [ 101 102 ];
    }
    }

    root@EX-U1# show vlans
    default {
    vlan-id 1;
    l3-interface irb.0;
    }
    erp-control-vlan {
    vlan-id 100;
    }
    erp-data-vlan-1 {
    vlan-id 101;
    }
    erp-data-vlan-2 {
    vlan-id 102;
    }

    root@EX-U1# show interfaces ge-0/0/0
    unit 0 {
    family ethernet-switching;
    }

    {master:0}[edit]
    root@EX-U1# show interfaces ge-0/0/23
    unit 0 {
    family ethernet-switching {
    }
    }

    The thing is that none of the "data" vlans (101 and 102) are passing through the ring. Which I understand is because I'm not trunking port 0 and 23, as you can see. If I try to trunk the ports I get this error message (I'm allowing ALL vlans for the sake of testing)

    root@EX-U1# commit check
    [edit protocols]
    'protection-group'
    L2CPD : Unable to parse vlan-id-list for IFL ge-0/0/0.0
    error: configuration check-out failed

    If I try to add "control vlan 100" to the East and West link (as the guide says). I get the following error

    root@EX-U1# commit check
    [edit protocols]
    'protection-group'
    L2CPD : Dedicated VLAN ID must not be configured for non trunk IFL ge-0/0/0.0 in protection group configuration
    error: configuration check-out failed

    I've tried adding different scenarios with and without trunk, with and without "control vlan 100". Other options with the physical interfaces and ERP config and nothing seems to work. I just can't make 2 hosts talk to each other over the ring. 

    What am I missing here? Any advise will be much appreciated!!!

    Thanks in advance





    ------------------------------
    FER
    ------------------------------


  • 2.  RE: EX3400 configuring ERP with ELS support

     
    Posted 05-04-2021 12:15
    Hello Fer,

    It seems you need to configure the vlans on the interfaces using the vlan-id.

    set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members 100
    set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members 101
    set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members 102

    The issue is documented on the following page.

    https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/ethernet-ring-protection-cli.html

    NOTE

    When EX2300 and EX3400 ERPS switches have a VLAN-ID configured with a name under an interface hierarchy, a commit error occurs. Avoid this by configuring VLAN-IDs using numbers when they are under an interface hierarchy with ERPS configured in the switch.


    Regards,

    Randall


  • 3.  RE: EX3400 configuring ERP with ELS support

    Posted 05-05-2021 04:47
    Hello Randall,

    Thanks very much for the response. I tried adding that but is still not working, also in order to add that I need to convert the interface to trunk, which is also causing problems.

    Here's the message I get when adding those commands

    root@EX-U1# show |compare
    [edit interfaces ge-0/0/0 unit 0 family ethernet-switching]
    + vlan {
    + members 100-102;
    + }

    {master:0}[edit]
    root@EX-U1# commit check
    [edit interfaces ge-0/0/0 unit 0 family ethernet-switching vlan]
    'members 100-102'
    Vlan range format not supported if interface-mode is access
    error: configuration check-out failed

    I'm following the article you suggested. Will see if I can try to nail this down, if I manage to solve it will post the solution.

    Regards,

    ------------------------------
    FER
    ------------------------------



  • 4.  RE: EX3400 configuring ERP with ELS support
    Best Answer

    Posted 05-05-2021 09:03
    Found the solution! Here's how I solved this. Please anyone, let me know if you think this config is bad or if it can be optimized.

    root@EX-U1> show configuration vlans
    erp-control-vlan {
    vlan-id 100;
    }
    erp-data-vlan-1 {
    vlan-id 101;
    }
    erp-data-vlan-2 {
    vlan-id 102;
    }
    v10 {
    vlan-id 10;
    }

    root@EX-U1> show configuration interfaces ge-0/0/0
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members [ 10 100-102 ];
    }
    }
    }

    {master:0}
    root@EX-U1> show configuration interfaces ge-0/0/23
    unit 0 {
    family ethernet-switching {
    interface-mode trunk;
    vlan {
    members [ 10 100-102 ];
    }
    }
    }


    root@EX-U1> show configuration protocols protection-group
    ethernet-ring erp1 {
    ring-protection-link-owner;
    east-interface {
    control-channel {
    vlan 100;
    ge-0/0/0.0;
    }
    ring-protection-link-end;
    }
    west-interface {
    control-channel {
    vlan 100;
    ge-0/0/23.0;
    }
    }
    control-vlan 100;
    data-channel {
    vlan [ 101 102 10 ];
    }
    }

    NOTE: Make sure that 'ring-protection-link-owner' & 'ring-protection-link-end'  are ONLY configured on 1 switch of the ring. All the other members should not have those lines on.

    And finally the ports that will face the management kit, are just access ports

    root@EX-U2> show configuration interfaces ge-0/0/15
    unit 0 {
    family ethernet-switching {
    vlan {
    members v10;
    }
    }
    }

    This is slightly different from what both guides mentioned. But for now is working. Meaning that if a link breaks, communication will continue to run and even if 2 links breaks at the same time, some sort of communication can still happen (as the ring will break in 2 basically, so both segment will still be able to communicate but just not within each other)

    Hope this helps!

    ------------------------------
    FER
    ------------------------------



  • 5.  RE: EX3400 configuring ERP with ELS support

     
    Posted 05-05-2021 09:10
    Hello Fer,

    The configuration looks good to me, but you may need to failover to test the redundancy.

    Regards,

    Randall


  • 6.  RE: EX3400 configuring ERP with ELS support

    Posted 05-05-2021 09:12
    Hello Randall,

    Yes, I've broken this several times now and works like a charm!

    Regards,

    ------------------------------
    FER
    ------------------------------



  • 7.  RE: EX3400 configuring ERP with ELS support

     
    Posted 05-05-2021 09:18
    Good job Fer! Congrats :).  I am glad to know that is working very well.


    Regards,

    Randall