Switching

Juniper QFX 5100 MPLS randomly drops pseudowires / ccc l2circuits

  • 1.  Juniper QFX 5100 MPLS randomly drops pseudowires / ccc l2circuits

    Posted 02-28-2021 09:46
    Hi

    We have Juniper QFX5100s running randomly dropping MPLS ccc L2 circuits. They are running 17.3R3-S1.5.

    Configuration is basically:

    set protocols l2circuit neighbor 1.2.3.4  interface xe-0/0/8.0 virtual-circuit-id 418

    set protocols l2circuit neighbor 1.2.3.4  interface xe-0/0/8.0 no-control-word

    set protocols l2circuit neighbor 1.2.3.4 interface xe-0/0/8.0 mtu 1522

    set protocols mpls traffic-engineering mpls-forwarding

    set protocols mpls explicit-null

    set protocols mpls no-decrement-ttl

    set protocols mpls no-cspf

    set protocols mpls label-switched-path cisco to 1.2.3.4

    set protocols mpls interface all

    set protocols mpls interface lo0.0


    We see this in the logs at the drop:

    Feb 28 14:02:02  qfx fpc0 BRCM_COS_HALP(brcm_cos_classifier_exp_set_switch:1591): brcm_cos_classifier_exp_set_switch: ifl index is zero

    ...

    Feb 28 14:02:02  qfx fpc0 LBCM-L2,pfe_brcm_add_sd_tag_mpls_tpids(),2133:Added TPID 0x8100 on mpls_port 0x18003ff1

    All the l2circuits are dropped at this point and then reform about 30 seconds later. From the MPLS neighbour, which is a Cisco, we see this intermittently:

    %LDP-5-NBRCHG: LDP Neighbor 1.2.3.3:0 (1) is DOWN (Session KeepAlive Timer expired)


    There are no layer-2 issues. We see connectivity never drop and no drop packets, interface resets, etc. 

    Anyone else seen this?  This one of numerous MPLS issues  we have seen with the QFX platform.

    Thanks