Switching

Expand all | Collapse all

EX4300 request snapshot to USB - syntax error

  • 1.  EX4300 request snapshot to USB - syntax error

    Posted 02-10-2021 07:45
    Hi,
    I have a cluster of two EX4300 switches and I would like to create a snapshots to USB (Junos 18.4R2-S5.4).
    I tried to do this according following documentations:
    Backing Up an Installation Using Snapshots
    request system snapshot

    but I have syntax error output when try to use 'usb' option:

    user@hostname> request system snapshot media usb
                                                                                                                            ^
    syntax error.

    {master:0}

    it is little strange for me because when I type '?' then the 'usb' option is available:

    user@hostname> request system snapshot media ?
    Possible completions:
    external Write snapshot to external storage device
    internal Write snapshot to internal flash
    usb Write snapshot to device connected to USB port


    I also tried another options but result is the same:
    request system snapshot member 0 media usb
    request system snapshot all-members media usb
    request system snapshot partition media usb


    Pendrive looks OK and meet requirements - it is a USB2.0, 4GB, FAT32:
    Feb 10 13:05:09 hostname /kernel: da1 at umass-sim1 bus 1 target 0 lun 0
    Feb 10 13:05:09 hostname /kernel: da1: <General UDisk 5.00> Removable Direct Access SCSI-2 device
    Feb 10 13:05:09 hostname /kernel: da1: 40.000MB/s transfers
    Feb 10 13:05:09 hostname /kernel: da1: 3840MB (7864320 512 byte sectors: 255H 63S/T 489C)


    Could you advice something please?







  • 2.  RE: EX4300 request snapshot to USB - syntax error

    Posted 02-10-2021 11:05
    I would expect you should use "request system snapshot partition media usb" as mentioned here: https://www.juniper.net/documentation/en_US/junos/topics/topic-map/backing-up-install-using-snapshot.html#id-creating-a-snapshot-on-a-usb-flash-drive-and-using-it-to-boot-the-ex-switch

    Please let us know if this works :)

    ------------------------------
    --
    Jonas Hauge Klingenberg - Juniper Ambassador
    ------------------------------



  • 3.  RE: EX4300 request snapshot to USB - syntax error

    Posted 02-10-2021 14:17
    Hi,
    I already wrote that I tired this and unfortunately it isn't works :(


  • 4.  RE: EX4300 request snapshot to USB - syntax error

    Posted 02-11-2021 08:05
    Hi,
    I already done upgrade to 19.1R3-S4.6 and problem no longer exist. It looks like this was a bug in 18.4R2-S5.4 version.