Switching

IMPORTANT MODERATION NOTICE

This community is currently under full moderation, meaning  all posts will be reviewed before appearing in the community. Please expect a brief delay—there is no need to post multiple times. If your post is rejected, you'll receive an email outlining the reason(s). We've implemented full moderation to control spam. Thank you for your patience and participation.



  • 1.  Active/Active MC-LAG Issue with QinQ

    Posted 10-23-2021 17:45
    Hello,

    I am trying to configure Active/Active MC-LAG from two PE MX routers to one MX CE Router running LACP. 

    AE1 are the interfaces configured into the MC-LAG.

    Here are my  PE configurations:

    set system host-name PE1
    set system root-authentication encrypted-password "$6$wmSaBZuR$RwK/bOqazvfjOV5tScCEr39HSJzTveAod9iZ4b1eNgvvqZxQJ.iYTR.l75t/o2/dyqiDoUgEPbGiq9te1AZoM/"
    set system syslog user * any emergency
    set system syslog user * match "!(.*Scheduler Oinker*.|.*Frame 0*.|.*ms without yielding*.)"
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set system processes dhcp-service traceoptions file dhcp_logfile
    set system processes dhcp-service traceoptions file size 10m
    set system processes dhcp-service traceoptions level all
    set system processes dhcp-service traceoptions flag all
    set chassis aggregated-devices ethernet device-count 2
    set interfaces ge-0/0/0 ether-options 802.3ad ae1
    set interfaces ge-0/0/1 unit 0 family bridge interface-mode trunk
    set interfaces ge-0/0/1 unit 0 family bridge vlan-id-list 10
    set interfaces ge-0/0/1 unit 0 family bridge vlan-id-list 200
    set interfaces ge-0/0/2 ether-options 802.3ad ae0
    set interfaces ge-0/0/4 ether-options 802.3ad ae0
    set interfaces ae0 flexible-vlan-tagging
    set interfaces ae0 encapsulation flexible-ethernet-services
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 unit 0 encapsulation vlan-bridge
    set interfaces ae0 unit 0 vlan-tags outer 200
    set interfaces ae0 unit 0 vlan-tags inner 100
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 multi-chassis-protection 172.16.1.2 interface ge-0/0/1
    set interfaces ae1 encapsulation flexible-ethernet-services
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp periodic fast
    set interfaces ae1 aggregated-ether-options lacp system-id aa:00:bb:11:cc:22
    set interfaces ae1 aggregated-ether-options lacp admin-key 1
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 1
    set interfaces ae1 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 0
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control active
    set interfaces ae1 unit 100 encapsulation vlan-bridge
    set interfaces ae1 unit 100 vlan-id 100
    set interfaces fxp0 unit 0 family inet dhcp vendor-id Juniper-vmx-VM6143D507E8
    set interfaces irb unit 10 family inet address 10.10.10.1/24
    set interfaces lo0 unit 0 family inet address 172.16.1.1/32
    set protocols ospf area 0.0.0.0 interface irb.10
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols iccp local-ip-addr 172.16.1.1
    set protocols iccp peer 172.16.1.2 redundancy-group-id-list 1
    set protocols iccp peer 172.16.1.2 liveness-detection minimum-interval 3000
    set protocols iccp peer 172.16.1.2 liveness-detection multiplier 3
    set bridge-domains MGMT vlan-id 10
    set bridge-domains MGMT interface ge-0/0/1.10
    set bridge-domains MGMT routing-interface irb.10
    set bridge-domains customer1 vlan-id 200
    set bridge-domains customer1vlans vlan-id none
    set bridge-domains customer1vlans service-id 2
    set bridge-domains customer1vlans interface ge-0/0/2.200
    set bridge-domains customer1vlans interface ae0.0
    set bridge-domains customer1vlans interface ae1.100
    set switch-options service-id 1
    ​

    set system host-name PE-4
    set system root-authentication encrypted-password "$6$DuGCaxVe$I249dq3tBQAjsHOZJeXoG6SFAV.4C0tTgbgx6Dm9E0oaR4cE0O98v52JqAwBzGjnBEgFcjLPn3Z.TodgVBSSG."
    set system syslog user * any emergency
    set system syslog user * match "!(.*Scheduler Oinker*.|.*Frame 0*.|.*ms without yielding*.)"
    set system syslog file messages any notice
    set system syslog file messages authorization info
    set system syslog file interactive-commands interactive-commands any
    set chassis aggregated-devices ethernet device-count 2
    set interfaces ge-0/0/1 unit 0 family bridge interface-mode trunk
    set interfaces ge-0/0/1 unit 0 family bridge vlan-id-list 10
    set interfaces ge-0/0/1 unit 0 family bridge vlan-id-list 200
    set interfaces ge-0/0/6 ether-options 802.3ad ae0
    set interfaces ge-0/0/7 ether-options 802.3ad ae0
    set interfaces ge-0/0/8 ether-options 802.3ad ae1
    set interfaces ae0 flexible-vlan-tagging
    set interfaces ae0 encapsulation flexible-ethernet-services
    set interfaces ae0 aggregated-ether-options lacp active
    set interfaces ae0 unit 0 encapsulation vlan-bridge
    set interfaces ae0 unit 0 vlan-tags outer 200
    set interfaces ae0 unit 0 vlan-tags inner 100
    set interfaces ae1 flexible-vlan-tagging
    set interfaces ae1 multi-chassis-protection 172.16.1.1 interface ge-0/0/1
    set interfaces ae1 encapsulation flexible-ethernet-services
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp periodic fast
    set interfaces ae1 aggregated-ether-options lacp system-id aa:00:bb:11:cc:22
    set interfaces ae1 aggregated-ether-options lacp admin-key 1
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 1
    set interfaces ae1 aggregated-ether-options mc-ae redundancy-group 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 1
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control standby
    set interfaces ae1 unit 100 encapsulation vlan-bridge
    set interfaces ae1 unit 100 vlan-id 100
    set interfaces irb unit 10 family inet address 10.10.10.2/24
    set interfaces lo0 unit 0 family inet address 172.16.1.2/32
    set protocols ospf area 0.0.0.0 interface irb.10
    set protocols ospf area 0.0.0.0 interface lo0.0
    set protocols iccp local-ip-addr 172.16.1.2
    set protocols iccp peer 172.16.1.1 redundancy-group-id-list 1
    set protocols iccp peer 172.16.1.1 liveness-detection minimum-interval 3000
    set protocols iccp peer 172.16.1.1 liveness-detection multiplier 3
    set bridge-domains MGMT vlan-id 10
    set bridge-domains MGMT interface ge-0/0/1.10
    set bridge-domains MGMT routing-interface irb.10
    set bridge-domains customer1 vlan-id 200
    set bridge-domains customer1vlans vlan-id none
    set bridge-domains customer1vlans service-id 2
    set bridge-domains customer1vlans interface ae0.0
    set bridge-domains customer1vlans interface ae1.100
    set switch-options service-id 1​

    I am seeing the following:
    show interfaces mc-ae
    Member Link : ae1
    Current State Machine's State: mcae active state
    Local Status : active
    Local State : up
    Peer Status : active
    Peer State : up
    Logical Interface : ae1.100
    Topology Type : bridge
    Local State : up
    Peer State : up
    Peer Ip/MCP/State : 172.16.1.2 ge-0/0/1.100 Unknown    

    Why is Peer Ip/MCP/State trying to use ge-0/0/1.100, I do not have vlan 100 as a VLAN on ge-0/0/1. Vlan 10 is the VLAN used to form connectivity for the ICL interfaces (ge-0/0/1).

    Any advice would be appreciated, this is in a lab environment for learning.

    ------------------------------
    Jack
    ------------------------------


  • 2.  RE: Active/Active MC-LAG Issue with QinQ

    Posted 10-25-2021 14:25
    From PE1, can you ping the ICCP peer, 172.16.1.2??  and/or vice versa from PE-4.  I'm thinking you may need to establish the ICCP session via a non-q-in-q interface.  Any particular reason your doing it that way(via q-in-q)???