Switching

Expand all | Collapse all

MC-LAG configuration step by step ex4200

  • 1.  MC-LAG configuration step by step ex4200

    Posted 12-17-2020 01:58

    Dear All,

    i want to configure MC-Lag in my ex4200 switch please suggest me complete step for it. 

    i t want to configure it without virtual chassis.

    Thanks and Regards.

    Umesh Sharma | 91 9007743324



    ------------------------------
    Umesh Sharma
    ------------------------------


  • 2.  RE: MC-LAG configuration step by step ex4200

     
    Posted 12-17-2020 02:14

    The EX4200 is not capable of MC-LAG operation. It can however connect to two MC-LAG peers as a client with a standard LACP aggregated ethernet interface.

    set chassis aggregated-devices ethernet device-count 1
    set interfaces xe-0/1/0 ether-options 802.3ad ae0
    set interfaces xe-1/1/0 ether-options 802.3ad ae0
    set interfaces ae0 aggregated-ether-options lacp active periodic fast
    set interfaces ae0 unit 0 family ethernet-switching port-mode trunk



  • 3.  RE: MC-LAG configuration step by step ex4200

    Posted 12-17-2020 04:08

    Thanks a lots for your reply..

    and i want to make below scenario..

    if possible please share the URL for it. 

    Thanks in advance..

    Regards..

    Umesh Sharma | 91 9007743324

     



    ------------------------------
    Umesh Sharma
    ------------------------------



  • 4.  RE: MC-LAG configuration step by step ex4200

    Posted 12-18-2020 02:42

    Hi,

    i think it will be suitable for my scenario.. 

    Configuration:

    Site-A_PC 1:

    set interfaces xe-0/1/0 unit 0 family ethernet-switching vlan members test
    set interfaces vlan unit 10 family inet address 1.1.1.1/24

    Site-B_PC 2:

    set interfaces xe-0/1/6 unit 0 family ethernet-switching vlan members test
    set interfaces vlan unit 10 family inet address 1.1.1.2/24

    Ex4200_1_Site-A:

    set protocols iccp local-ip-addr 2.3.4.1
    set protocols iccp peer 2.3.4.2 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 2.3.4.2 liveness-detection transmit-interval minimum-interval 60
    set multi-chassis multi-chassis-protection 2.3.4.1 interface ae0

    set chassis aggregated-devices ethernet device-count 2
    set interfaces et-0/0/1 ether-options 802.3ad ae1
    set interfaces et-0/0/0 ether-options 802.3ad ae0
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members all
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp system-id 00:00:00:00:00:10
    set interfaces ae1 aggregated-ether-options lacp admin-key 1
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 1
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control active
    set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
    set interfaces ae1 unit 0 family ethernet-switching vlan members test
    set interfaces xe-0/0/4:0 unit 0 family ethernet-switching vlan members test
    set interfaces irb unit 0 family inet address 2.3.4.1/24

    set vlans default vlan-id 1
    set vlans default l3-interface irb.0
    set vlans test vlan-id 10

    Ex4200_2_Site-A:

    set protocols iccp local-ip-addr 2.3.4.2
    set protocols iccp peer 2.3.4.1 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 2.3.4.1 liveness-detection transmit-interval minimum-interval 60
    set multi-chassis multi-chassis-protection 2.3.4.2 interface ae0

    set chassis aggregated-devices ethernet device-count 2
    set interfaces et-0/0/0 ether-options 802.3ad ae0
    set interfaces et-0/0/1 ether-options 802.3ad ae1
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members all
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp system-id 00:00:00:00:00:10
    set interfaces ae1 aggregated-ether-options lacp admin-key 1
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 0
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control standby
    set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
    set interfaces ae1 unit 0 family ethernet-switching vlan members test

    set vlans default vlan-id 1
    set vlans default l3-interface irb.0
    set vlans test vlan-id 10
    set vlans vlan500 vlan-id 500
    set interfaces irb unit 0 family inet address 2.3.4.2/24

    Ex400_1_Site-B:

    set protocols iccp local-ip-addr 1.2.3.1
    set protocols iccp peer 1.2.3.2 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 1.2.3.2 liveness-detection transmit-interval minimum-interval 60

    set chassis aggregated-devices ethernet device-count 2
    set interfaces et-0/0/48 ether-options 802.3ad ae1
    set interfaces et-0/0/52 ether-options 802.3ad ae0
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members all
    set interfaces ae1 aggregated-ether-options lacp active
    set interfaces ae1 aggregated-ether-options lacp system-id 00:00:00:00:00:11
    set interfaces ae1 aggregated-ether-options lacp admin-key 2
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 0
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control active
    set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
    set interfaces ae1 unit 0 family ethernet-switching vlan members test
    set interfaces irb unit 0 family inet address 1.2.3.1/24

    set vlans default vlan-id 1
    set vlans default l3-interface irb.0
    set vlans test vlan-id 10
    set vlans vlan500 vlan-id 500

    Ex4200_2_Site-B:

    set protocols iccp local-ip-addr 1.2.3.2
    set protocols iccp peer 1.2.3.1 liveness-detection minimum-receive-interval 60
    set protocols iccp peer 1.2.3.1 liveness-detection transmit-interval minimum-interval 60
    set multi-chassis multi-chassis-protection 1.2.3.2 interface ae0

    set chassis aggregated-devices ethernet device-count 2
    set interfaces et-0/0/96 ether-options 802.3ad ae1
    set interfaces et-0/0/97 ether-options 802.3ad ae0
    set interfaces ae0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ae0 unit 0 family ethernet-switching vlan members all
    set interfaces ae1 aggregated-ether-options lacp passive
    set interfaces ae1 aggregated-ether-options lacp system-id 00:00:00:00:00:11
    set interfaces ae1 aggregated-ether-options lacp admin-key 2
    set interfaces ae1 aggregated-ether-options mc-ae mc-ae-id 1
    set interfaces ae1 aggregated-ether-options mc-ae chassis-id 1
    set interfaces ae1 aggregated-ether-options mc-ae mode active-active
    set interfaces ae1 aggregated-ether-options mc-ae status-control standby
    set interfaces ae1 aggregated-ether-options mc-ae init-delay-time 240
    set interfaces ae1 unit 0 family ethernet-switching vlan members test
    set interfaces xe-0/0/0 unit 0 family ethernet-switching vlan members test
    set interfaces irb unit 0 family inet address 1.2.3.2/24

    set vlans default vlan-id 1
    set vlans default l3-interface irb.0
    set vlans test vlan-id 10
    set vlans vlan500 vlan-id 500



    ------------------------------
    Umesh Sharma
    ------------------------------



  • 5.  RE: MC-LAG configuration step by step ex4200

    Posted 12-18-2020 02:53

    updated....



    ------------------------------
    Umesh Sharma
    ------------------------------



  • 6.  RE: MC-LAG configuration step by step ex4200

    Posted 12-17-2020 03:39

    As previously mentioned, EX4200 is not capable of MCLAG. You need to go with EX4600 or QFX-series.

    Depending on your needs and design options, there is other ways to gain higher availability and throughput.

    Is it "uplink"-traffic or an end host that needs to be connected?