Expand all | Collapse all

EX3300 Configure STP on specific port (SONOS)

Jump to Best Answer
  • 1.  EX3300 Configure STP on specific port (SONOS)

    Posted 03-23-2020 04:04



    I'm running 2xEx3300 (in Virtual chassis configuration). I'm trying to configure some ports to use STP. The reason for using STP on some ports it to be able to run my sonos device with STP and the rest to use RSTP.

    (Sonos need STP when running them borth with wireless and cable connection).


    I'm failing to do so, both with J-web and cli.

    Using Jweb I have added and configured STP, but when enabling it i get the message:

    "Already RSTP instance is configured.Do you want to disable it and enable STP ?" 

    It seems I can't run both STP and RSTP.


    Trying to use CLI to enable STP

    (looking at https://www.juniper.net/documentation/en_US/junos/topics/topic-map/spanning-tree-configuring-stp.html)



    root@juniper1# set stp interface ge-1/0/4  
    missing argument.
    {master:0}[edit protocols]




    This is my current config


    root@juniper1> show configuration protocols 
    igmp-snooping {
        vlan all;
    stp {
        bridge-priority 4k;
        max-age 20;
        hello-time 2;
        forward-delay 15;
        interface ge-1/0/4.0 {
            priority 128;
            cost 10;
    rstp {
        interface ge-1/0/4.0 {
    lldp {
        interface all;
    lldp-med {
        interface all;

    Plugging in sonos device in ge-1/0/4 gives me a broadcast storm.


    How can I configure ge-1/0/4 to use STP, I want the rest to continue using RSTP.


    Thanks in advance, J

  • 2.  RE: EX3300 Configure STP on specific port (SONOS)
    Best Answer

    Posted 03-23-2020 04:18



    I believe RSTP is backward compatible with the legacy STP. 




    RSTP is backward-compatible with legacy STP; if legacy STP BPDU is detected on a link, then an RSTP-capable bridge will revert to legacy STP on that given port.


    Hope this helps



  • 3.  RE: EX3300 Configure STP on specific port (SONOS)

    Posted 03-23-2020 06:22



    Thanks. It worked using RSTP and configuring using sonos recommended settings.


    Best Regards J