Switching

Expand all | Collapse all

QFX5100 - mixing families

  • 1.  QFX5100 - mixing families

    Posted 02-06-2019 06:00

    Hello all,

     

    We've got a QFX5100-48S with on a single port 'family ethernet-switching' and 'family inet' configuration.

    This has worked for a long time, and by committing this configuration back then, the device didn't stop us.

     

    Later on, we committed another 'family inet' unit on this port and the 'family ethernet-switching' part just stopped working.

    The existing 'family inet' part kept on working.

     

    Is this something only SRX, EX and MX devices stop you from committing?

     

    Beeelze



  • 2.  RE: QFX5100 - mixing families

     
    Posted 02-06-2019 06:43

    Hi there,

     

    We can configure one family on unit 0.  If you meant, multiple subinterfaces/units with different families then you can use the "flexible-ethernet-services" feature for this config on same physical interface:

    https://www.juniper.net/documentation/en_US/junos/topics/topic-map/switches-interface-flexible.html

    https://www.juniper.net/documentation/en_US/junos/topics/topic-map/switches-interface-flexible.html

     

    The feature  is not supported on Juniper EX4xxx/EX3xxx/EX2xxx series products.  However you may always use L2-switched subinterfaces/units with a vlan configured with a vlan-id.  Then configure an irb interface assigned to that vlan and if L3 services are needed, add an IP to this IRB based on the new ELS-style config for switching products supported from 12.3R2 onwards).

    https://www.juniper.net/documentation/en_US/junos/topics/task/configuration/getting-started-els.html

     

     

    Hope this helps.

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).

    Hope this helps.

     

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).



  • 3.  RE: QFX5100 - mixing families

    Posted 02-07-2019 05:10

    Hi -r,

     

    Thanks for your response.

     

    Only 1 family on unit 0, got it! But that's not what we have here.

    Our QFX accepts the following configuration, 'family ethernet-switching' and 'family inet' on the same interface.

     

    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    unit 0 {
        family ethernet-switching {
            interface-mode trunk;
            vlan {
                members [ couple of VLANs ];
            }
        }
    }
    unit 10 {
        vlan-id 10;
        family inet {
            address x.x.x.x/30;
        }
    }
    

    After configuring unit 10, but then for 2 different VLANs, the 'family ethernet-switching' portion doesn't work anymore.

     

    So what I'm asking is, can the 'family ethernet-switching' and 'family inet' familes coexist on the same interface?

     

    Beelze



  • 4.  RE: QFX5100 - mixing families

     
    Posted 02-07-2019 06:46

    Hi Beeelzebub,

     

    What's the Junos version on your QFX5100? From the reference links:

     

    "On QFX5100 switches, you can combine encapsulations on the same physical interface for vlan-bridge and family ethernet switching. Starting with Junos OS Release 16.1R6, you can also combine encapsulations on the same physical interface for family inet and family ethernet-switching."

     

    Hope this helps.

     

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).



  • 5.  RE: QFX5100 - mixing families

    Posted 02-07-2019 07:57

    Hi -r,

     

    beelze@qfx5100-nkh-01> show version

    fpc0:

    --------------------------------------------------------------------------

    Hostname: qfx5100-nkh-01

    Model: qfx5100-48s-6q

    Junos: 14.1X53-D45.3



  • 6.  RE: QFX5100 - mixing families

     
    Posted 02-07-2019 17:27
    Hi Beeelzebub,

    That explains. The feature you're using (combining families) isn't supported on Junos 14.1X53. If that worked before, it may have worked in error. To make changes that you're trying to work reliably, please upgrade to one of the JTAC recommended software later than Junos 16.1R6: https://kb.juniper.net/InfoCenter/index?page=content&id=KB21476

    Reference: https://www.juniper.net/documentation/en_US/junos/topics/topic-map/switches-interface-flexible.html

    Hope this helps. Please let me know if it does.

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).


  • 7.  RE: QFX5100 - mixing families

    Posted 02-12-2019 05:21

    Hi mriyaz,

     

    Is it written somewhere that combining "family ethernet-switching" and "family inet" on the same interface is not supported?

    I just need to be sure that my QFX5100 switches aren't broken, or that this type of switch has this as a "bug".

     

    Thanks for checking this out!

     

    Beelze



  • 8.  RE: QFX5100 - mixing families

     
    Posted 02-12-2019 17:10

    The feature that allows mixing of family inet and ethernet services is setting the interface to flexible vlan tagging.  This is not supported on all platforms so you will need to see if you can use it.

     

    When you do you won't have all the members on unit 0 but you will need to call out each vlan tag on a separate subinterface.  And also each vlan tag with the family inet ports.

     

    here is a short example:

    root@steve> show configuration interfaces fe-0/0/2 
    flexible-vlan-tagging;
    unit 1 {
        vlan-id 20;
        family inet {
            address 192.168.10.11/31;
        }
    }
    unit 2 {
        vlan-id 30;
        family ethernet-switching;
    }
    unit 3 {
        vlan-id 40;
        family ethernet-switching;
    }
    

    I also think you can do this on devices that have flexible ethernet services as an option, but don't have a box handy to confirm that with.  Try that if flexible vlan tagging is not an option on the qfx5100.

     



  • 9.  RE: QFX5100 - mixing families

    Posted 02-13-2019 00:59

    Hi spuluka,

     

    flexible-vlan-tagging has this descriptions:

    "flexible-vlan-tagging          Support for no tagging, or single and double 802.1q VLAN tagging"

     

    It doesn't say anthing of mixing family inet and ethernet-switching or services.

     

    Take a look at the following, on an ge interface on a qfx5100 with version 14.1X53-D45.3:

     

    flexible-vlan-tagging;
    encapsulation flexible-ethernet-services;
    unit 0 { vlan-id 10; family inet; ## ## Warning: Family ethernet-switching and rest of the families are mutually exclusive ## family ethernet-switching { interface-mode trunk; vlan { members vlan-8; } } } unit 20 { vlan-id 20; family inet { address 192.168.10.11/31; } }

    Apparantly the switch does not pass a configuration when using family inet and ethernet-switching under the same unit / logical interface.

     

     

    Here I set flexible-vlan-tagging / flexible-ethernet-switching and on unit 0 i set VLAN 10 and below under ethernet-switching a trunk port with two members, vlan-8 and vlan-9. I also set family inet under unit 0.

     

    It does, however, not fail on unit 20? Because that is where it went wrong.

    Adding the unit 20 would have broken the switch capabilities of the port.

     

    Would above configuration pass the test when the JunOS version is above 16.1R6?\

     

    Beeelze

     

     

     



  • 10.  RE: QFX5100 - mixing families

     
    Posted 02-13-2019 02:55

    Hi Beeelzebub,

     

    Thanks for sharing the config.  This config doesn't commit post Junos 16.1 too.  And it doesn't commit whichever unit (0 or otherwise) combines "inet+ethernet-switching", irrespective of whether we have a single unit or multiple units on the interface.  Please see sample commit check below.

     

    We can mix the interface families on the same interface but on different units to get different logical/sub-interfaces.  And mixing families on different logical interfaces should achieve the purpose. 

     

    The interface wouldn't route and switch on the same logical interface.  What's the idea of combining inet/ethernet-switching on the same unit? And on which code did that commit work earlier? If it's just that it was working earlier and commit doesn't go through now, then at best, the commit would have been allowed in error.  If you know the old Junos version, we can easily validate that.

     

    **************************************************

    {master:0}[edit]

    root@R4# show | compare

    [edit interfaces]

    +   xe-0/0/7 {

    +       flexible-vlan-tagging;

    +       encapsulation flexible-ethernet-services;

    +       unit 0 {

    +           vlan-id 10;

    +           family inet;

    +           family ethernet-switching {

    +               interface-mode trunk;

    +               vlan {

    +                   members vlan-8;

    +               }

    +           }

    +       }

    +       unit 20 {

    +           vlan-id 20;

    +           family inet {

    +               address 192.168.10.11/31;

    +           }

    +       }

    +   }

     

    {master:0}[edit]

    root@R4# commit check

    [edit interfaces xe-0/0/7 unit 0 family]

      'ethernet-switching'

        Family ethernet-switching and rest of the families are mutually exclusive

    [edit protocols]

      'bgp'

        warning: requires 'bgp' license

    [edit protocols]

      'isis'

        warning: requires 'isis' license

    error: configuration check-out failed: (statements constraint check failed)

     

    {master:0}[edit]

    root@R4# show interfaces xe-0/0/7 | display set

    set interfaces xe-0/0/7 flexible-vlan-tagging

    set interfaces xe-0/0/7 encapsulation flexible-ethernet-services

    set interfaces xe-0/0/7 unit 0 vlan-id 10

    set interfaces xe-0/0/7 unit 0 family inet

    set interfaces xe-0/0/7 unit 0 family ethernet-switching interface-mode trunk

    set interfaces xe-0/0/7 unit 0 family ethernet-switching vlan members vlan-8

    set interfaces xe-0/0/7 unit 20 vlan-id 20

    set interfaces xe-0/0/7 unit 20 family inet address 192.168.10.11/31

     

    {master:0}[edit]

    root@R4# delete interfaces xe-0/0/7 unit 0 family inet

     

    {master:0}[edit]

    root@R4# commit check

    [edit protocols]

      'bgp'

        warning: requires 'bgp' license

    [edit protocols]

      'isis'

        warning: requires 'isis' license

    configuration check succeeds

     

    {master:0}[edit]

    root@R4# set interfaces xe-0/0/7 unit 20 family ethernet-switching

     

    {master:0}[edit]

    root@R4# show | compare

    [edit interfaces]

    +   xe-0/0/7 {

    +       flexible-vlan-tagging;

    +       encapsulation flexible-ethernet-services;

    +       unit 0 {

    +           vlan-id 10;

    +           family ethernet-switching {

    +               interface-mode trunk;

    +               vlan {

    +                   members vlan-8;

    +               }

    +           }

    +       }

    +       unit 20 {

    +           vlan-id 20;

    +           family inet {

    +               address 192.168.10.11/31;

    +           }

    +           family ethernet-switching;

    +       }

    +   }

     

    {master:0}[edit]

    root@R4# commit check

    [edit interfaces xe-0/0/7 unit 20 family]

      'ethernet-switching'

        Family ethernet-switching and rest of the families are mutually exclusive

    [edit protocols]

      'bgp'

        warning: requires 'bgp' license

    [edit protocols]

      'isis'

        warning: requires 'isis' license

    error: configuration check-out failed: (statements constraint check failed)

     

    {master:0}[edit]

    root@R4# delete interfaces xe-0/0/7 unit 20

     

    {master:0}[edit]

    root@R4# set interfaces xe-0/0/7 unit 0 family inet                     

     

    {master:0}[edit]

    root@R4# show | compare

    [edit interfaces]

    +   xe-0/0/7 {

    +       flexible-vlan-tagging;

    +       encapsulation flexible-ethernet-services;

    +       unit 0 {

    +           vlan-id 10;

    +           family inet;

    +           family ethernet-switching {

    +               interface-mode trunk;

    +               vlan {

    +                   members vlan-8;

    +               }

    +           }

    +       }

    +   }

     

    {master:0}[edit]

    root@R4# commit check

    [edit interfaces xe-0/0/7 unit 0 family]

      'ethernet-switching'

        Family ethernet-switching and rest of the families are mutually exclusive

    [edit protocols]

      'bgp'

        warning: requires 'bgp' license

    [edit protocols]

      'isis'

        warning: requires 'isis' license

    error: configuration check-out failed: (statements constraint check failed)

     

    {master:0}[edit]

    root@R4# run show version

    fpc0:

    --------------------------------------------------------------------------

    Hostname: R4

    Model: qfx5100-48s-6q

    Junos: 18.3R1.9

    **************************************************

     

    Hope this helps.

     

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).



  • 11.  RE: QFX5100 - mixing families

     
    Posted 02-13-2019 03:08

    Thanks for testing on the QFX.  I've only ever mixed layer 2/3 like this on MX and SRX before.

    I know it didn't work on the EX platforms we tried to use as well.

     

    So I wasn't sure what other platforms allowed the mixing or not.

     



  • 12.  RE: QFX5100 - mixing families

    Posted 02-13-2019 03:42

    mriyaz,

     

    Thanks for testing indeed.

    If I had a QFX5100 spare, then I would not have to ask you 😞

     

    We can mix the interface families on the same interface but on different units to get different logical/sub-interfaces.  And mixing   

    families on different logical interfaces should achieve the purpose. 

     

    Yes, that's exactly what I did a couple of weeks ago. But then, somehow, the ethernet-switching stopped working.

    I'm not trying to mix the familes on the SAME UNIT, but on DIFFERENT UNITS.

     

    And THAT is apparantly what broke the ethernet-switching portion:

     

    flexible-vlan-tagging;

    encapsulation flexible-ethernet-services;

    unit 0 {

        family ethernet-switching {

            interface-mode trunk;

            vlan {

                members [ vlan-4 voice-vlan7 esxi-server vlan-60 ];

            }

        }

    }

    unit 10 {

        vlan-id 10;

        family inet {

        }

    }

     

     

    I want to know if my QFX is broken, but i'm almost 100% sure it is not.

    I think it's also best practice to either configure the port with ethernet-switching (switch port) or with vlan-bridging/family inet (router port). All this combining of families is never good I think.

    I hope I can convince management the switch is not broken for this matter.

     

    Beelze



  • 13.  RE: QFX5100 - mixing families

     
    Posted 02-14-2019 00:38
    Hi Beelze,

    You're welcome and thanks for confirming you were trying the different families on different units. That is exactly what is supported post Junos 16.1R6 on QFX5100s, with a caveat that family ethernet-switching should be configured only on unit 0.

    Reference: https://www.juniper.net/documentation/en_US/junos/topics/topic-map/switches-interface-flexible.html

    "On QFX5100 switches, you can combine encapsulations on the same physical interface for vlan-bridge and family ethernet switching. Starting with Junos OS Release 16.1R6, you can also combine encapsulations on the same physical interface for family inet and family ethernet-switching."

    Your QFX should be fine and you can quote the above to explain the behavior. If this config is still desired, consider upgrading to the latest JTAC recommended Junos for QFX5100:
    https://kb.juniper.net/InfoCenter/index?page=content&id=kb21476


    Hope this helps.

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).