Switching

Expand all | Collapse all

Upgrade firmware to Ex2300

Jump to Best Answer
  • 1.  Upgrade firmware to Ex2300

    Posted 09-16-2019 14:01

    Current firmware: 

    Hostname: JUNO-B1
    Model: ex2300-24t
    Junos: 15.1X53-D57.3

    --- JUNOS 15.1X53-D57.3 Kernel 32-bit JNPR-11.0-20170825.354680_build


    Want to upgrade to 18.4.R2

    >request system software validate /tmp/image2.tgz  fails with error:

    validation fails on:

    Validating against /config/juniper.conf.gz

    This is the output error:

    .....

    Hardware Database regeneration succeeded
    Validating against /config/juniper.conf.gz
    Chassis control process: <xnm:error xmlns="http://xml.juniper.net/xnm/1.1/xnm" xmlns:xnm="http://xml.juniper.net/xnm/1.1/xnm">
    Chassis control process: <source-daemon>chassisd</source-daemon>
    Chassis control process: <edit-path>[edit interfaces]</edit-path>
    Chassis control process: <statement>xe-0/1/1</statement>
    Chassis control process: <message>INTERFACES_TYPE_UNIDIR: Error in parsing interface name</message>
    Chassis control process: </xnm:error>
    mgd: error: configuration check-out failed
    Validation failed

     

     

     



  • 2.  RE: Upgrade firmware to Ex2300
    Best Answer

     
    Posted 09-16-2019 18:47

    Hi Ivugrinec, jumping over more than 2 main releases is not supported. Also, 15 and 18.4 codes have major changes, instead try to move first to: 15.1X53-D58 or 15.1X53-D590, and then move to 18.2 before getting to 18.4.

     

    See:

    https://www.juniper.net/documentation/en_US/junos/topics/topic-map/upgrading-and-downgrading-to-upgraded-bsd.html

    ""You can skip no more than two releases when upgrading (or downgrading). That means you can upgrade only to one of the three releases subsequent to your current release. If you want to upgrade across more releases than this, you need to perform multiple upgrades.""



  • 3.  RE: Upgrade firmware to Ex2300

     
    Posted 09-16-2019 19:09

    The 2 release jump limitation, is more or less precautionary.  The jump should actually work, but are you sure you have the right EX2300 image?  I think you would be best to land on (at least right now) 18.2R3-S1.  The image name should have "arm" in it.  The image I found for EX2300 (includes -C and EX3400 as well) looks like this:

     

    https://cdn.juniper.net/software/junossr/18.2R3-S1.7/junos-arm-32-18.2R3-S1.7.tgz?SM_USER=rmcgovern&__gda__=1568686764_5e9150fea13f7b11a11cc00f896c451a

     

    I suspect you are not using an EX2300 image, and the reason why xe-0/1/1 is not valid in the config.  No idea what your /tmp/image2.tgz is???

     

    You should also look at this KB - https://kb.juniper.net/InfoCenter/index?page=content&id=KB31201&actp=METADATA

     

    Good luck



  • 4.  RE: Upgrade firmware to Ex2300

    Posted 09-17-2019 03:08

    The solution was not to jump from current firmware directly to 18.4R2. I had to go step by step. First i updated to 15.1X53-D590 and then to 18.4R2.

    Everything wen't smoothly this way.