Switching

Expand all | Collapse all

EX4300 QinQ Trunk Port's

Jump to Best Answer
  • 1.  EX4300 QinQ Trunk Port's

    Posted 02-10-2020 05:23

    Attempting to setup and test for upcoming solution we will implement to pass customer traffic between EX4300 switches.

    I have two switches virtual stacked on either side of the link.  The EX4300 connect via LACP on ae1.

    On both sides of the link I have two cisco switches connected to ge-0/0/2.

    Setup is identical on both sides but I can only pass traffic between the cisco devices if their ports are configured at access ports.

    Attempting to get this working as well with the cisco ports being trunk ports is this possible?

    One odd thing I have noticed when both cisco devices are setup as trunk ports they still are able to see each other via CDP as I can clear the table and it generates again...

     

    Below is the set I have.

    Customer Interface
    ge-0/0/2 {
    flexible-vlan-tagging;
    native-vlan-id 10;
    encapsulation extended-vlan-bridge;
    unit 10 {
    vlan-id 10;
    input-vlan-map push;
    output-vlan-map pop;
    }
    }
    LACP Interface
    ae1 {
    flexible-vlan-tagging;
    native-vlan-id 10;
    encapsulation extended-vlan-bridge;
    aggregated-ether-options {
    lacp {
    active;
    periodic fast;
    }
    }
    unit 10 {
    vlan-id 10;
    }
    }
    VLAN config
    v10 {
    interface ae1.10;
    interface ge-0/0/2.10;
    }



  • 2.  RE: EX4300 QinQ Trunk Port's
    Best Answer

    Posted 02-10-2020 17:10

    Hi there,

     

    what is the vlan ID you are passing through? this should be possible we have been working recently on this KB I have tested this many times try to follow this one:

     

    KB33838

     



  • 3.  RE: EX4300 QinQ Trunk Port's

     
    Posted 02-10-2020 23:00

    Hi mmawhinney360,

     

    The extended-vlan-bridge is meant to work with 802.1Q tags.  I think you'd need to do without the native-vlan-id in the configuration. 

     

    Just a guess based on your description, although the connection isn't entirely clear to me, perhaps a line diagram will help if the above doesn't resolve.

     

     

    Hope this helps.

    Regards,
    -r.

    --------------------------------------------------

    If this solves your problem, please mark this post as "Accepted Solution."
    Kudos are always appreciated :).



  • 4.  RE: EX4300 QinQ Trunk Port's

    Posted 02-11-2020 05:34
      |   view attached

    Tried to remove the native-vlan-id and still no go.

    Basically I want to take any packets coming from a 'customer' in my test setup to the EX4300 ge0/0/2 and add a S-VLAN tag to it send it across the ae1 to the other EX4300 and back out the ge0/0/2 with the S-VLAN tag removed.  Sounds so simply but haven't had much luck.

    The cisco ports are configured as trunk ports and allow vlan 30 & 40.

     

    interface GigabitEthernet1/0/1
    switchport trunk allowed vlan 30,40
    switchport mode trunk

    However the only way my setup has worked so far is to have the packets come from the cisco switches with native vlan specified which would mean it is not even tagged to start with..  In the actual production setup customers will mostly all come in with via tunnels and some via access...

    For instance if I set vlan 30 to native on the cisco switches I can ping between vlans and it works but vlan 40 doesn't.

    If I switch the native vlan to 40 then only vlan 40 passed not vlan 30...

    I need all traffic on the trunk to pass through ge0/0/2 get a tag added traverse the ae1 and come back out ge0/0/2 with the extra tag removed.  



  • 5.  RE: EX4300 QinQ Trunk Port's

    Posted 02-11-2020 11:06

    Hi Mmawhinney360,

     

    To me it looks like you want to do some sort of QinQ tunneling on the EX4300, this should allow you to add an outer tag to the original L2 header for transmission, and the tag will be removed out of the tunnel preserving the orginal tag, either 30 or 40 for later connectivity. 

     

    If setting a native VLAN resolves the problem for one VLAN and not the other, this would be kind of expected, and possibly and configuration error, if you need more information about the QinQ feel free to update the post.

     

    also you can review the next document:

     

    Configuring Q-in-Q Tunneling and VLAN Q-in-Q Tunneling and VLAN Translation

    https://www.juniper.net/documentation/en_US/junos/topics/topic-map/q-in-q.html