Switching

Expand all | Collapse all

Strange password issue after upgrade

Jump to Best Answer
  • 1.  Strange password issue after upgrade

    Posted 08-12-2019 05:44

    EX2300-48P

    Upgrading thru SPACE

     

    From 15.1X53-D58.3

    TO   18.1R2

     

    When completed for several switches they are NOT up in SPACE. I needed to delete the one out of 3 switches upgraded,

    and readd them. The switches are pingable.

     

    HERE IS THE RUB:

     

    When I tried to log into one switch no password would work for any user ID, not even root.

    I had to go to the switch with a console cable and was able to login as root.

     

    None of the 5 users were in the system-users- login area.

    I had to rebuild each of them.  Have any of you seen this before.?



  • 2.  RE: Strange password issue after upgrade

     
    Posted 08-12-2019 06:48

    I have seen this before with root only, not with other users.

     

    Add the following line either way and test again.

     

    set system services ssh root-login allow



  • 3.  RE: Strange password issue after upgrade
    Best Answer

     
    Posted 08-12-2019 06:48

    ssh as root requires 'set system services ssh root-login allow' with 17 and later. I don't know why the other users woudl be missing.



  • 4.  RE: Strange password issue after upgrade

    Posted 08-12-2019 08:13

    I am sure we have that, because before the upgrade it was there, so if it is because of the upgrade, then thanks I will research more.