Switching

 View Only
last person joined: 2 days ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  Trunk VLANS on EX4300 Uplink Port Configuration

    Posted 04-13-2018 08:54

    Hey all,

     

    This is my first Juniper switch and I've done a lot of learning the last couple of days. I have worked with Adtran and cisco switches in the past. 

     

    I have 2 EX4300 switches configured in virtual chasis. the Master switch is connected to an EdgeRouter that is supplying the L3 VLANS like so:

     

       #EdgeRouter Configuration
    ethernet eth1 { description "LAN" duplex auto speed auto vif 2 { address 10.10.0.1/22 } vif 3 { address 10.10.4.1/22 } vif 4 { address 10.10.6.1/24 } vif 5 { address 10.10.7.1/24 } vif 10 { address 10.10.10.1/24 }

    I want to trunk all these VLANS to the EX4300, but having trouble configuring the Uplink port. The EX4300 should be part of vlan 2 and have a management address of 10.10.0.2. On my old Adtran, I had to configure it's own uplink VLAN on the switch and assign the uplink port that VLAN. Seems like this would be an easy thing to do... My current EX4300 uplink port configuration looks like this:

     

    #Set Uplink Port
    set interfaces ge-0/0/23 unit 0 family ethernet-switching port-mode trunk
    set interfaces ge-0/0/23 unit 0 family ethernet-switching vlan members vlan2
    set interfaces ge-0/0/23 unit 0 family ethernet-switching vlan members vlan3
    set interfaces ge-0/0/23 unit 0 family ethernet-switching vlan members vlan4
    set interfaces ge-0/0/23 unit 0 family ethernet-switching vlan members vlan5
    set interfaces ge-0/0/23 unit 0 family ethernet-switching vlan members vlan10
    set interfaces ge-0/0/23 native-vlan-id 2
    
    #Setup Static Route to EdgeRouter
    set routing-options static route 0.0.0.0/0 next-hop 10.10.0.1
    
    #Setup Vlans
    set vlans vlan2 vlan-id 2
    set vlans vlan3 vlan-id 3
    set vlans vlan4 vlan-id 4
    set vlans vlan5 vlan-id 5
    set vlans vlan10 vlan-id 10
    
    #Set management address
    set interfaces vme unit 0 family inet address 10.10.0.2
    
    

    I'm not sure how I should setup the management interface. Documentation says I should assign it to the virtual chasis interface, but on my Adtran switches, I would assign an address to the vlan 2 interface. I think this is where my problem is.

     

    Any help is grealty appreciated! 



  • 2.  RE: Trunk VLANS on EX4300 Uplink Port Configuration

     
    Posted 04-14-2018 11:51

    Hi,

     

    I am little confused with your requirement. But i beilive you are looking for a connectvity through vlan2 and would like to use it for switch management. 

    In this case you may assign an IP address on vlan2 and that should serve your purpose. But it wont be an outofband connectviity , for that you may need to configure that through VME itself.

     

    set vlans vlan2 l3-interface irb.2

    set interfaces irb unit 2 family inet address 10.10.0.2/22 

     

    Hope this helps.

     

    Regards,

    Ajo Thomas



  • 3.  RE: Trunk VLANS on EX4300 Uplink Port Configuration

    Posted 04-17-2018 10:23

    Thanks for your repsonse. I guess my requirement would be to be able to ping the switch from my router and then trunk all vlans. I've made the two changes that you had pointed out to me and I'm still unable to ping the switch from the route or vice-versa. My irb interface now looks like this:

     

    irb {                               
            unit 0 {                        
                family inet {               
                    dhcp {                  
                        vendor-id Juniper-ex4300-24t;
                    }                       
                }                           
            }                               
            unit 2 {                        
                family inet {               
                    address 10.10.0.2/22;  
                }                           
            }                               
        }                

    Vlan 2 interface looks like this:

        vlan2 {                    
            vlan-id 2;                      
            l3-interface irb.2;             
        } 

    I've changed the vme interface to use the address 10.10.0.3 like so:

     

        vme {                               
            unit 0 {                        
                family inet {               
                    address 10.10.0.3/22;  
                }                           
            }                               
        }


  • 4.  RE: Trunk VLANS on EX4300 Uplink Port Configuration
    Best Answer

    Posted 04-17-2018 12:25

    I was able to figure this out. I do indeed need to configure an uplink VLAN (or use the default vlan) and assign it to the uplink port like so:

     

    set interfaces ge-0/0/23 native-vlan-id 1000  
    set interfaces ge-0/0/23 unit 0 family ethernet-switching vlan members 1000

    After doing this, I am able to ping the irb.2 interface from my router. Thanks for the help!