Switching

 View Only
last person joined: 17 hours ago 

Ask questions and share experiences about EX and QFX portfolios and all switching solutions across your data center, campus, and branch locations.
  • 1.  EX Series vlan members and vlan-range simultaneously

    Posted 02-27-2018 03:41

    Hello, dear community.

    Is there any way around this restriction? It is necessary to use a range and individual members on different interfaces.

     

    12.3R12-S8.1

     

    range_1 {
    vlan-range 4-75;
    }
    
    
    
    show interfaces xe-0/0/16
    unit 0 {
    family ethernet-switching {
    vlan {
    members vlan30;
    }
    }
    
    
    
    show interfaces ae27
    aggregated-ether-options {
    link-speed 1g;
    lacp {
    active;
    periodic slow;
    }
    }
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members [ range_1 ];
    }
    }
    
    
    
    commit check
    error: tag value 30 is being used by more than one vlan <__range_1_30__> and <vlan30>
    error: configuration check-out failed

     



  • 2.  RE: EX Series vlan members and vlan-range simultaneously

     
    Posted 02-27-2018 05:02

    You are receiving the error because you are trying to config interface xe-0/0/16 specifically to be a member of VLAN30 (I assume vlan-id 30) as well as make it via the range a trunk and a member VLAN-ID, 4-75 (which includes VLAN30, I assume).  Depending upon what you want, you could either exclude xe-0/0/16 from range_1, or not specifically configure xe-0/0/16 with VLAN30.

     

    The former would make xe-0/0/16 an access (non-Trunk, non-802.1q) interface being a member of VLAN30, the latter would be xe-0/0/16 becomes both a trunk and a member of 4-75 via range_1.

     

    Hopefully this helps.



  • 3.  RE: EX Series vlan members and vlan-range simultaneously

    Posted 02-27-2018 07:27

    But xe-0/0/16 port is not included in the range_1, this is seen in the config above.

    I do not use the range in xe-0/0/16 interface, I use it on ae27 and other.

     

    On xe-0/0/16 I need separate members (example: members vlan8, vlan13, vlan11, vlan122, vlan161, vlan229 and etc), BUT NOT ALL RANGES or all members.

     

    But this does not accept the configuration, how else are the options?

     

    My range's:

    range_1 {
    vlan-range 4-75;
    }
    range_2 {
    vlan-range 76-132;
    }
    range_3 {
    vlan-range 133-180;
    }
    range_4 {
    vlan-range 181-252;
    }
    
    
    
    ae27 {
    aggregated-ether-options {
    link-speed 1g;
    lacp {
    active;
    periodic slow;
    }
    }
    unit 0 {
    family ethernet-switching {
    port-mode trunk;
    vlan {
    members [ range_1 range_2 range_3 range_4 ];
    }
    }
    }
    
    
    
    show | compare
    [edit interfaces xe-0/0/16 unit 0 family ethernet-switching]
    + vlan {
    + members vlan30;
    + }
    [edit vlans]
    + vlan30 {
    + vlan-id 30;
    + }
    show interfaces xe-0/0/16

    unit 0 {
    family ethernet-switching {
    vlan {
    members vlan30;
    }
    }
    }
    commit check error: tag value 30 is being used by more than one vlan <__range_1_30__> and <vlan30> error: configuration check-out failed

     



  • 4.  RE: EX Series vlan members and vlan-range simultaneously

     
    Posted 02-27-2018 11:33

    The vlan-range command is essentially creating the vlan definitions. You can't define two different vlans with the same tag.

     

    Can you configure xe-0/0/16 to use the member called __range_1_30__ ? This is the individual vlan created by the range command.



  • 5.  RE: EX Series vlan members and vlan-range simultaneously

    Posted 02-28-2018 06:06

    If you mean like this, then it also does not work.

    set vlans range_1_30 vlan-range 30-30
    
    commit check
    error: tag value 30 is being used by more than one vlan <__range_1_30_30__> and <__range_1_30__>
    error: configuration check-out failed

     



  • 6.  RE: EX Series vlan members and vlan-range simultaneously

     
    Posted 02-28-2018 08:37

    No, I mean use the vlan already created by the range command:

     

    set interfaces xe-0/0/16 unit 0 family ethernet-switching vlan members __range_1_30__
    

    That said, I just tried on a test box and I get a commit failure.

     

     

    set interfaces ge-0/0/0 unit 0 family ethernet-switching interface-mode trunk
    set interfaces ge-0/0/0 unit 0 family ethernet-switching vlan members test
    set interfaces ge-0/0/1 unit 0 family ethernet-switching vlan members test-vlan-1005
    set vlans test vlan-range 1000-1010
    test@test# commit check 
    error: vlan test-vlan-1005 configured under interface ge-0/0/1.0 is an internal vlan
    error: configuration check-out failed