Switching

Expand all | Collapse all

SFP+/SFP module not recognized on EX2300

Jump to Best Answer
  • 1.  SFP+/SFP module not recognized on EX2300

    Posted 09-01-2020 09:08

    I have two switches (1 EX2300-48P and 1 EX2300-24P)  that I am bench testing for an upcoming deployment. I have 2 non-Juniper SFP+/SFP modules connected between them. The 48 port switch sees the hardware and creates the appropriate interface but the 24 port switch does not.

    > show chassis hardware detail
    Hardware inventory:
    Item             Version  Part number  Serial number     Description
    Chassis                                                  EX2300-48P
    Pseudo CB 0
    Routing Engine 0          BUILTIN      BUILTIN           RE-EX2300-48P
      flash/sp     8 MB                                      Virtio Block Disk
      da0    1910 MB  USB                  650005E6E5CB4124  Virtio Block Disk
      usb0 (addr 0.1) EHCI root HUB 0      Broadcom          uhub0
      usb1 (addr 0.2) USB2.0 Hub 1544      vendor 0x05e3     uhub1
      usb2 (addr 0.3) USB DISK 2.0 16640   vendor 0x13fe     umass0
    FPC 0            REV 19   650-059961                     EX2300-48P
      CPU                     BUILTIN      BUILTIN           FPC CPU
      PIC 0          REV 19   BUILTIN      BUILTIN           48x10/100/1000 Base-T
      PIC 1          REV 19   650-059961                     4x10G SFP/SFP+
        Xcvr 1                NON-JNPR     AQK02SA           DUAL-SFP+-SR/SFP-SX
    Power Supply 0                                           JPSU-850W-AC-AFO
    

     

    I thought there might be a problem with the specific port I was plugging into the on the 24 port switch but neither one of the 4 ports work.  I then thought there was a problem with the SFP module but when I swapped the 48 & the 24, the 48 can see the new module.

    > show chassis hardware detail
    Hardware inventory:
    Item             Version  Part number  Serial number     Description
    Chassis                                                  EX2300-48P
    Pseudo CB 0
    Routing Engine 0          BUILTIN      BUILTIN           RE-EX2300-48P
      flash/sp     8 MB                                      Virtio Block Disk
      da0    1910 MB  USB                  650005E6E5CB4124  Virtio Block Disk
      usb0 (addr 0.1) EHCI root HUB 0      Broadcom          uhub0
      usb1 (addr 0.2) USB2.0 Hub 1544      vendor 0x05e3     uhub1
      usb2 (addr 0.3) USB DISK 2.0 16640   vendor 0x13fe     umass0
    FPC 0            REV 19   650-059961                     EX2300-48P
      CPU                     BUILTIN      BUILTIN           FPC CPU
      PIC 0          REV 19   BUILTIN      BUILTIN           48x10/100/1000 Base-T
      PIC 1          REV 19   650-059961                     4x10G SFP/SFP+
        Xcvr 1                NON-JNPR     APQ2U0N           DUAL-SFP+-SR/SFP-SX
    Power Supply 0                                           JPSU-850W-AC-AFO
    

     

    What am I missing here? 



  • 2.  RE: SFP+/SFP module not recognized on EX2300

    Posted 09-01-2020 11:19

    Are both switches running the same Junos version?

     

    Any indications i /var/log/messages or /var/log/chassisd when inserting the transceiver?

     

    P.S. You have posted output for your EX2300-48P twice - so please provide output from your 24P model as well 🙂



  • 3.  RE: SFP+/SFP module not recognized on EX2300

    Posted 09-01-2020 11:42

    Both switches are running 18.2R3-S5.3. I didn't include the output for the 24 because it didn't show anything but here you go.

    Switch24P# run show chassis hardware detail
    Hardware inventory:
    Item             Version  Part number  Serial number     Description
    Chassis                                                  EX2300-24P
    Pseudo CB 0
    Routing Engine 0          BUILTIN      BUILTIN           RE-EX2300-24P
      flash/sp     8 MB                                      Virtio Block Disk
      da0    1910 MB  USB                  650005B294AB3B04  Virtio Block Disk
      usb0 (addr 0.1) EHCI root HUB 0      Broadcom          uhub0
      usb1 (addr 0.2) USB2.0 Hub 1544      vendor 0x05e3     uhub1
      usb2 (addr 0.3) USB DISK 2.0 16640   vendor 0x13fe     umass0
    FPC 0            REV 21   650-059968                     EX2300-24P
      CPU                     BUILTIN      BUILTIN           FPC CPU
      PIC 0          REV 21   BUILTIN      BUILTIN           24x10/100/1000 Base-T
      PIC 1          REV 21   650-059968                     4x10G SFP/SFP+
    Power Supply 0                                           JPSU-450W-AC-AFO
    

     

    I'm not seeing anything in chassisd but I'm seeing something what looks like STP topology changes downstream (ge-0/0/23) when I last reinserted the SFP for port ge-0/1/0

    Sep 1 08:10:05 Switch24P l2cpd[10715]: Root bridge in routing-instance 'default' changed from 20480:3c:8a:b0:18:27:41 to 32768:50:c7:09:a4:64:a5
    Sep 1 08:10:36 Switch24P l2cpd[10715]: Root bridge in routing-instance 'default' changed from 32768:50:c7:09:a4:64:a5 to 20480:3c:8a:b0:18:27:41
    Sep 1 08:10:36 Switch24P l2cpd[10715]: ROOT_PORT: for Instance 0 in routing-inst ance default Interface ge-0/0/23.0
    Sep 1 08:10:36 Switch24P l2cpd[10715]: TOPO_CH: for Instance 0 in routing-instan ce default received on port ge-0/0/23.0
    Sep 1 08:10:38 Switch24P l2cpd[10715]: TOPO_CH: for Instance 0 in routing-instan ce default received on port ge-0/0/23.0



     

     

     



  • 4.  RE: SFP+/SFP module not recognized on EX2300
    Best Answer

    Posted 09-02-2020 08:04

    False issue. The actual switch I was plugging in the SPF module into was a 3rd switch in the test stack. Once I plugged it into the correct switch, it came right up. One of the challenges of working at home in a COVID environment I guess is to verify which switch your colleague is plugging stuff into for you.

     

    Issue resolved.